FRIHOST • FORUMS • SEARCH • FAQ • TOS • BLOGS • COMPETITIONS
You are invited to Log in or Register a free Frihost Account!

Debian 9 Stretch wifi network no working




I ‘ ve installed Debian 9 Stretch and wasn‘t able to connect to my WiFi network, even with LAN connection it works fine. I installed all wifi drivers and checked previously that the hardware is ok, the router is ok, but at some point, still, the wifi connection is no working at all. It keeps connecting and disconnecting from the network, and it’s impossible to access the Internet.

Did anyone have similar experience happening with Debian 9? Any help on to this will be extremely appreciated.

Thanks and regards



4 blog comments below

This would probably attract more attention in the computer problems and support forum. Other places you might look are the official Debian forums, or the stackexchange linux forum.

You will probably need to find what hardware chip your computer uses, using the command lspci or similar, in order to get detailed help. There may be a bug report and a workaround for the problem, look around at existing answers first.

Welcome to Frihost, by the way. We're not as specialized as the OS specific sites, but there are some friendly technical people here who would be glad to assist you in your search.
SonLight on Wed Oct 25, 2017 4:22 pm
I installed Debian 9 on a refurbished laptop (Lenovo ThinkPad T400) that I bought a few weeks ago. In order to make the wifi work I was forced to install the firmware-iwlwif [non-free] package. Since then the wifi network has worked flawlessly without any problems.

Your hardware is probably different so the solution to your problem is probably different as well.
Peterssidan on Sat Oct 28, 2017 12:43 pm
Hi I am using Debian 9 too but didn't have that problem but I found some solution you might want to take a look at to solve your issue.

https://www.youtube.com/watch?v=eUnfVG7Zst0
jestoy0514 on Sat Oct 28, 2017 5:16 pm
thanks for all your advice, I m new to the forum. I 'm going to try to follow your tutorial and see if I can fix internet wifi, or make a fresh reinstall of Debian 9, cause is taking too long to fix this error or drivers issue. I 've also looked at the official Debian forum for similar topics and can't fix it. I wonder if I can answer to all the posts in general or can answer to each of them directly.

Thanks and Regards
pipecort on Mon Oct 30, 2017 9:04 pm



FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.