FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!

Working with qmail -1




Today I had a major problem with Qmail, for one of our servers.
It was giving an error in the log (maillog) :-
mail X-Antivirus-MYDOMAIN-1.25-st-qms:
and Unable to open pipe to /var/qmail/bin/qmail-queue [16777215] (#4.3.0) - Broken pipe

I don't know too much about qmail. I had just inherited from the guy who left, who was the linux administrator, so this was all chinese to me.
Fortunately google came to the rescue, and after about an hour of searching, and rebooting the machine, I found what could be the answer.
The answer was int he /var/qmail/queue folder, which had the permissions set to something else.
I think I inadvertently did this, when I was setting permissions for another directory, but didnt change it properly.
Fortunately, from the site, I found what permissions needed to be set, set it, restarted the server, and wallah, it started working.
I was so relieved, because it is for a major client, and who gets cranky, most of the time.



3 blog comments below

Congrats on getting qmail working again. Sometimes people make those mistakes and do not realize it for days, but at least you got it taken care of and it sounds like without to much difficulty. Good job.
pauline123 on Wed Aug 08, 2012 7:11 pm
Hi Pauline, thanks for the wishes and compliments, but really, I'm not really an expert on these things, but I have to rack my brains and get around it all, and sometimes it all works out.
I guess I have a technical angel somewhere around me. Laughing
menino on Sun Aug 12, 2012 11:02 am
Perhaps, you are just an expert-in-training? Perhaps you will become the expert that is needed? Or perhaps you do have a technological angel around you. Only time will tell.
pauline123 on Mon Aug 13, 2012 6:05 pm



FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.