FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!

Finally php 5 on server 2!




Yes, I finally upgraded server 2 to php 5 (Version 5.2.4) - which causes all our servers to be php 5 only from now on.

If anyone has problems or questions related to this change, please comment here or post them in the support forums.

I also had to remove the PEAR and LIBXML php options since php didn't want to compile with them. I don't think they were used much, so hopefully this won't cause any problems for the websites/accounts.

The websites on server 2 seem to be much faster now, but that's probably just good luck and not mostly not related to the change, although php 5 is indeed a bit faster than php 4. Very Happy



48 blog comments below

Thanks so much Bondings Very Happy
Its going to be much easier to code for server 2 now, because my localhost will now be the same version as the server! Smile
Manofgames on Fri Sep 07, 2007 6:07 pm
w000t... it happend!!! great news... the book i bought about 3 months ago can finaly help me now xD... ill check out my site in a bit to see whats up with any problems.

edit: Found a problem that I was 99% sure would happen (as it as a heck of a hard time to get to work the first time)
edit: It seems it was really nothing at all, a simply and easy fix.. and i dont think it even had anything to do with php5 GREAT! ^^

PHP 5 on sever 2 has NOT found its first victom.
m-productions on Fri Sep 07, 2007 6:12 pm
Nice work. Smile
Bengt on Fri Sep 07, 2007 7:35 pm
The feedstats no longer work on my wordpress blog,which isnt really an issue as i didnt really need them,but other than thats theres no change.
truespeed on Fri Sep 07, 2007 8:42 pm
Many thanks. I've been able to put a test order through my shopping cart.

Even the coding I've done seems to be working ok!

I did the the feeling the site is running faster too so that's good news.

Is it likely that the frequent Apache restarts will no longer be needed?
GSIS on Fri Sep 07, 2007 9:33 pm
@truespeed, I'll try to recompile it with some more options which might solve your feedstats problem.

@GSIS, I'll be working on that issue and try to make it at least a bit less frequent.
Bondings on Fri Sep 07, 2007 10:13 pm
Hey !
Congrats for the work and thnks for the upgrade !
dacode on Fri Sep 07, 2007 10:25 pm
Truespeed, could you please try again? I re-installed it with new options and I think it should work now.
Bondings on Fri Sep 07, 2007 11:49 pm
Thanks bondings,it works fine now.
truespeed on Sat Sep 08, 2007 1:14 am
You don't know how happy I am - One other question, and thats reguarding mySQL. Sorry if it has already been mentioned but is Server 2 still using mySQL 4 or did you upgrade that as well?
garionw on Sat Sep 08, 2007 2:12 am
I made another post before I saw this, but today I am getting an error when I log into my admin. I am using joomla, here is the error that just started, and no I haven't changed any settings..

Following PHP Server Settings are not optimal for Security and it is recommended to change them:

PHP register_globals setting is `ON` instead of `OFF
Chris24 on Sat Sep 08, 2007 5:39 am
I see no problems whatsoever with php5 on my account. So all seems to be well. My forums were already adapted to it/coded to fit with beforehand anyway I believe. So it's all good. If I encounter any problems I'll just get help with them. Smile

But glad to see that all servers are on php 5 now.
SpellcasterDX on Sat Sep 08, 2007 6:47 am
Quote:
Sorry if it has already been mentioned but is Server 2 still using mySQL 4 or did you upgrade that as well?

It's still mysql 4 and not mysql 5. That's quite a big upgrade though and might cause some problems with mysql queries. At least I had some problems with my own queries. And apparently some phpbb forums don't work with it.

@Chris24, I put register_globals to off. Either it was changed during the upgrade or I forgot to change it till now.
Bondings on Sat Sep 08, 2007 11:57 am
Nice. My other servers all use PHP 5 so this will be very useful!
Dougie1 on Sun Sep 09, 2007 9:54 am
Your "Great Work" give me fortune I just now sent my request for hosting.
Thanks So Much.
the-guide on Sun Sep 09, 2007 11:37 am
every thing is ok now. thanks Rolling Eyes
Carlosus on Sun Sep 09, 2007 9:25 pm
hi, I had some scripts for feeds and now they aren't working. I checked, and it seems because allow_url_include is Off now. Is there a way we can have it On again?
For all the rest, I think PHP 5 is a great update for the site.
Mrs Lycos on Tue Sep 11, 2007 9:57 am
This is one of the great news that I read about frihost improvements .
I am proud to be a member here ...
Frihost is really one of the most stable free hosting service , and this never happen without the great efforts that Bondings is spending .
One of my friends yesterday was very excited that he joined an unlimited free hosting site ( in one of untrustable and support less team ) .
But I am proud and to be be here even I have 1 mb space .
God bless Frihost
alkutob on Tue Sep 11, 2007 9:16 pm
Now with pages that have include() or require_once() I am getting errors.
roboguyspacedude on Thu Sep 13, 2007 9:13 pm
I changed the 'allow_url_include' setting to on. Please check if it works now.
Bondings on Thu Sep 13, 2007 10:36 pm
you're the better!!!
D'Artagnan on Fri Sep 14, 2007 12:59 am
It works alright. Thanks! You're number one hosting!
Mrs Lycos on Fri Sep 14, 2007 9:50 am
yea, it works!!!! Thank you so much for php 5.
roboguyspacedude on Fri Sep 14, 2007 8:54 pm
Holy upgraded servers, Batman!! Twisted Evil This is so sweet! I can now run my perl scripts directly from PHP pages. OMG, i'm just beside myself with programming bliss!!

I love you guys!! Razz
IceCreamTruck on Mon Sep 17, 2007 9:43 pm
Hi Bondings,

Of cause didn't it works at first, and after working hard in several of hours to find out where the problems was, did I took the next step.

I did installed the CMS (e107) into a new directory with same myspl reference and then copied into the old directory and overwrite the old files. After that the most of functions worked, without one single plugin.

Thanks alot for the upgrade, I think that this is makes you a lot more the #1 free hosting service, as far I know doesn't other free hosting services offer PHP5 yet.

Keep on this brilliant working


Cheers!
Rosanova on Tue Sep 18, 2007 10:01 am
I had xoops 2.0.17 working on the server before upgrading but after that few errors appeared and the DB was messed up so i deleted the Xoops installation and tried to install Xoops 2.0.13.2 again but i always get an error message during the installation identifying that all the variables can NOT be inserted in the mainfile.php of the software.

I don't know if the software needs the PEAR or LIBXML options, but it was working fine before the upgrade.

I won't forget that you were the best host i ever found and most comfort to me. Thanks
TrueFact on Sun Sep 23, 2007 12:07 am
@TrueFact, please create a post in the support forums about this. If possible, with the actual error and maybe a link to the page. I'll try to identify the problem and solve it.
Bondings on Sun Sep 23, 2007 12:54 am
Its rather sad...I coudnt wait for 5.0 (as my book is on php 5.0) but becuase it took so long, I went ahead and made my site 4.0 (which still works with 5.0 without some items tho) and now I dont feel like remaking it... -_- ohwell, one day lol.
m-productions on Sun Sep 23, 2007 6:44 am
Already uploaded the version 2.0.17 and worked but still loading slow and sometimes get a blank page from time to time. will post it to the support forums too it is just to keep you informed. Thanks.
TrueFact on Sun Sep 23, 2007 10:03 pm
thanks... Laughing
yeni1 on Mon Oct 01, 2007 3:57 pm
Sigh! I'm thrilled!
I suspect I'll be finding myself spending more time around Frihost these days. You have met my needs once again, and I thank you!
riv_ on Thu Oct 11, 2007 8:12 pm
jsonEncode says its PHP 5.2.0 and up... how come its not supported on this server yet?
Aredon on Thu Oct 11, 2007 10:46 pm
Congrats but i cant even get a server 2 or 3 account only server 1 and i would like server2
biomerocks on Sun Oct 14, 2007 7:05 pm
Thanks a lot for this Bondings.
And as you say, sites on server 2 seems to work faster.
mtorregiani on Sat Oct 20, 2007 5:53 pm
thak you very much php 5!!! thanks
axolotlologo on Fri Nov 16, 2007 12:15 am
Great, i can post my project on then
kelvinwkw on Wed Nov 21, 2007 6:05 pm
this is avery great news... hope it will also upgrade the bandwidth and the webspace as well eheehhehe
AOP Web Development on Sat Dec 01, 2007 8:25 pm
Thank you;

Anyone know a good PHP5 book? I have recently started using PHP and only have access to books on php4... is it worth starting off with a book on php5?
azohoor on Thu Dec 06, 2007 5:03 am
thank Arrow Cool Cool Arrow you
dhthaking on Sun Dec 09, 2007 2:47 am
I think this thread has answered my question. I'm new to this site and wondered if they hosted messageboards as well as your sites. Looks like they do so am really thrilled to be on here!
fiftiesfury on Sat Jul 05, 2008 12:05 pm
the only way to go!
disasters on Thu Jun 04, 2009 6:57 pm
Confused Good ! But I want to know more about PHP5. Very Happy
ordi on Fri Jun 05, 2009 11:24 am
I mean actually, it's good for us to go trought something new and uptodate ! Cool
ordi on Fri Jun 05, 2009 11:27 am
shit have to change the confliciting parts...Sad
jais on Tue Jun 09, 2009 11:52 am
well for the greate good..YEAAAAAAAAAAAAAAAAAAAAAa!!!
jais on Tue Jun 09, 2009 11:52 am
thank you so much for php5 Applause Applause Applause Applause Applause Applause Applause
ichmagtoastbrot on Mon Oct 26, 2009 6:21 pm
thank you so much for php5 Applause Applause Applause Applause Applause Applause Applause
ichmagtoastbrot on Mon Oct 26, 2009 6:21 pm
Very Happy Ahaa... PHP5 ready??/ woW...!
sifa on Tue May 04, 2010 6:12 am



FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.