FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!

Server 1 problems




Server 1 was comprised yesterday and directories that were needed for booting are gone.

I will have to reinstall the operating system first and configure it. Then I will need to recreate all the users and put the account data back so that cPanel recognizes it. And I can only start this after backing up everything on a different server.

All this is going to take a long time unfortunately, my apologies.

Edit: The data has been restored, but there are most likely still a lot of problems left after the restore. If you encounter any problems, please post them here!



38 blog comments below

Lucky me.
CHAOS-THEORY on Sun May 19, 2013 12:43 pm
I will be trying to copy all the config files and data so I won't have to recreate all the accounts and then correctly link them to the data. This would save a lot of time and effort - if it works.

Unfortunately the backup is taking a long time and I'll have to do it again differently too. And then get it back on the server after the OS installation.

Luckily for Frihost there aren't many accounts left on Server 1 and a good part of the accounts are inactive long-time users/staff whose accounts I never dared to remove.
Bondings on Sun May 19, 2013 1:36 pm
Aha .... that explains the lack of a response to what has gone down. Not many of us on Server 1. Thanks for all of the hard work.
deanhills on Sun May 19, 2013 2:20 pm
Yupe; appreciated as always.
CHAOS-THEORY on Sun May 19, 2013 3:19 pm
Wow, that sucks! Hope the fix goes down without any extra hitches.
Ankhanu on Sun May 19, 2013 4:19 pm
I hope that the server 1 problem would be solved soon so that people can have their websites back online. It has been a very long time since you last posted other than featuring a post. Welcome back.
twotrophy on Mon May 20, 2013 4:46 am
The data has been restored, but there are most likely still a lot of problems left after the restore. If you encounter any problems, please post them here!
Bondings on Mon May 20, 2013 11:28 am
Not a priority of course, but looks as though Frontpage extensions have been disabled.

Rest is working perfectly thanks except my disk use seems to have gone crazy. Can't remember exactly what it was before, but it couldn't have been much over the 100MB if 100. The slider used to be green, and it's changed to red at 216 MB. When I have a bit more time later on I'll check through the files to see why this is.
deanhills on Mon May 20, 2013 4:35 pm
#first server problems


^.^

/couldn't resist
ocalhoun on Mon May 20, 2013 8:15 pm
OK I checked my files. Looks as though my public folder has been duplicated.
*removed graphic*
deanhills on Mon May 20, 2013 9:15 pm
I am on server 4 so I am not affected by this problem. Bondings seems to come online in the time we least expect. I also wrote a thread to request to change my subdomain and reset my account.
twotrophy on Tue May 21, 2013 12:53 am
@deanhills, I think that is normal for cPanel.

@twotrophy, it might be better if you request a subdomain change on your account page and mention you want a hosting acccount reset. Topics can be easily overlooked if you don't have enough time to handle them at the moment you see it (and then forget about it).
Bondings on Tue May 21, 2013 7:57 am
Thanks Bonding for the efforts.
I just don't really understand what happened.
"Server 1 was comprised yesterday"
Is this a typo of "compromised" ?
rx9876 on Tue May 21, 2013 9:01 am
Apologies Bondings. I obviously was wrong. I worked through all of my files this afternoon and surprised myself with all of the photos I'd been using in my blogs. So there were no duplications. I managed to reduce my files from 216MB to 187MB. Then used FTP to back up the public html files to my computer for a total of 137MB. Wondering now where the 40MB are. Am planning to delete all of the current files in my cPanel once I've been able to make a full backup in cPanel. And then publish my Website from scratch. Am hoping for a further reduction in the size.
deanhills on Tue May 21, 2013 11:47 am
Looks as though some of the cPanel functions aren't working. I tried to make a full back-up last night of my Website and my Home Directory and after waiting a considerable time length (last session 6 hours), it came up with the following "error" message:
Quote:
There was an error setting gids: 1 (Operation not permitted)

Yesterday, when I tried to delete a sub-domain I created a couple of weeks ago, it came up with the exact same message. Softaculous isn't working either.
deanhills on Wed May 22, 2013 4:59 am
It is good that Bondings has fixed server 1. I am currently using server 4. Thank you Bondings for free good quality hosting once again.
twotrophy on Wed May 22, 2013 1:38 pm
I can't reach cPanel with my domains but only ip:port. My domains seem confused. When I enter to domain settings at cpanel, everything is normal, but if I want change something, there is "operation not permmited" error.
darkeagle on Wed May 22, 2013 6:03 pm
Good to see a Bondings again.
Very Happy
cybersa on Thu May 23, 2013 5:32 pm
Bondings said that he would try to give me a domain for free this week and said that it would be done probably on Sunday. I requested for a .me domain with privacy protection so it may cost more than 350 coins so I am trying to increase my number of coins.

I hope that Bondings would be able to earn enough money from advertisements to cover the cost of running Frihost such as paying for hosting this website, giving away free hosting as well as free top-level domain names.
twotrophy on Fri May 24, 2013 4:28 am
Thanks Bondings. Looks as though the cpanel features (except for the FrontPage extensions) have been restored. I was able to make a back-up of my Website. I tried the Frontpage extensions, but they were not working. Would be nice if they could, but I can work around them as well.

Must say it was quite funny to see my disk space going into RED after the back-up was made. Once I deleted the back-up file it went back to ORANGE although it should be GREEN. I think there must be some "archived" space that got added in, after sorting out the Websites after the hacking, and I am hoping that when I do a re-install from scratch, that the disk space will be back to normal again. Am planning to do this over the weekend.
deanhills on Thu May 30, 2013 9:30 am
I'm just wondering, but would there have been any risk of the backups being modified in any way or not? Also do you know how the server was compromised (e.g. through a website vulnerability, viruses uploaded to server, etc.)?

It's great that you're still looking out for us Frihost members, even though (I presume) you've been extremely busy with real life commitments to tender to.
Qantas94Heavy on Mon Jun 03, 2013 5:50 am
@Qantas. It was a straight hacking of vengeance with intent to demolish a Website on the server. The hacker then gained access to the server and destroyed operating software in it. As a consequence the server could not reboot itself. The parts that were badly affected were the configurations and settings, particularly in cPanel. Took a while to be straightened out. I can't imagine the backups would have been affected. Although I did gain a few extra MB of materials.
deanhills on Mon Jun 03, 2013 11:39 am
Hey Bondings, just a heads up that I really appreciate all that you do to maintain the servers. It's greatly appreciated.

Thanks again!
LostOverThere on Sun Jun 09, 2013 5:51 am
wow, i am truly impressed with the support and how cool people are in this forum. i think i am in the right place
chuwachuwa on Thu Jun 13, 2013 7:19 am
Well, at least thanks for being straightforward about the breach.
wombatrpgs on Sat Jul 20, 2013 4:05 am
Thanks for all of the work!
7110kemmerk on Wed Sep 18, 2013 3:39 pm
thank you for the information
ck7up on Sat Oct 19, 2013 12:37 pm
Guess I am late to the Server 1 down party. Just went to access my site and not having much luck! I can't even access Cpanel.
coolclay on Sat Dec 21, 2013 3:05 am
It's OK now Coolclay. Been up and running as fast as usual for a few hours now.
deanhills on Sat Dec 21, 2013 3:46 pm
Thanks for support!
omidz on Mon Mar 17, 2014 6:51 pm
Thanks for all of the work! Very Happy
corefinder00 on Fri Mar 21, 2014 2:18 pm
thanks for the info
gameproo on Thu Apr 10, 2014 2:24 pm
Thanks for the info.
corail on Tue Aug 19, 2014 9:50 am
By the Thanks for the support!
corail on Tue Aug 19, 2014 9:52 am
Excellent support team... Good Job Cool
emailghost on Tue Oct 07, 2014 4:13 pm
Thx for the info. Cool
daniel_dynamic on Mon Dec 01, 2014 11:57 am
I'm just wondering, but would there have been any risk of the backups being modified in any way or not? Also do you know how the server was compromised (e.g. through a website vulnerability, viruses uploaded to server, etc.)?
shappat on Wed Apr 15, 2015 2:13 pm
Excellent support team... Good Job Man Cool thanks for information Cool
Abody2020 on Mon Apr 27, 2015 8:09 am



FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.