FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Problem launching phpmyadmin under Ubuntu





DoctorBeaver
I'm new to Ubuntu so please forgive my stupidity.

I installed LAMP using Synaptic Program Manager on an old PC and I could access it from Firefox. I've just done exactly the same on another PC and when I tried to point Firefox at it I got a 404 error.

I uninstalled & used Synaptic to re-install. I'm still getting the 404.

I haven't done anything after installing it the 2nd time. Did I forget to do something this time around? Synaptic Manager says it's there too.

Incidentally, I can use Terminal to access mysql do it's just phpmyadmin that isn't available. Also, I installed mysqlNavigator and that's in the main menu working just fine - but I don't like using it. I want phpmyadmin! Crying or Very sad
DoctorBeaver
I used the file browser to do a search, and a lot of phpmyadmin files showed up. But I can't find out exactly where they are as no directory path is shown. I searched from File System.
Fire Boar
They should be in /var/www. Try this:

apt-get install apache2 php5 php5-mysql libapache2-mod-php5

Then point your browser to http://localhost/phpmyadmin/

If that doesn't work, try removing and reinstalling phpMyAdmin.
DoctorBeaver
Fire Boar - thank you for your reply.

I did apt-get install apache2 php5 php5-mysql libapache2-mod-php5, still got the 404.

I used Synaptic to uninstall phpmyadmin and chose "Remove completely".

I then used the terminal again with sudo apt-get install phpmyadmin. It all downloaded and I was asked which server to use. Apache2 was highlighted so I accepted it.

I used Synaptic again to check, and it found it OK. It said it was installed, gave all the versions & everything. The only thing it didn't tell me is where it is.

I opened Firefox, typed http://localhost/phpmyadmin/ in the address bar and got the following 404 again:-

The requested URL /phpmyadmin/ was not found on this server.
Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch Server at localhost Port 80


The annoying thing is that I've installed other mysql admin programs (mysqlNavigator & mysqlAdministrator) and they work fine. But they are complicated & fiddly (I have to keep checking the reference material) compared to phpmyadmin and that's why I really want it. It is so quick and easy to do things with.
Fire Boar
Does /etc/apache2/conf.d/phpmyadmin.conf exist? If not, does /etc/phpmyadmin/apache.conf exist?

If the first doesn't exist and the second does, try:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf
sudo /etc/init.d/apache2 restart
Diablosblizz
For me, you had to add some configuration file to apache's config file for phpmyadmin, after that it worked perfectly. I can't find where I read this, but I'm sure that's what you need to do.

Good luck.
Fire Boar
Diablosblizz wrote:
For me, you had to add some configuration file to apache's config file for phpmyadmin, after that it worked perfectly. I can't find where I read this, but I'm sure that's what you need to do.

Good luck.


That's what my suggestion is - put the configuration file in place. If that doesn't work, the next suggestion is to add it to apache2.conf explicitly.
DoctorBeaver
Fire Boar - you are wonderful! I want to have your babies!! It was in etc. I ran the 2 sudo commands, pointed my browser to localhost/phpmyadmin, and there it is!
Fire Boar
Glad you got it working. It's strange though - PHPMyAdmin should do that symlink automatically when you install it. Razz

Never mind though. It's working now, that's the main thing. And thanks for the Frih$.
DoctorBeaver
You're more than welcome.
kr_prithvi
FireBoar- thanks. The phpmyadmin worked fine in ubuntu after i executed the two commands.
ranithsr
Grt.....grt.......U solved the problem which I was stuck in for a few hours...thnxxxxx
kr_prithvi
Fireboar- you rock... the two commands worked like magic...
Fire Boar
Augh! Just for the record, I am not the one making alt accounts and randomly bumping this thread to praise myself.
ranito
I recently installed Linux Mint distro in a virtual machine and tried installing PhpMyAdmin like you guys and had the same problem. Thanks to you guys I got it fixed with the 2 commands that were mentioned. Thank you so much!
metalfreek
Here is the process to install XAMPP on Linux machine

After downloading simply type in the following commands:

Go to a Linux shell and login as the system administrator root:

su

Extract the downloaded archive file to /opt:

tar xvfz xampp-linux-1.8.0.tar.gz -C /opt

Warning: Please use only this command to install XAMPP. DON'T use any Microsoft Windows tools to extract the archive, it won't work.

Warning 2: already installed XAMPP versions get overwritten by this command.

That's all. XAMPP is now installed below the /opt/lampp directory.
* Step 3: Start
To start XAMPP simply call this command:

/opt/lampp/lampp start

You should now see something like this on your screen:

Starting XAMPP 1.8.0...
LAMPP: Starting Apache...
LAMPP: Starting MySQL...
LAMPP started.

Ready. Apache and MySQL are running.


To check ht installation just go to localhost on browser.
nguyenvulong
You might want to try install by terminal like the guide in apachefriends
It just works perfectly fine for me
Related topics
Which linux is the best for a new user?
PhpMyadmin problem
Directadmin Server 2 Problems
Google Works under Linux
PhpMyAdmin
dual boot
Creative Audigy Driver for Ubuntu...
Problem with phpMyAdmin?
running DOS apps in Ubuntu 7.10 plz help!!
VGA cable shielding?
Vista's biggest problem is perception
help needed - phpmyadmin under Ubuntu
What Made You Switch To Linux?
Problem of Firefox under Linux
Reply to topic    Frihost Forum Index -> Computers -> Operating Systems

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.