You are invited to Log in or Register a free Frihost Account!

prefix www doesn't work.

OK, I have been using different hosting services and usually all of them have under each subdomain an option to put a mar on the checkbox if you wish to have your www subdomain directed to your domain. Here I have lets say, which work fine, but I did try and it doesnt display me anything. Just gives "The page cannot be displayed". So it means subdomain www is not working. On cPanel I tried to add www subdomain, but it gives me "Sorry, www cannot be used in subdomains." I can see on ftp that I have a www folder which is redirected to public_html, which means tat whoever is trying to open www will get the same thing that is in public_html, but it appears that server is not accepting anything that has a www prefix.
Please advise how to fix it. Maybe there is somewhere on cPanel a small checkbox that I just missed.
Normally adding www before a domain should always work in cpanel. Please provide me with the url in question because otherwise I can't really do much.
Here it is:
It works fine in this way, but I would like people to get the same thing if they type in At least I am getting "The page cannot be displayed"
I could be wrong, but in my opinion everything is set up correctly on Frihost. Could it be that the problem is on the no-ip side?

It seems like no-ip offers dns services for the subdomain, but doesn't offer a redirection for the www subdomain and most likely all other subdomains.
Well, I did look thru all the settings available at NO-IP. I did not find anything that would fix it. Nothing that says aboud www or even no way to add any extra sudomains. Maybe here is someone who knows how to resolve this problem?
Well ruba, I tried to park the www on your main account, but it said that the zone already existed - like it should. In my opinion, the problem is with, but I'm not 100% sure of it.
Quote: (an authoritative nameserver for says that there are no A records for

The dns doesn't seem to reach the Frihost server.

By the way, have you ever used that domain on another host? And did the www work there?
The only solution I can see is to recreate your account, but if the problem is with no-ip, I really can't do much about it.

Maybe someone else has a better solution ...
Notice the difference between the two queries for A records.
Searching for A record at Reports an answer. A IN 60

Searching for A record at Reports no A records (NXDOMAIN). 62ms.

This is happening because you don't have an A record for

You can do either of these,
create a NS record for , pointing to (and optionally, an additional one pointing to
create an A record for , pointing to
create a CNAME record for , pointing to

Frihost server has the answer to the queries for "www", but it is not even being asked.
because the nameservers don't know where to redirect the query for "www".

You'll face this problem with any additional subdomain that you create.

If you create NS records to delegate your ns queries to frihost nameservers (first method) you don't need to worry about all this...frihost server will take care of adding the necessary A records for these additional subdomains.
Just in case...make sure you uploaded in WWW and not the main directory Very Happy
progman89 wrote:
Just in case...make sure you uploaded in WWW and not the main directory Very Happy

AS Morph said when u open his site with "www", request can't even reach frihost so even if he uploads his site to every direcotry it will not work.
Thank you all for your replies, will try to fight with then!
This particular problem is listed in their faq's
OK, I figured out what is going on. For others who may have the same problem is the solution. I found it by myself. At go to the menu Hosts / Redirects and from there go to Manage. Choose your domain name that you want to have www on the front and click on Modify next to it. This will open you another page where you can see all the settings for this domain name. In the first table, there is a checkbox that tells Allow Wildcards. So if you select that box then www or anything else on the front of your will be pointed to the address you wanted. It can be even dynamic IP that is being updated by their program.

Only problem that I still have is that requires to have Enhanced or Plus account which is paid account. So I will stay without www or some day will just register my domain at any other service provider like

But anyway, www on the front of is possible.
Ok great! Issue solved and topic -locked- . To reopen it, please pm me.
Related topics
How can I change the caption of Browse button?
My domain doesn't work
Why doesn't my cronjob work?
Regular Expression - get content of a cookie
Help with Dreamweaver sessions !!!!!!!!
Is Adam really the first human in our world?
Internet Explorer
Windows XP or HDD?
Mozile Firefox: ENTER in url bar doesn't work
Problem in Div with IE
the get_file_contents function doesn't work anymore
Provide evidence of the Supernatural (God et al.)
MySQL => Select tables by prefix
This topic is locked: you cannot edit posts or make replies.    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

© 2005-2011 Frihost, forums powered by phpBB.