FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Increase the life of the session object





chasbeen
Sometimes I like to enhance my reply or refine a new subject. When I press the submit button I am offered the login screen. I then have to use the browser back button and put all my typing in a buffer (copy). Relogin, navigate to the relevent forum and then add my reply.

Can we increase the life of the session object?
rvec
you could just login and press the back button a couple of times Wink
then you'd only have to press the 'submit' button again instead of copy-pasting it.
chasbeen
I think your service would be a bit better if you weren't logged out when you submit a reply though. So whats the reason that the name/value pair associated with session time out aren't change or is there a bigger complication?
LukeakaDanish
Never happened to me...what browser are you using?
chasbeen
I think this is a server issue, so it does not matter what browser your using. Short posts like this and yours won't be affected....
mathiaus
I also have never had this problem and have before, created longer posts than this.

Have you selected the auto login I wonder?
ocalhoun
This happens whenever Frihost doesn't detect any activity from a user for a certain amount of time, the system then decides that the user has left, so it logs it out.

The problem is that if you spend a lot of time reading a long topic, researching a response, or typing up a very long response, then the system will still detect inactivity and log the user out. If the time it waits before logging the user out was increased this would happen less often.

It is extremely annoying when it happens because it also resets the tracking of which posts are new posts and which have already been read.
Bondings
There is a session length option in the admin panel of phpbb. I changed it from 3600 seconds to 7200 (1 hour to 2 hours). I guess this is the setting you mentioned and I hope this is enough to make the problem disappear.
chasbeen
Bondings, me and "oc" are talking about a problem when we type something up and the problem can occur if you spend 5-10 minutes on a post or new subject. I don't think the setting is in the bulletin board/PHP software.
Are you running on an apache server?
You need direct/indirect access to the httpd.conf Apache configuration file and inside that you might find a "name" variable called "SessionTimeout" it's probably set to something like "360".
I'm not sure if you have to reboot the server before the setting works
rvec
chasbeen wrote:
Bondings, me and "oc" are talking about a problem when we type something up and the problem can occur if you spend 5-10 minutes on a post or new subject. I don't think the setting is in the bulletin board/PHP software.
Are you running on an apache server?
You need direct/indirect access to the httpd.conf Apache configuration file and inside that you might find a "name" variable called "SessionTimeout" it's probably set to something like "360".
I'm not sure if you have to reboot the server before the setting works

restarting apache will do.

But I can't find the word 'session' in my apache config nor in my http config file (on both WAMPP on xp and apache2 on debian).

edit: it's in php.ini
session.gc_maxlifetime
session.cache_expire

one of those should do it.
ocalhoun
Wow!
That may be a record for prompt response and action taken for a suggestion...
No "it will be part of the redesign... someday..." here!
Bondings
rvec wrote:
chasbeen wrote:
Bondings, me and "oc" are talking about a problem when we type something up and the problem can occur if you spend 5-10 minutes on a post or new subject. I don't think the setting is in the bulletin board/PHP software.
Are you running on an apache server?
You need direct/indirect access to the httpd.conf Apache configuration file and inside that you might find a "name" variable called "SessionTimeout" it's probably set to something like "360".
I'm not sure if you have to reboot the server before the setting works

restarting apache will do.

But I can't find the word 'session' in my apache config nor in my http config file (on both WAMPP on xp and apache2 on debian).

edit: it's in php.ini
session.gc_maxlifetime
session.cache_expire

one of those should do it.

I changed the session.gc_maxlifetime from 1440 to 3600. Also the session.gc_divisor from 100 to 200. I hope that helps.
chasbeen
Bondings I think I was wrong about apache.
What did you do to fix this?
I'm reporting that this has fixed a significant shortcoming and will benefit the user community...
deanhills
Bondings wrote:
There is a session length option in the admin panel of phpbb. I changed it from 3600 seconds to 7200 (1 hour to 2 hours). I guess this is the setting you mentioned and I hope this is enough to make the problem disappear.


I have not posted for a few weeks, and have never had this problem before, actually ever before. I could stay on for hours at a time. But all of a sudden when I returned, this session, I have had to log in approx. four times just for two short postings. I almost thought that that was my punishment for having been away for a while Smile

Hopefully this will be a one-off?
chasbeen
I can assure the last poster that the original problem that was posted in May no longer occurs.
To be specific, you could loose a long post and this incicated that despite being 'active' the session had NO KNOWLEDGE that users were still active.

You might be talking about a temporary server problem (Because of a sudden need for several reboots for example) but your current problem is not related to the original problem I think.
sonam
I have this probelm before when I have slow dial up connection. When I get ADSL I haven't this problem and I am log in forewer.

TEST: This post is waiting more then 45 minutes from start to the end.

EDIT: When press Submit I didn't get log in.

Sonam
deanhills
chasbeen wrote:
I can assure the last poster that the original problem that was posted in May no longer occurs.
To be specific, you could loose a long post and this incicated that despite being 'active' the session had NO KNOWLEDGE that users were still active.

You might be talking about a temporary server problem (Because of a sudden need for several reboots for example) but your current problem is not related to the original problem I think.


Thanks for the response. The server problem is not temporary. But will try again tonight at home (am travelling right now). Bondings suggested a few things and will try it out.
Related topics
Bluetooth
Justification for War in Iraq
Aliens - Myth or reality?
how many of the four cardinal virtues do you practice?
Bin Laden offers truce...
Changements to the Points/frih$ system (Discuss)
Define Religion?
Beauty is the Pattern of Nature
Where did life originated?
session_destroy problems
Psychics "for entertainment only"
Do dreams have symbol?
How are cookies saved?
Need Help on creating a validation script
Reply to topic    Frihost Forum Index -> General -> Suggestions

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.