FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Remotely access mysql for wordpress





surdy
Hi

I have wordpress installations on my frihost site and they work fine. Now i have this another hosting which does not have mysql and i wanted to put worpress there and access mysql from the frihost hosting. I have two questions

1) Is it possible (as in is it allowed to access mysql databases here from another site , assuming i have the permission set up for that website on the database)
2) If answer to 1) is YES then what do I write in DB_HOST , as in just frih.net or something else.

I guess i'm on server 2.

Thanks
rvec
yes it's possible. But you need hosting on frihost to do that and for that you need to keep your points higher. You hosting could be removed if you don't get more active.

You can go to directadmin, add a database and add a connection host. Then on the other webhost set your whole url as the db_host . So also the subdomain in front of frih (example: rvec.frih.net).
surdy
thanks for the response

so this means i cannot do so fron a non-frih hosting?
rvec
surdy wrote:
thanks for the response

so this means i cannot do so fron a non-frih hosting?

It means you can, but you need your points up to keep your hosting. If you have more points I don't see any reason why it would'nt be allowed/possible.
IceCreamTruck
I'm trying the same thing, but from a desktop application that I want to interface with MySQL, but I keep getting "Access denied for user: '<db_username>@67.135.152.28' (Using password: YES)" error when I try to connect.

I have setup my domain as a host for the database: xmpact.com. I've checked all the other settings but I just seem to be blocked somehow.

I'm trying to connect on port 3306, and that might have something to do with it, but I am not totally sure.
IceCreamTruck
ok, i fixed my own problem, and now i'm back to let you guys know that although my problem was tricky, and I was originally sure that I needed someone with a better view than I to make the change...I am proud to annouce that I have fixed it and here's how.

When the MySQL database comes back and says: "Access denied for user: '<db_username>@67.135.152.28' (Using password: YES)"

What it is saying is this:
Access denied for user: '<database_username_you_set_up>@<connecting_from_this_secure_host>' (Using password: YES/NO)

You have to set up the username, and you also have to tell the database the ip address of the computer (might be your routers or ISP routers address) that you will be connecting from. That was my problem. I didn't tell the database server where I would be connecting from.

I heard a dirty little secret that you can set host to value = "%" and this will cause any host to be able to connect and exchange data with the database, but I'm not so sure that this is a good idea. Having to supply the Host ip address in advance of connect is a good security measure.
rvec
yeah % is mostly the default value for people trying to connect from another host. After you get everything working you can always put in an ip but with a % you can be sure it accepts the connection.
Related topics
Windows Tips&tricks!
simple php problem, please help...
windows xp
MySQL Masters Binary Logs & Replication?
a challenge?
Python support for MySQL
Installing phpBB2 with WAMP
Wordpress blog on ypur website
Server Two MySQL Down
Getting database connection error while installing wordpress
MySQL Host remote connection
Can't Access HTTPS in Wordpress
Can't access my blog
Wordpress Files Not Displayed HELP PLEASE
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.