FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Changing default keyboard on ubuntu 5.04






how much (out of 5) do you like pointless and off-topic polls?
5, i LOVE them!!!
33%
 33%  [ 1 ]
4, they're cool.
33%
 33%  [ 1 ]
3, i don't mind them.
0%
 0%  [ 0 ]
2, i don't like them much, they can be annoyng.
0%
 0%  [ 0 ]
1, they totally SUCK!!!
33%
 33%  [ 1 ]
0, they're totally pointless and all users that create them should be reported, blocked and shot at dawn.
0%
 0%  [ 0 ]
Total Votes : 3

MarzEz
I need help changing the default keyboard on ubuntu 5.04 for the login screen. i set it to Dvorak on installation but have switched the keyboard layout back to US English.
i can change the layout for me as an individual user, but not for the login screen. Brick wall
can someone PLEASE help me with this? Question i really need help! Sad
LostOverThere
5.04? Seriously, upgrade. Sorry.
MarzEz
thx 4 the help...
not.
7.10 uses 128mb more ram... that i don't have.
mehulved
You can try ubuntu 6.06 which is LTS.
Or even Xubuntu will be a good idea since it has XFCE, which requires less RAM. Also, you could use something like fluxbox or xfwm instead of a full blown DE, but they have a slightly higher learning curve.

Getting back to your original query. You need to edit your Xorg settings. There are 2 methods you can use to do this
1) Directly edit the /etc/X11/xorg.conf file. You won't be able to do so directly as the keyboard will work like a DVORAK keyboard. So, rather take a live CD like puppy, mount your ubuntu partition and edit the file. Do remember to take a backup of the file before editing
2) Run the following command
Code:
sudo dpkg-reconfigure xserver-xorg

Now Xorg will try to autodetect all your hardware. Most of them, if not all will be detected fine. IF it's not then you will have to do so manually. But, again remember to take backup before running this command.
In this case if something is detected wrongly and you aren't sure then you might again have some problems. But, chances of this happening is very low as it didn't happen when you installed ubuntu.
JayBee
I don't use Ubuntu, but I can recommend you some tips

- You should check, if you have installed package with keyboard layouts. (xkbdata, xkeyboard-config, ...)
- I use XFCE insted of gnome or KDE and after boot, I have about 90MB RAM filled and the rest is free
- Try XFKC, it is easy utility to switch keyboard layout (It mus be started before your X session starts, read manual, how to do that)
- Try never versions of software, some old (Like Ubuntu 5.04 is) could be more buggy then new releases
- Find /etc/X11/xorg.conf and edit Keyboard InputDevice section
- If you use Gnome (i don't know the utility name, because I never use Gnome) or KDE (kxkb), you should find some utility, which change keyboard layout at runtime. If this utility is used, settings in xorg.conf is useless, because it is override by this utility. This utility could start at background and you should not know it.
Related topics
Linux users - Which window manager do you prefer the most
Help : Fedora Core 4 + Ubuntu
Install ubuntu 7.04 with ATI Radeon X1xxx series card
Uninstalling Ubuntu v7.04
Ubuntu 8.04
Ubuntu 8.04
Unable to Access websites in Ubuntu 8.04
Ubuntu 9.04's New Themes
Ubuntu 9.04 [random freezing].
Ubuntu 10.04 released! How are you finding it?
how to get nodoka (fedora default theme) in ubuntu 10.04
Ubuntu 11.04
Install deb Package in Ubuntu 11.04 without Internet Conn
Ubuntu 12.04 vs. Windows Vista
Reply to topic    Frihost Forum Index -> Computers -> Operating Systems

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.