FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Error 500 when turning off register_globals (server 1)





leontius
Hi,

A script I am trying to install needs a turned off register_globals. The problem is that I searched the forum about how to turn off register_globals, and I found that I am to put

Code:
php_flag register_globals off


in .htaccess. However, when I put it in, the server issued error 500 (and the error goes away if I remove the line). So how do I turn it off? (I am in server 1)

Oh, and actually the script (the Drupal CMS) cares so much about this in the default .htaccess given, but it does not seem to handle Frihost's server:

Code:
# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

leontius
Sorry to bump, but has anybody looked into this? See http://www.lxtr.frihost.net/install.php?profile=default for the real error message.
mathiaus
Replacing
Code:
  php_value register_globals                0

with
Code:
php_flag register_globals off

doesn't work?
leontius
I think "php_flag register_globals off" works ok. However, it seems that if I use this configuration, index.php won't load (gives error 500) even if it only contains "echo 'a';". The error goes away if the php_flag line is removed. Any other PHP file works fine. Any ideas?
Related topics
My server is down with internal error 500 ?
how 2 super tweak ure server
cPanel isn't working
PHP register_globals setting is `ON` instead of `OFF`
Error 500
MySQL connection error on Server 2?
>.<!! 500 internal server error and things I can't exp
Error 500 and Internal Server Error
JOOMLA Article Manager Error
Frihost da joomla sitesi kurdum ama 500 hatasi aliyorum
Upload Error 500
Internal Server Error
Internal Server Error 500
Joomla config file write error 500
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.