You are invited to Log in or Register a free Frihost Account!

My java applet can not find class file on the server

I wanted to run an applet in my page but I faced errors. I wondered whether it was about applet so I change my applet to a small easy one. But the problem was still over there! I see a red cross in my applet's area. When I open java console it says:
load: class lake.class not found.
java.lang.ClassNotFoundException: lake.class
   at sun.applet.AppletClassLoader.findClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at sun.applet.AppletClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at sun.applet.AppletClassLoader.loadCode(Unknown Source)
   at sun.applet.AppletPanel.createApplet(Unknown Source)
   at sun.plugin.AppletViewer.createApplet(Unknown Source)
   at sun.applet.AppletPanel.runLoader(Unknown Source)
   at Source)
   at Source)
Caused by: open HTTP connection failed.
   at sun.applet.AppletClassLoader.getBytes(Unknown Source)
   at sun.applet.AppletClassLoader.access$100(Unknown Source)
   at sun.applet.AppletClassLoader$ Source)
   at Method)
   ... 10 more

I changed all my index.html, mypic.jpg and lake.class permissions to 777.

When I manually write url of the lake.class, my browser finds it but the java applet can not find!

I examined Apache usage log file.
It is seen that a 500 error occurred when applet request the lake.class file:(after lake.class it looks also lake/class.class)
My IP adress here - - [11/Dec/2007:10:04:51 -0600] "GET /lake.class HTTP/1.1" 500 - "-" "Mozilla/4.0 (Windows XP 5.1) Java/1.5.0_09"
My IP adress here - - [11/Dec/2007:10:04:51 -0600] "GET /lake/class.class HTTP/1.1" 500 - "-" "Mozilla/4.0 (Windows XP 5.1) Java/1.5.0_09"

But when I manually type the url of the class file, it is ok as seen here:(the file length is 10119)

My IP adress here - - [11/Dec/2007:09:51:42 -0600] "GET /lake.class HTTP/1.1" 200 10119 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20071102 Firefox/ Navigator/"

What can be the problem? I am working for days but no way!!
Have you solved the problem since your post? Because it works oke here. I see the applet with a picture of a lake ("No nudes allowed" Very Happy )
no no, problem still there...
as I said this a problem that I was trying to solve for days... but no solution...
may be it is about my account.. I don't know...
and yes, no nudity allowed Smile
what's the code you use in your page? Are you sure you didn't make a typo there?

BTW you forgot to erase your ip in the second line of the first code snippet Wink
I changed it for you.
I copied my page source and paste here:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  <meta http-equiv="content-type" content="text/html; charset=windows-1250">
  <meta name="generator" content="PSPad editor,">

   <applet code="lake.class" width="280" height="440">
  <param name="image" value="mypic.jpg">
<param name="href" value="">


No typo. I don't think it is a typo-like small error.

BTW thank you rvec Smile
I must use an applet on my page. This is important for me.

Can you see my applet?(if not, what you see in java console)

What do you think about this ridiculous problem? I am stuck in this horrible problem.
I have still this problem... Sad

I just want to run a java applet on my page... It shouldn't be this much hard... Any body tried this page and saw the applet working?
alem wrote:
I have still this problem... Sad

I just want to run a java applet on my page... It shouldn't be this much hard... Any body tried this page and saw the applet working?

"Loading Java applet failed"
thank you neji for trying. same for me... doesn't work...

I remember that my applet worked (may be 1 month ago) for a while but then it broke down again but I didn't understand why it worked and again failed. As far as I remember, I was playing with .htaccess files and changing custom error pages. But now there is no .htaccess file there and no custom error pages... I do not know what to do...Sad
Related topics
Firefox problem
java applet not working!!
JavaScript or Java Applet and maybe DHTML codes
I need a php upload script, NEEDED BADLY
My Disk Server, File Server Software
Very Simple On Site Editor
java applet refresh problem
games using java applet
PHP utf-8 to Java Applet
Image in applet
Java Applet
Java applet error.
File Server and Resource Manager (Part 2)
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

© 2005-2011 Frihost, forums powered by phpBB.