FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


SMF forum error?





TheForgottenArts
How come my sites forum doesn't work anymore? It was working last night perfectly. I got a bunch of errors when I came on earlier today. Something about MySQL connecting. I got them on my index.php and forum. This is the error I got on the forum. I fixed the front page, somehow.

Code:


Notice: Undefined variable: sourcedir in /home/alostsou/domains/cyberinfections.frih.net/public_html/forum/index.php on line 49

Warning: require_once(/QueryString.php) [function.require-once]: failed to open stream: No such file or directory in /home/alostsou/domains/cyberinfections.frih.net/public_html/forum/index.php on line 49

Fatal error: require_once() [function.require]: Failed opening required '/QueryString.php' (include_path='.:/usr/local/lib/php') in /home/alostsou/domains/cyberinfections.frih.net/public_html/forum/index.php on line 49



Can someone tell me how do fix this? No one has altered my files. Maybe it's because of my FTP? It's been down for a long while, and it recently came back.
wumingsden
TheForgottenArts wrote:
How come my sites forum doesn't work anymore? It was working last night perfectly. I got a bunch of errors when I came on earlier today. Something about MySQL connecting. I got them on my index.php and forum. This is the error I got on the forum. I fixed the front page, somehow.

Code:


Notice: Undefined variable: sourcedir in /home/alostsou/domains/cyberinfections.frih.net/public_html/forum/index.php on line 49

Warning: require_once(/QueryString.php) [function.require-once]: failed to open stream: No such file or directory in /home/alostsou/domains/cyberinfections.frih.net/public_html/forum/index.php on line 49

Fatal error: require_once() [function.require]: Failed opening required '/QueryString.php' (include_path='.:/usr/local/lib/php') in /home/alostsou/domains/cyberinfections.frih.net/public_html/forum/index.php on line 49



Can someone tell me how do fix this? No one has altered my files. Maybe it's because of my FTP? It's been down for a long while, and it recently came back.


The error says that a file which is required doesn't seem to be there. Check whether you have the file QueryString.php
TheForgottenArts
I have that file, though.
SlowWalkere
I would think that the following line...
Code:
Notice: Undefined variable: sourcedir in /home/alostsou/domains/cyberinfections.frih.net/public_html/forum/index.php on line 49


is the one to be worried about. The other errors are probably related to it.

From the sound of it, there's a variable that is supposed to hold the path to these files and that variable is not being defined for some reason.

If you look at the third error, it says it failed to open "/QueryString.php". I would assume that $sourcedir is pre-pended to that string, and in the source code it reads something like
Code:
$sourcedir . '/QueryString.php'


Since $sourcedir isn't defined, no path is given to php to find the file. You'll need to search for where $sourcedir is defined (maybe in a config file?) and fix that. Perhaps an include file got left out or something...

Good luck,
- Walkere
wumingsden
^^ I didn't think of that.

Maybe try running repair_settings.php and see it that works? If not then rename the file settings_bak.php to settings.php.
Related topics
Forum error when posting
SMF Forum is not working
SMF install: Unable to connect to FTP server
I keep getting error e-mails
SQL user/password files in SMF
SMF help needed!
Close Please
403 Error On My Smf Forums Index.php
SMF forum- help needed please
SMF forum
Installing forums in your site
Integrate Wordpress blog with SMF forum
Editing SMF forum main menu
Is It Possible to Sync Wordpress Database and SMF Forum
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.