FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Ubuntu 7.10 Desktop effects problem





ThePolemistis
Hi,

I have problems with my laptop getting the Desktop Effects to work on 7.10. However, they work perfectly on Ubuntu 7.04 (the wobbly window and cube effect).

Only "none" option works, the basic one (below it), and the last one does not work.

My gfx card is ATI Radeon Mobility 7500, but its quite old 32mb on it. But as I said, the desktop effects on ubuntu 7.04 wokred perfectly.
Anyone know why?
mehulved
Check the output of
Code:
glxinfo | grep direct

It will tell you if direct rendering is on or off.
Secondly, check if you're still using the right driver
Code:
grep Driver /etc/X11/xorg.conf
Loghete
Try downloading the Advanced Compiz Configure and just enable the wobbly window and cube effect, the custom high setting might be too much for your computer, since it enables a lot of other effects that has been added since 7.04.
ThePolemistis
mehulved wrote:
Check the output of
Code:
glxinfo | grep direct

It will tell you if direct rendering is on or off.
Secondly, check if you're still using the right driver
Code:
grep Driver /etc/X11/xorg.conf


OKay,, Im having some troubles.. At the moment, im running off live CD, so dunno if it will work..
Anyways

It says Direct Rendering is switch off:

Code:
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)


Dunno what the LIBGL_DEBUG=verbose stuff means, im a linux no0b.

Also, I hav ran glxgears and that works (if thats relevant :S )

I made the following changes to the xorg.conf file:

EDIT: Actually, the code below is from the website link shown, I somehow cannot manage to edit my xorg.conf file anymore loll... but when I did do it,, i added the option statements in the correct places

Code:

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
Driver "ati"
BusID "PCI:1:0:0"
Option "GARTSize" "64"
Option "AGPMode" "4"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
Option "AIGLX" "true"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection


I added the 3 Options shown in the code above... but the attempt has failed, although for others using the same gfx card, it has succeeded @ http://ubuntuforums.org/showthread.php?t=584439

loghete wrote:

Try downloading the Advanced Compiz Configure and just enable the wobbly window and cube effect, the custom high setting might be too much for your computer, since it enables a lot of other effects that has been added since 7.04.


err.. to do the above, ive been trying to follow this guide: https://help.ubuntu.com/community/CompositeManager/CompizFusionATI?highlight=%28compiz%29

I have enabled the universal respository and installed compiz, but i get the following problem when installed the full stuff:
Code:

ubuntu@ubuntu:~$ sudo apt-get install compiz compizconfig-settings-manager
Reading package lists... Done
Building dependency tree       
Reading state information... Done
compiz is already the newest version.
E: Couldn't find package compizconfig-settings-manager
ubuntu@ubuntu:~$ sudo apt-get install compiz compizconfig-settings-manager compiz-gnome


Any other solutions? Bear in mind, im running from LIveCD... cus i aint gonna install it, only to delete it if the effects don't work.

Cheers for any help
LostOverThere
Uh, when I used the Live CD the Desktop Effects didn't work for me.

But as soon as I installed it I just downloaded a different driver and it worked like a charm.
Fat Fetched, but it could be as simple as that.
carlospro7
the compiz effects won't work on the live CD because once you download and install the drivers, you are required to restart if you want to use the effects, but being a live cd and nothing your doing is really being saved, once you restart, everything that happened during the ubuntu live session will be flushed like it never happened.
ThePolemistis
thanks for the help... i guess I will have to install 7.10 and hope for the best Smile... if the effects don't work... i guess ill have to revert to 7.04.
mehulved
Effects will work out of the box only for intel chipsets. For ATI and Nvidia, you will have to install extra 'non-free'(read proprietory) drivers for 3D to work.
And if you have sis or via then better be happy with 2D.
nbeerbower
Upgrade to Gusty Gibbon. Everything should work then.
mehulved
nbeerbower wrote:
Upgrade to Gusty Gibbon. Everything should work then.

It's not about the version cos AFAIK, gutsy doesn't include binary drivers for nvidia and ATI cards. So if he has one of those then desktop effects won't work unless the binary driver is installed.
So, no point in upgrading to gutsy just for that reason.
lastelement0
if you activate the "restricted driver" for your ATI card you will be able to get the graphic effects to work. using integrated graphics will not allow you to do so. and seeing as the card is an ATI it won't work out of box without setting up the restricted drivers for it.
Related topics
Whats Your Top 10 Desktop Applications
New laptop ubuntu 6.10 problems
Ubuntu 6.10 video card
Ubuntu 7.04
Ubuntu 6.10 - Sound & Compact Flash [SOLVED]
Install Ubuntu over existing Suse10.2
Install ubuntu 7.04 with ATI Radeon X1xxx series card
gnash sera incluido en ubuntu 7.10
Ubuntu 7.10 "Gutsy Gibbon" Released
Ubuntu -- in search of a VM home for Gutsy
Another plan for the new Ubuntu operating system
A problem in ubuntu
Problem with Ubuntu 7.10 ; Disable F10 key for Eclipse
Ubuntu 12.10
Reply to topic    Frihost Forum Index -> Computers -> Operating Systems

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.