FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Why my site is getting error ???





sambhav
I am getting this error on the first page....Please help.

Quote:
SELECT id, path, tn_ext
FROM phpwebgallery_images
WHERE id IN (2,29,53,94,140,220,238,255,338,345,359,413,452,510,531,605,621,686,704,753,790)
;
[mysql error 1016] Can't open file: 'phpwebgallery_images.MYI'. (errno: 145)
rvec
please give some more info, it makes guessing easyer.

I think you are using phpwebgallery, and the file phpwebgallery_images.MYI is missing. You probably forgot to upload one file or one folder.
Bondings
Login to phpMyAdmin with the username and password of the database. Click on the phpwebgallery_images table and go to the commands (or however/wherever it's called/located) and click on the repair option.

Otherwise issue the mysql query:
Code:
REPAIR TABLE `phpwebgallery_images`

It's also a good idea to make a backup of the table/database before doing this. Even though it's very unusual for something to happen, a backup is always useful.
sambhav
Thanks Bonding....Its working fine now....Actually I was a bit busy and didint know since how long the site is face the problem....anyways thanks again. Can you please brief me why such problem occurs and what exactly the repair table do ??
Bondings
Most likely the table crashed or was corrupted for some reason. This could have happened for a lot of reasons, like stopped programs, server crashes, ... and happens the most to frequently-used tables. The repair command tries to fix it, like by rebuilding the index file or changing the corrupted data into the most likely form.
sambhav
Thanks for the info.
Related topics
Error 404 ..... How to Hide ...
Can someone explain how google works exacly?
unable to login to cpanel
I keep getting error e-mails
php error ?[parse error]
need help building a switch/case dynamically w/ a loop &
Can't extract a file from a Zip archive!!!
footer sign error
Problem with write perimissions.
Need help with site getting error on http://validator.w3.org
Office 2007
Getting started
Firmware Updating! Please Help :S
Error 110: Request Timed out
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.