FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


PHP Security problems with latest frihost changes





simplyw00x
I have been relying quite extensively on the PHP shell in order to perform effective (and bandwidth-forgiving) backups of my frihost site, and also to ease FTP bandwidth. With some recent changes - the system() and ini_parse() functions being nerfed - these tools have become broken, and for a questionable gain in security.

Of course giving people fake shell access is a security risk, but PHP itself is a security risk, and the number of people with sufficient technical skill to screw themseleves over with these functions is far smaller than the number of people who insist on taking up huge amounts of bandwidth and, more importantly, processing power, with their own poorly-written and bloated scripts.

Please consider,

Carl van tonder
Related topics
Slight Server Problem
[Dúvidas] Pontos
What Will Vista Mean to You?
The changes of frihost [Discuss]
Question about a php and mysql script.
Cookies
PHP Update
Problem restoring databases
Frihost blog post bug
PHP and MySQL FAQ - Read Before posting!
CMS trial and error
Question About RaC Mod
Which php version on the new server? (5.2.12 or 5.3.1)
Open-Realty and Frihost
Reply to topic    Frihost Forum Index -> General -> Suggestions

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.