FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


[resolved]





ocalhoun
In order to complete the installation of a piece of website software, I need to CHMOD a file to the 444 permissions setting.
(The file is www.onet.frih.net/walk/cfg.php)
The problem is that Frihost's server will not allow me to set any file's permissions to 444. (Error message: 550 cfg.php Operation not permitted) In case this is actually my fault, I'm trying to use my FTP program, SmartFTP, to CHMOD the file.

So, I need one of these things:
-For somebody (an admin) to CHMOD 444 this file for me
-For somebody to change the server's settings so that it is possible for me to do it.
-For somebody to explain how I can do it some other way
-For somebody who is experienced with this software (BLOG:CMS) to give me precise instructions on how to get it to work without CHMODing the file.
silverdown
This might help

-For somebody (an admin) to CHMOD 444 this file for me
If you have Direct Admin control panel just go to the file and see if the file is ownership is by apache and click reset ownership and you can change the file CHMOD.
-For somebody to change the server's settings so that it is possible for me to do it.
Sounds like you dont have ownership if the file ( see above to fix if you have Direct Admin Control Panel)
-For somebody to explain how I can do it some other way
See above 2 ^
-For somebody who is experienced with this software (BLOG:CMS) to give me precise instructions on how to get it to work without CHMODing the file.
See Above!


Refrence that may help if you have Direct Admin.

--- File Permissons ( CHMOD )
http://www.site-helper.com/filemanager.html#permissions
ocalhoun
^I've already tried it using directadmin. Here's the result of that:
Code:

Unable to set file permissions

Details

Unable to chmod /domains/onet.frih.net/public_html/walk/cfg.php to 444

Experimentation shows that this particular file is the problem, not this particular permissions setting. I cannot change that file's permissions in any way, though I can change others' just fine.
silverdown
Sounds like a ownership problem to me.

See if you own the file in DA, most of the time when I cannot edit files it because apache owns them.
ocalhoun
Ah, indeed apache owned it. I downloaded it and uploaded it back; now I can change the permissions.
Thanks for the help.
(In case anybody searches and finds this thread, I think the reason it was apache-owned is because a php script created the file.)
Animal
Topic resolved, so I'll -close- it. Please feel free to PM any member of staff if you would like it re-opened.
Related topics
Points and FRIH$ -- RESOLVED --
[RESOLVED]Resend Account Details Please!
PhpBB Ranks <RESOLVED>
Resolved
Resolved
Unexpected T_STRINGS *Resolved*
i also resolved the issue of openvpn+freeradius+mysql
Totally bizarre network issue
mysql_real_escape_string not working?
[RESOLVED] Videos?
Nameservers
Hotmail accounts at risk
wow
Do you use css to design a website?
This topic is locked: you cannot edit posts or make replies.    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.