FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Intel Pro Set Wireless / Windows XP Wireless Network Issue





Animal
I've got an Intel Pro Set Wireless 3945ABG card in my laptop running XP Pro and connect wirelessly to a Netgear DG834G router (WPA enabled). I use the software that came with the Intel Wireless card because it performs much better than the built-in Windows WZC client (faster in connecting initially, connections are dropped far less frequently etc), so I want to continue to use it. However, when I start up my computer, the wireless network is connected virtually instantly after logging on (as shown by the green Wireless Signal icon in the image below), but the Windows Wireless Network Connection shows "Acquiring Network Address" and stays like that (the moving yellow ball as if it's waiting to connect) until I manually open the wireless properties window and hit OK. I am able to browse the web etc even though the "Acquiring Network Address" icon is still showing.

After logging on, my task bar shows this:

...........^ "Acquiring Network Address" despite already being connected.

I found several sites on the internet where similar problems are encountered (such as this cnet forums article), and the advice seems to be that you should disable the Wireless Zero Configuration (WZC) service within Windows. I have done so by accessing RUN > services.msc and disabling WZC completely. Even after restarting several times, the problem still occurs. I've also tried turning off the option to "Notify me when this connection has limited or no connectivity" from the Network Connections part of the Control Panel - this still doesn't help. I've just updated to all the latest Intel software and drivers and I am still encountering this issue. It's getting a little (ok, a lot) annoying.

Does anyone know of a solution to this, or can suggest some way to make the "Acquiring Network Address" logo go away?
yjwong
I'm not sure, but it seems to be the Intel Wireless driver screwing up, not Wireless Zero Configuration. I've encountered a similar problem before, and the Wireless Network Connection Status dialog shows the connection speed being at 0 bps, and connection to an unnamed network. What I did to solve the problem was to perform a clean install of the driver. Remove the Intel PRO/Set Wireless Software and Intel Wireless driver completely, then reboot. Then once you reboot, download the installer from Intel's website then re-install.
Animal
Tried a fresh install of both the drivers and the Intel Pro Set Wireless software and the problem still remains. That's why I have a feeling it's a Windows issue. Any other ideas?
turbosquid
I have a Samsung X60plus with Intel Pro Wireless networking, It's set up as a duel boot system with XP pro and Linux (Ubuntu). I have also encountered this problem it seems to happen from time for no apparent reason, although it only seems to happen when using Win XP.
As you described i get the 'Acquiring Network Address' for about two minutes then I get a failed connection.

After getting a failed connection running 'ipconfig' i find windows has assigned itself a private IP address (169.x.x.x) which means that DHCP has failed.

To get the connection working again i normally end up resetting my router, this is not a fix just a workaround.
I can't seem to find the actual cause of the problem so would be interested to see if anyone else knows a fix.

TurboSquid
Jaan
Tried disabling the startup entry?
Run>Msconfig>startup> disable the intel proset. if you are not sure you can just hit disable all the reboot and check what you need.
Tried hard resetting your router? hold the reset button for 30 seconds or so, to perform hard reset to when you bought it. reset normally just reboots it.

Cheers
Animal
turbosquid wrote:
As you described i get the 'Acquiring Network Address' for about two minutes then I get a failed connection.

This may be caused by a WZC conflict if you use your network card's software to manage the wireless connection - this seems to be similar to other problems when I was trying to find a resolution. Try disabling the Wireless Zero Configuration service (via START > RUN > services.msc), reboot and see if the problem remains.

Jaan wrote:
Tried disabling the startup entry?
Run>Msconfig>startup> disable the intel proset. if you are not sure you can just hit disable all the reboot and check what you need.

This isn't much help if you actually want to use the Intel Pro Set software - as I've discovered, it performs much better than the built-in Windows WZC.

Jaan wrote:
Tried hard resetting your router? hold the reset button for 30 seconds or so, to perform hard reset to when you bought it. reset normally just reboots it.

turbosquid wrote:
To get the connection working again i normally end up resetting my router, this is not a fix just a workaround.
I can't seem to find the actual cause of the problem so would be interested to see if anyone else knows a fix.

Looks like turbosquid's already tried this solution Wink It's no help with my problem either.

I've still not managed to resolve the issue - are there any other suggestions?
Jaan
What about the config of the router?

And intel pro set uses profiles, i had a similar problem once where it just stayed connecting. I deleted all the profiles, and changed some other configs in the intel app, maybe mess around with that? Also try the config of the router?
Animal
Jaan wrote:
And intel pro set uses profiles, i had a similar problem once where it just stayed connecting. I deleted all the profiles, and changed some other configs in the intel app, maybe mess around with that?

Tried deleting the current profile, restarting, creating a new profile, reconnecting, restarting and the issue still remains - I guess this didn't help I'm sorry to say.

Jaan wrote:
What about the config of the router?... Also try the config of the router?

The config of the router has nothing to do with this issue since I'm fully connected and have full internet access. My previous WinXP laptop used an (older) Intel Pro Set Wireless card and it connected without displaying the "Acquiring Network Address" icon, so it's solely a software issue on my current laptop.

Thanks for the input though - feel free to keep the ideas coming!
DecayClan
Well, something that might be irrelevant, but, have you checked your firewall? I had the exact same problem, using my on-board wireless card at my laptop, but my firewall (comodo), blocked a service( can't remember which), and i had that exact problem... Try turning of the firewall, or other programs like that and try again.

This firewall and other firewalls, don't only block connections.

I hope that i helped.
Jaan
And another note: disable Windows XP firewall if you haven't allready. It may be as simple as Decay said. Disable firewall then check if it works and then forward ports or something?
Animal
Sorry for the delay...

I've tried disabling my firewall (ZoneAlarm Free Edition) and anything else from auto-running at startup and the "Acquiring Network Address" logo is still showing in the taskbar.

It's quite easy to get rid of (double-click on it, select Properties and hit OK), but it's still really irritating. However I can't seem to get any help on this at all. Intel have withdrawn email and phone support for their Wireless products, the PC manufacturer don't support software issues and have decided that the hardware is working fine (I tend to agree with them), and there doesn't seem to be anything on the Microsoft Knowledgebase.

I'm stumped. Brick wall
Related topics
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.