FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


hyperthreading on intel processors





riyadh
i have an intel processor with hyperthreading. can anyone tell me how to turn it off. unfortunately, nvidia drivers have an issue with hyperthreading which is preventing me from playing Sims 2. this is what is written in the readme document tht came with the game:
Quote:
PROBLEM: Game crashes soon after starting.
Some recent NVIDIA drivers have problems when running when Hyperthreading is enabled on your processor. Try updating your driver first. If this doesn't help, turning off Hyperthreading in your BIOS will workaround this issue. If you have no idea what Hyperthreading or BIOS is, it's probably not worth messing around with this stuff. Contact your video card manufacturer for assistance.
RiCtee
Well the information is in the readme.
Quote:
Try updating your driver first.

There might be a newer driver around that might support HT. So get the latest. If not then....
Quote:
turning off Hyperthreading in your BIOS

You have to go in BIOS. Depends on your motherboard, you have to press delete/f10/f8, I don't really know, when your computer boots up. There will be a setting to toggle HT on or off. Just check your motherboard manual.
riyadh
i havean intel pentium D processor but i don knw if it has hyper threading technology because there is no option in the BIOS for turning off hyper threading. and my video crad drivers r up to date
MeddlingMonk
Intel Celerons don't have Hyper-Threading. Intel Pentium 4s do. I've had a quick look around and what I've found seems to suggest that most Pentium Ds do not have hyper-threading (since they're dual-core, which is better than a hyper-threaded single-core). Check http://www.intel.com/products/processor/pentium_d/prodbrief800.pdf for more information.

My suggestion would be to check the motherboard manual. If there isn't an option (either physically onboard or in the BIOS), then you may need to update your BIOS. A word of caution, though: if you update your BIOS and anything goes wrong, that'll probably be the end of your motherboard.

Since you've got a dual-core CPU, it may actually be the dual-core nature of the CPU that's causing issues (check with the video card manufacturer). I have no idea how to solve this issue.
gnubug
This is something which has crept up lately, Games getting Hyper-Threading & Data Execution mixed up. This could possibly causing the problem. 2 ways I know of to fix these, one rather easy, the other I would recommend only if you get around your computer and don't mind fussing around with things...


The first way is easy just follow these steps.

1.Click Start, and then click ControlPanel.

2.Under Pickacategory, click PerformanceandMaintenance.

3.Under or Pick a Control Panel icon, click System.

4.Click the Advanced tab.

5.In the Performance area, click Settings.

6.Click the DataExecutionPrevention tab.

7.Select Turn on DEP for all programs and services except for those I select.

8.Click Apply, and then click OK. A dialog box appears and informs you that you must restart your computer for the setting to take effect. Click OK

The next restart follow the same guide, and then select the add button and add your game to the list, this will keep DEP from accessing the game or application.
gnubug
First of all, you need to be logged under an administrator account!!!
Do not attempt if you are unsure about completing the steps...


Disabling DEP system-wide using boot.ini


1.Click Start, and then click ControlPanel.

2.Under Pickacategory, click PerformanceandMaintenance.

3.Under or Pick a Control Panel icon, click System.

4.Click the Advanced tab, and in the Startup and Recovery area, click Settings.

5.In the SystemStartup area, click Edit.

6.In Notepad, click Edit and then click Find.

7.In the Findwhat field, type /noexecute and then click FindNext.

8.In the Find dialog box click Cancel.

9.Replace the policy_level (for example, "OptOut") with "AlwaysOff” (without the quotes).

WARNING: Be sure to enter the text carefully.

Note: Your boot.ini file switch should now read:

/noexecute=AlwaysOff

10.In Notepad, click File and then click Save.

11.Click OK to close StartupandRecovery.

12.Click OK to close SystemProperties and then restart your computer.
gnubug
Hope this helps getting your games and some applications working correct.
darkmetal123
You can simply turn off the hyper threading option in the BIOS.

I don't think that can improve the performance of your PC.

The reason is that every program does not support hyper threading. If that is the case then your CPU works at it's max speed to work out the program. If the program is designed to use the hyper threading feature then it will work better if the hyper threading option is enabled.

Cool
Related topics
The Best PC out?
AMD Open Letter
AMD VS. Intel
Overheated
Intel to adopt new logos
IBM or MAC for laptops??
Intel Vs AMD
What is better? AMD or Intel
The New MacIntels
Hardware Questions...
Macbook Pro Graphics
Pentium D or AMD Athlon 64 X2???
Mac's first virus
Photoshop CS2 to CS3, it worth it?
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.