FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


svchost.exe gone on rampage





greatfire
Every time I start up my computer (boot or bring it out of hibernation) svchost.exe sucks up 100% of cpu usage. I'm pretty sure its not a virus or spyware cos i have scanned for both several times. anyone have any idea what is causing this and how to fix it.
wumingsden
greatfire wrote:
Every time I start up my computer (boot or bring it out of hibernation) svchost.exe sucks up 100% of cpu usage. I'm pretty sure its not a virus or spyware cos i have scanned for both several times. anyone have any idea what is causing this and how to fix it.


It is probably a system process but it could also be a virus/trojan, etc, even if your anti-virus software doesn't pick anything up. This maybe useful determining what it is and what to do next.
Bones
Here is another link to a thread that discusses the same problem:
http://www.daniweb.com/techtalkforums/thread82.html

You will probably also want to download Process Explorer from here:
http://www.microsoft.com/technet/sysinternals/utilities/ProcessExplorer.mspx

That program should help to track down the culprit. As stated above though, a lot of the time this is caused by a virus on the system.

For a quick fix attempt, you might want to try running an sfc /purgecache followed by an sfc /scannow from the run line. Though you may need your Windows disk handy, and OEM restore disks dont generally work (although Dell ones usually do, and a few others)
realkiller
OMG i had a problem with that svhost.exe what the hell is it lol in my processors i had like 20 of them Very Happy crazy or what whats the best thing to do? :S iv tried loads and they all just keep comming Very Happy
JJGY
realkiller wrote:
OMG i had a problem with that svhost.exe what the hell is it lol in my processors i had like 20 of them Very Happy crazy or what whats the best thing to do? :S iv tried loads and they all just keep comming Very Happy


I've had a problem similar to this. About forty instances of the process began running, sucking up all of my CPU. For some reason they were kicked up to a high priority as well, although the original was not. The problem hit at a time when I was about to reformat anyway however, so the fix was obvious.
mystzero
I've been haunted by the same problem before. After doing some research, i found out that the culprit is Windows Update. The proof is when i disable Automatic Update, svchost.exe will stop being frenzy. However, when i turn on Automatic Updates again, the problem went on. Somehow, i just couldn't understand why Windows XP establishes a connection with Windows Update server on every startup.

Anyway, after so long, Microsoft has finally released a hotfix for this problem. You can download the hotfix here:

http://support.microsoft.com/kb/916089/
DecayClan
Well, how does it get 100%? I mean,i had a similar problem, that when i clicked on any file, svchost, consumed 100%... That was caused by a virus...

Try scanning with a\n other program, and try stinger, that can detect some stuff that other programs don't. But in any case, it is almost ceratin that this is caused by a virus...

I would get the HDD out, install it to an other computer as slave, and start scanning it with many programs, to fix he problem.

If that doesn't work:

Also, log into safemode, go to start\run\msconfig, go to the last tab, and disable everything, and at the services tab, shut down what you don't need, and then restart your computer in normal mode. If this helps, then try reactivating them slowly, in order to find out what is causing it...
greatfire
thanks everyone. It was the windows automatic update thing. I turned it off and my computer runs fine, im about to apply the hotfix
johanfh
Just one thing about svchost: it's the 'SerViCeHOST', a small program wich is used as a host for some other process. That process can be almost anything, so if you have problems with svchost, use the above mentioned process explorer. Look in that program wich instance of svchost is the bad proces (there can be multiple harmless svchosts for different services) and check wich service it is running.

JohanFH
KHO
Actually, you can safely delete the file from system32 altogether and the system cache will restore it. If it has become malformed, this will likely fix it, if it is a virus, then the creator of the virus would know to infect the cached copy also, so then it would yield no results. Try giving that a shot. Also, there is a command to restore all the system files to the original state. I don't know it offhand, but try google-ing for it.
et-configs
That works with your sound device. Check you soundcard
rheanna
believe it or not i seem to have the same problems
daviosoftware
I had the same problem. But the problem was at my office computer. I talked to the network guis and they fixe-it. The process was started by some network antivirus.
internetjobs
svchost.exe is related with rpc service, remote procedure call, dont do anythis with this service, like stoping or disabling, then u will get a big problem, the solution for this is update latest all security patches. it will solve your problem, but i am not sure about it
Related topics
Virus Problem
What programs do you run
Zone Alarm Popup constantly
processus windows
explorer.exe
Help: I can not change background of laptop. XP(Sp2)
Is it a Virus?!?!
svchost.exe
problem z services.exe
HelpSVC.exe and svchost.exe using up your resources?
SVHOST.EXE error!!!
HELP problem in Svchost.exe
winsit.exe
svchost.exe error, superfetch?
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.