FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Creative Audigy Driver for Ubuntu...





Animal
Hi all,

I was looking for some advice regarding drivers for my Creative Audigy 2 ZS Notebook PCMCIA sound card under Ubuntu. I've been doing some research online and can't find anyone with the same specific problem as me. I posted the following on the Ubuntu Forums but as yet haven't had any answer. If anyone could offer any help with this, it would be most appreciated.

I posted on the Ubuntu forums and wrote:
I've been trying to install the alsa drivers for my Creative Audigy 2 ZS Notebook card. However, following instructions both on this site and the alsa site itself, I keep getting the following error:

Quote:
checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


I've run the modinfo soundcore command and I get the following:
Quote:
filename: /lib/modules/2.6.15-28-386/kernel/sound/soundcore.ko
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.15-28-386 preempt 486 gcc-4.0
depends:
srcversion: DD426F1CCA2CC5F060F6F92


Despite trying to include the option --with-kernel=/lib/modules/2.6.15-28-386/kernel/sound/soundcore.ko and --with-kernel=/usr/src/linux, I can't get past this error. Unfortunately, web searches have been fruitless so far too!

Could anyone please try to explain what the problem may be and how I could possibly fix it? I'm not an entire noob when it comes to Ubuntu, but I've not really installed or compiled too much from the Terminal. I should say that I'm running Ubuntu Dapper Drake (6.06), and I'm trying to install the most recent alsa packages (at time of posting).
Blaster
Animal i will try to find out your problem. It might take a while though. I would suggest starting your own topic on ubuntu forums and if it isn't answered then bump it. Also make sure it is in the new user forum because that is the forum that makes it easiest to get support in.
djclue917
Animal wrote:
checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


You should install the kernel source package: linux-source-2.6.15
After installing, the ./configure script would most likely find where the kernel sources are so you wouldn't have to explicitly specify where they are.

Quote:
Despite trying to include the option --with-kernel=/lib/modules/2.6.15-28-386/kernel/sound/soundcore.ko


This actually does nothing because soundcore.ko is only a kernel module and not the whole kernel itself.
Related topics
The Best PC out?
Windows XP the best?
DVD ROM and Listening to Audio Problem...
UBUNTU HELP!!
Your dream computer?
No Sound - Suddenly Stopped *RESOLVED*
HDTV card
What audio setup does everyone have?
which creative sound card is better?
Ubuntu
Need advice about building a System
Windows Vista. Jakie macie o nim zdanie???
Stuttering Sound When Playing Couner-Strike: Source
windows XP or swap to VISTA
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.