FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Images not displayed





mawia
I have uploaded my files using AceFTP and it can be browsed but the images could not be displayed. I used Frontpage for designing my website and I already enabled the Frontpage extension in DirectAdmin. Have I not uploaded my files correctly? Please help.
wumingsden
mawia wrote:
I have uploaded my files using AceFTP and it can be browsed but the images could not be displayed. I used Frontpage for designing my website and I already enabled the Frontpage extension in DirectAdmin. Have I not uploaded my files correctly? Please help.


Looking at your source code it looks like the images have not been uploaded into the correct place. For example, I took the following from your source code but they do not exist (some paths you also shouldn#t use/are also not possible)....

www.yoursite.frih.net/_themes/copy-of-blocks-home/blobkgde.gif
www.yoursite.frih.net/box_01.gif
www.yoursite.frih.net/_derived/home_cmp_rmnsque100_vbtn_p.gif
www.yoursite.frih.net/_derived/about.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/_derived/faculty.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/_derived/extension.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/_derived/library.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/_derived/photogallery.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/_derived/students.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/_derived/alumni.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/_derived/feedback.htm_cmp_rmnsque100_vbtn.gif
www.yoursite.frih.net/images/Content%20bar/content-bar-sample-trcnews.gif
www.yoursite.frih.net/_themes/copy-of-blocks-home/blobul1e.gif
www.yoursite.frih.net/images/Content%20bar/content-bar-sample-1news-2.gif
www.yoursite.frih.net/photos/NAAC-lecturers-home.jpg
www.yoursite.frih.net/images/Content%20bar/content-bar-sample-1career.gif
www.yoursite.frih.net/images/Content%20bar/content-bar-sample-1links-2.gif
mawia
Thanks for the response. I dont know what you mean by 'some paths you should'nt use'. Now can I delete all the files I uploaded earlier? What files should I not touch? I want to upload again. Please help.
rheanna
path should be in html

"/images/certain.gif"

example
img src="/images/certain.gif"

put all your images in a folder called "images" so you can keep track
wumingsden
mawia wrote:
Thanks for the response. I dont know what you mean by 'some paths you should'nt use'. Now can I delete all the files I uploaded earlier? What files should I not touch? I want to upload again. Please help.


What I mean by the paths that you should use are, for example, the yoursite.frih.net/_derived/about.htm_cmp_rmnsque100_vbtn.gif

I don't this path would work. It has to be something like yoursite.frih.net/_derived/about.htm/cmp_rmnsque100_vbtn.gif but even then it's not the best way to do it......

Like the member suggested above, it may be easier to create an images directory in your root and moving all of the images there. You should then change the path of the file to represent this. For example,

yoursite.frih.net/_derived/about.htm_cmp_rmnsque100_vbtn.gif

would become...

yoursite.frih.net/_derived/images/cmp_rmnsque100_vbtn.gif

Note: The _derived in your URL confuses me. Do you want people to go to www.yoursite.frih.net/_derived/about.htm ? Or www.yoursite.frih.net/about.htm ?
tidruG
I have discovered your problem
Take a look:
http://trc.frih.net/Myweb7/index.htm
It appears your website is in a folder called Myweb7 which is in the public_html folder.

Here's where I think you have made a mistake:
Can you tell me how you have uploaded your files?
If you are using Microsoft Frontpage, your best bet would be to use it's in-built "Publish" option.

Let me know if this is what you did or if you need more help with how to publish using frontpage.
mawia
Thanks everyone for helping. I have mentioned that I used AceFTP to upload my files and that I used Frontpage to build the website.

Yes, as Wumingsden pointed out the problem lies in incorrect image source path. This is because I changed the directory of the folder 'myweb7' from F drive(where I created) to D drive (where I uploaded). I think the image path still points to the F drive whereas they are actually on D drive.

I will work on this as soon as possible.
kingkong
You should point your image file on the server rather than local drive. If you point to your local drive that will cause nobody will be able to see your image display on the site (except yourself).

Use related path something like /images/yourpic.gif or ../images/
try it with your browser.
Related topics
Pluto is no longer a planet
[tutor] How to protect images without htaccess using PHP
Images in avatar gallery
Images with an invisible background.
*Poof*... Bye bye Images
Rollover Buttons or Images
W3C buttons without images
Some nature's images
Good photoshop images
Increased Avatar pixel limit
wont load images
Jackson - Not Guilty
all images appear corrupt!
What do you use to make your page layout?
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.