FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Joomla + SEO doesn't work





oleszka
When I switch on in Joomla SEO=> SEF URL's =ON and then renamed htaccess.txt into htaccess .... links of my site don't work... just 404 error pages appear .. what to do ?
pashmina
hmm.. I am not familar with joomla SEF, but i could help you with ARTIO SEF
i have implemented ARTIO SEF on my site http://pashmina.frih.net
oleszka
pashmina wrote:
hmm.. I am not familar with joomla SEF, but i could help you with ARTIO SEF
i have implemented ARTIO SEF on my site http://pashmina.frih.net


i heard smth about Artio. where I can download it?
pashmina
http://extensions.joomla.org/component/option,com_mtree/task,viewlink/link_id,1063/Itemid,35/
I can help if it doesn't work cheers
oleszka
pashmina wrote:
http://extensions.joomla.org/component/option,com_mtree/task,viewlink/link_id,1063/Itemid,35/
I can help if it doesn't work cheers

thanx for link. I have installed this component via admin panel. also i replaced non-latin characters as it was said in readme file (because my site is in Russian)...
but still have problem... urls don't work instead of them just 404 error page
may be i should do smth in configuration?
mathiaus
Did you name it htaccess or .htaccess (dot at beginning?). If the former, do the latter.
oleszka
mathiaus wrote:
Did you name it htaccess or .htaccess (dot at beginning?). If the former, do the latter.

yes it works!
but now i got another problem.... I can not login into admin panel...
it always asks me to login again and again... during logining it shows
Quote:
Warning: session_start() [function.session-start]: open(/domains/top-literature.frih.net/tmp/sess_2d7b3d3488289494c143c55f092e0609, O_RDWR) failed: No such file or directory (2) in /home/oleszka/domains/top-literature.frih.net/public_html/administrator/index.php on line 95

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/oleszka/domains/top-literature.frih.net/public_html/administrator/index.php:95) in /home/oleszka/domains/top-literature.frih.net/public_html/administrator/index.php on line 95

Warning: session_write_close() [function.session-write-close]: open(/domains/top-literature.frih.net/tmp/sess_2d7b3d3488289494c143c55f092e0609, O_RDWR) failed: No such file or directory (2) in /home/oleszka/domains/top-literature.frih.net/public_html/administrator/index.php on line 138

Warning: session_write_close()
pashmina
does your .htaccess file looks something like this
Code:

##
# @version $Id: htaccess.txt 4756 2006-08-25 16:07:11Z stingrey $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
# Only use one of the two SEF sections that follow.  Lines that can be uncommented
# (and thus used) have only one #.  Lines with two #'s should not be uncommented
# In the section that you don't use, all lines should start with #
#
# For Standard SEF, use the standard SEF section.  You can comment out
# all of the RewriteCond lines and reduce your server's load if you
# don't have directories in your root named 'component' or 'content'
#
# If you are using a 3rd Party SEF or the Core SEF solution
# uncomment all of the lines in the '3rd Party or Core SEF' section
#
#####################################################

#####  SOLVING PROBLEMS WITH COMPONENT URL's that don't work #####
# SPECIAL NOTE FOR SMF USERS WHEN SMF IS INTEGRATED AND BRIDGED
# OR ANY SITUATION WHERE A COMPONENT's URL's AREN't WORKING
#
# In both the 'Standard SEF', and '3rd Party or Core SEF' sections the line:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# May need to be uncommented.  If you are running your Joomla/Mambo from
# a subdirectory the name of the subdirectory will need to be inserted into this
# line.  For example, if your Joomla/Mambo is in a subdirectory called '/test/',
# change this:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# to this:
# RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##optional - see notes##
#
#####################################################


##  Can be commented out if causes errors, see notes above.
Options FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On


#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla/MamboDirectory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
############# Use this section if using ONLY Joomla! core SEF
## ALL (RewriteCond) lines in this section are only required if you actually
## have directories named 'content' or 'component' on your server
## If you do not have directories with these names, comment them out.
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]       ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
RewriteRule ^(content/|component/) index.php
#
########## End - Joomla! core SEF Section



########## Begin - 3rd Party SEF Section
############# Use this section if you are using a 3rd party (Non Joomla! core) SEF extension - e.g. OpenSEF, 404_SEF, 404SEFx, SEF Advance, etc
#
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]       ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
#
########## End - 3rd Party SEF Section



########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#                             
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

oleszka
i solved it... problem was in .htaccess file.... where I wrote php_value session.save_path "/domains/top-literature.frih.net/public_html/tmp"... i don't know why but without this ...all works.. Rolling Eyes
anyway thanx to all for help with SEO


-----

to pashmina: yes NOW it looks like this Smile
pashmina
Because that was the code which i had inserted on .htaccesss file.
you had to add this code on your htaccess file. This code is for 3rd Party SEF
Code:

########## Begin - 3rd Party SEF Section
############# Use this section if you are using a 3rd party (Non Joomla! core) SEF extension - e.g. OpenSEF, 404_SEF, 404SEFx, SEF Advance, etc
#
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]       ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
#
########## End - 3rd Party SEF Section

and enable SEF on the global configuration.

when i entered your site i found that SEF was not enabled. make sure you enable them
oleszka
hmmm may be i was testing smth when you went to my site :-S

check now, please...does it work?

some links look like
Code:
http://www.top-literature.frih.net/otvety/otklyuchenie-pokaza-uvedomlenij-notice.html?Itemid=1

is it ok that at the end such ?Itemid=1 ?
pashmina
it shouldn't look like that!
check out the settings.
oleszka
pashmina wrote:
it shouldn't look like that!
check out the settings.


so now i moved all Joomla to www.top-literature.com

what you have in Advanced Configuration??

Exclude source info (Itemid)
Reappend source (Itemid)
Append non-SEF variables to URL
Related topics
Is there any free forum software as good as Invision?
Regular Expression - get content of a cookie
MamboOR/CMS Realty?
Help with Dreamweaver sessions !!!!!!!!
Internet Explorer
Windows XP or HDD?
Mambo 4.61 Addons
Content Management Systems (CMS)
Problems with Dynamic URLs
Joomla + Wordpress?
Joomla slow-ness
Problem installing joomla!
[TuT]JOOMLA Installation Guide(Easiest Way)
[TuT]JOOMLA Installation Guide (Less Easy Way)
Reply to topic    Frihost Forum Index -> Scripting -> Php and MySQL

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.