FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


USB Mass Storage device gone nutz





ronald.helpdesk
Hello guys... I have a brand new Mac OS X and I'm experiencing some troubles with my usb flash drive, when I plug the device in a free usb port, it doesn't appear to be anywhere in the world, finder don't get it... not on the desktop, not mounted, but... it is right there if I check the profiler.... so physically is there, but not working.

I found out something today, I've been working with a usb HID Mouse, I unplugged it and place the flash drive instead of it, and IT WORKED !!!!!!!! it pop up right there, where it's supposed to... but, never in the other port, then I switched the whole thing, I shutted down the mac, plugged the mouse in other port, and the very same thing happened... but, in the other port.

What the hell am I doing wrong?

P.S. I'm kindda new in this Mac World... please be kind.
RiCtee
Could it be something wrong with that one USB port?? Or something if the compatibility.
kuyman
To me it sounds like a problem of a powered USB port. There are unpowered and powered USB ports. Powered ones transfer data and have 5 volts of current passing through them to power any external device that may need it. Your mass storage device may need this power and that could be why it worked in the port where you had your mouse plugged in to.

What Mac are you using? What version of OS X? What kind of mass storage device?

If it continues not to work even after you tried a powered USB port, you should look up the model number of the device on a Mac forum like the one at macrumors. If you find it isn't Mac compatible, maybe you could take it back to the retailer to exchange it.

Best of luck
ronald.helpdesk
This is one of those weird experiments one does to our non lucky computers, is an intel based system, I downloaded a Mac OSX Tigger version, for intel, and it worked to certain point smoothly, but... (there's always a "but") I'm not able to install software, everytime I mout the installation images, the damn thing does something weird now, and the mass storage stuff, is very weird too... hehe it has to be a powered usb port, cuz it's atached to the mainboard, and jumpered to be powered just in case, I don't know what went wrong with that, anyway, I tried the very same os in a Gateway Laptop, the usb thing worked well, but the installation issues could never been resolved, by me at least, I'm kindda newbie with this mac stuff, I like it, but I'm getting a little frustrated.

kuyman wrote:
To me it sounds like a problem of a powered USB port. There are unpowered and powered USB ports. Powered ones transfer data and have 5 volts of current passing through them to power any external device that may need it. Your mass storage device may need this power and that could be why it worked in the port where you had your mouse plugged in to.

What Mac are you using? What version of OS X? What kind of mass storage device?

If it continues not to work even after you tried a powered USB port, you should look up the model number of the device on a Mac forum like the one at macrumors. If you find it isn't Mac compatible, maybe you could take it back to the retailer to exchange it.

Best of luck
Related topics
Xbox 360 vs PS3
psp how good?
what software for all drive of usb flash disk 98se
USB2 Mass Storage Device
Flash memory on windows 98
using gsm phone as a web cam?
I'm trying to connect two computers via crossover cable...
HD-DVD vs. Blu-Ray Simplified by Three Panel Soul
MP3 player hard driver recovery?
Partion deleting
Help to install pen drive in windows 98
For those who want speed.
USB ports
iPod as a storage device
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.