FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Please help. Major Problem with Linux on external Harddrive.





Dougie1
Well I installed Ubuntu (version of Linux) on an external hard drive and that was all fine. I restarted the computer and then unplugged my hard drive and got a GRUB 21 error. I crapped myself. I thought I had broken my computer. So I frantically plugged my hard drive back in and rebooted. It came up with a menu with what OS to boot. Ubuntu or Windows. Now this only comes up if I have my external hard drive is plugged in, otherwise I get the error. My did is pissed off because he doesn't like this added annoyance and I am also annoyed as I have to keep my hard drive plugged in which was not the point in having an external hard drive. Does anyone know how I would stop this happening. I am willing to un-install ubuntu. Thanks
Animal
Dougie1 wrote:
Well I installed Ubuntu (version of Linux) on an external hard drive and that was all fine. I restarted the computer and then unplugged my hard drive and got a GRUB 21 error. I crapped myself. I thought I had broken my computer. So I frantically plugged my hard drive back in and rebooted. It came up with a menu with what OS to boot. Ubuntu or Windows. Now this only comes up if I have my external hard drive is plugged in, otherwise I get the error. My did is pissed off because he doesn't like this added annoyance and I am also annoyed as I have to keep my hard drive plugged in which was not the point in having an external hard drive. Does anyone know how I would stop this happening. I am willing to un-install ubuntu. Thanks

By installing Ubuntu, this has taken over your master boot record and has replaced it with Grub. Grub is located on your Linux partition, so as you've discovered, it won't boot unless the external hard disk is plugged in.

I'm fairly sure it's possible to boot Windows and Linux from the Microsoft boot loader, but I don't know how to do this. The easiest way to fix it is to insert your Windows CD to the CD drive, reboot the computer and load the Windows Recovery Console. Type fixmbr and reboot.

This will restore your original Windows boot record, but will mean that Linux will no longer be able to boot at startup.
Dougie1
So doing this reset windows on my computer back to default? Just make it the primary boot?

EDIT. Unfortunately my computer did not come with a window cd so unfortunately this is not an option. Thanks for the help but do you know where I would find alternate methods to do this.
SamiTheBerber
Dougie1 wrote:
So doing this reset windows on my computer back to default? Just make it the primary boot?

EDIT. Unfortunately my computer did not come with a window cd so unfortunately this is not an option. Thanks for the help but do you know where I would find alternate methods to do this.

What kind of errors are they? Is your drive on /etc/fstab so it is tried to load on start up? Are you sure that errors come on grub? Could there be anything on grub files that appoints to external hdd?

Those questions will help us to solve your problem.
Dougie1
SamiTheBerber wrote:
Dougie1 wrote:
So doing this reset windows on my computer back to default? Just make it the primary boot?

EDIT. Unfortunately my computer did not come with a window cd so unfortunately this is not an option. Thanks for the help but do you know where I would find alternate methods to do this.



What kind of errors are they? Is your drive on /etc/fstab so it is tried to load on start up? Are you sure that errors come on grub? Could there be anything on grub files

Those questions will help us to solve your problem.

The only error is because of GRUB not being able to load due to it being installed on the external hard drive.

My drive is attached to the USB port but I don't know what you mean by /etc/fstab.

The GRUB files are on the external hard drive and point to the external hard drive as an OS.
Animal
This Microsoft Knowledge-Base article might help you. However, I can't fully follow it.

As far as I know, you will need to get the Windows Recovery Console to run - this may entail creating some boot disks as you don't have the XP CD. However, it may be most beneficial for you to try installing Ubuntu (or another distro such as Damn Small Linux - I don't have any experience with this though) on a new (small) partition on your existing hard disk. This will replace the existing Grub boot loader that references your external HD, and you can then set Windows to load by default.

Have you checked if you were given a "recovery CD" with your PC? If so, the recovery console might be on this CD. If not, the alternative would be for you to contact your PC manufacturer and ask them to provide you with a recovery CD that includes the Recovery Console.
SamiTheBerber
Dougie1 wrote:
The only error is because of GRUB not being able to load due to it being installed on the external hard drive.

My drive is attached to the USB port but I don't know what you mean by /etc/fstab.

The GRUB files are on the external hard drive and point to the external hard drive as an OS.

When you installed Ubuntu, you should install /boot in part of your internal HDD, not in external. Windows installing CD in and repair installation.

/etc/fstab is file, where is mounting information. cat /etc/fstab will show what you can mount automatically and where it will mount.
ezekiel_rage
Dougie1 wrote:
Well I installed Ubuntu (version of Linux) on an external hard drive and that was all fine. I restarted the computer and then unplugged my hard drive and got a GRUB 21 error. I crapped myself. I thought I had broken my computer. So I frantically plugged my hard drive back in and rebooted. It came up with a menu with what OS to boot. Ubuntu or Windows. Now this only comes up if I have my external hard drive is plugged in, otherwise I get the error. My did is pissed off because he doesn't like this added annoyance and I am also annoyed as I have to keep my hard drive plugged in which was not the point in having an external hard drive. Does anyone know how I would stop this happening. I am willing to un-install ubuntu. Thanks


If you dont have a Windows CD, you can just use a windows 98 boot floppy, then on DOS type:

fdisk /mbr

it will reset the MBR

if you dont know where to get a win98 boot disk try to search in google, you can download an executable thaty will automatically write to a floppy the needed files.


Hope this helps
ezekiel_rage
Dougie1 wrote:
... I am also annoyed as I have to keep my hard drive plugged in which was not the point in having an external hard drive. ...


If you want to have liunux installed in your external hard drive, may i suggest that you install Knoppix instead?

To install without messing your dad's hard drive, first unplug the hard drive.

Plug in your external Hard Drive
Boot from your knoppix CD

and then install knoppix

do not select debian-like in the install type choices.

Then everytime you like to boot linux with your external hardrive, just select USB-hard drive as the primary boot device in the BIOS

or you can set your boot device priority like this

1. USB Hard Drive
2. your dads' hard dive
3.CD-ROM
4.Other boot device

But to successfully use this method, your Motherboard must support booting from a USB device

Hope this helps

And tell your dad to chill
Related topics
simple php problem, please help...
Major Problem with COmputer. Help Please
Please help. I have a problem with installing FreeBSD
Problem with MySQL Server Please Help!!
Please Help Packet Problem
Someone please help
A problem.. please help
Please help regarding editing of index file
Which is the source of the problem???PLEASE HELP ME!!!
Anyone please help me!
Internal Server Error in Joomla, Please help!
undecided on what to use ---> please help
Please help me
help me please with my problem
Reply to topic    Frihost Forum Index -> Computers -> Operating Systems

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.