FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Warcraft III port forwarding





Sparda
Hi, I kinda need some help with opening and/or forwarding ports for Warcraft III The Frozen Throne. I have tried visiting portforwarding.com for help, but I get an error message when doing what the site told me to. "Not enough space" I tried to enable ports, but I got that message.

I have a D-Link wireless router DI - 624M. My gateway is 192.168.0.1

I am to open and forward ports 6112-6113. Also I am using a wireless connection, so does that mean I cannot create a game on Warcraft III even if I would forward/open ports?

Any information or support appriciated.
PS: It lets me create games for my local area connection computers to join if I have their Custom IP entered open in my firewall.
Animal
Usually when setting up port forwarding, you need to point the ports at your specific computer rather than your gateway. I've not used D-Link before, but I would assume it's a similar set up to my Netgear wireless router.

The first problem you'll have is that DHCP is enabled, meaning you might be assigned a different LAN IP address every time you restart your computer. You can change this though (I'll assume your using Windows):

Firstly, make sure you're connected to your router, then hit START > RUN > cmd
Then type ipconfig /all and hit enter. Write down your DNS servers, subnet mask and IP details then close the window.

Now, go to START > SETTINGS > NETWORK CONNECTIONS, right-click on your wireless network connection and hit PROPERTIES. Select INTERNET PROTOCOL (TCP/IP) from the list and hit the PROPERTIES button. Then select the radial buttons for "Use the following IP address" and "Use the following DNS servers". Enter the information in here that you got from IP Config (your default gateway will be 192.168.0.1).

A quick word of warning before we continue: If you use your computer on another wireless network, you will need to deactivate these settings manually - just change them back to "Assign an IP address automatically".

Ok, now go back to your router settings and assign ports 6112-6113 to the IP address you've selected for your computer (for example 192.168.0.3). This should now work, but make sure you're running a decent software firewall since this will open your computer up to incoming attacks on these ports.

HTH Very Happy
Sparda
I am trying to add this rule to allow ports 6112-6113, but I still get this:
http://www.freewebs.com/jarock/errorw.bmp (1.19MB)


I did everything that you said to do. I am still getting the same thing.
How do I do this if it does not allow me to add a new rule?
tommyjordache
No luck at http://www.portforwarding.com ??

cheers

tom
Straevaras
tommyjordache wrote:
No luck at http://www.portforwarding.com ??

cheers

tom


Bookmark that site. It will cover virtually every router out there for virtually every application that you might need port forwarding for.
Animal
Sparda wrote:
I did everything that you said to do. I am still getting the same thing.
How do I do this if it does not allow me to add a new rule?

This may be an error caused because you're trying to make a public port and a private port the same - I think these have to be different (unless otherwise stated in the WOW manual?)
Sparda
To Tommy: I did try portforwarding.com forums too, but I cannot make an account for the forums for some reason.

To Animal: It says I need to have a Private Port. What I think it means by not enough spaces is that there is no more room for another server. And why would I need a WOW manual?

Any suggestions?
DesChut3s
I'm not quite sure what the others were saying, so I'll start fresh.

I don't believe you stated, but I'm assuming your trying to run your own game of WC3. Routers, not modems, are complicated in a way that they only allow certain packets to transfer through the router. When connecting to a game, your only receiving data and there's no need for alternate communications. Though, when sending data as if you were running your own server, the router tends to block it due to 'incoming handlers'.

I don't know why those virtual server/DNS objects are there, but nevertheless, you basically need to delete one in order to add a new rule. You need to enable those ports to move to your local IP address. Keep in mind, local IPs are much different then ISP IPs. Simply go into command prompt(START >> RUN >> TYPE CMD >> HIT ENTER) and type ipconfig to get your local IP address. In which case, you use that as the destination of the ports. So simply delete one of those rules, and add a new one forwarding those ports to your local IP.

Good luck.
tommyjordache
For portforwarding account : do not use a hotmail or yahoo account...doesn't work
DesChut3s
tommyjordache wrote:
For portforwarding account : do not use a hotmail or yahoo account...doesn't work


Why use a tool when you can do it yourself just as easily?
tommyjordache
DesChut3s wrote:
tommyjordache wrote:
For portforwarding account : do not use a hotmail or yahoo account...doesn't work


Why use a tool when you can do it yourself just as easily?


You got a point there...but hey...not everyone is a pc wizard, are they ?
cheerio
tom
Sparda
To DesChut3s: Would it be safe for my computer to delete a virtual server? I would like to create a game on Warcraft III, but I would not like to make my computer valnurable to hackers. If this is ok, which rule should I delete?

I see that you said that a modem cannot be the problem, but I use to have just a modem and could not host at that time either. Are you sure the modem doesn't block it also?

~Thx
DesChut3s
I looked a little closer at that list in that screenshot. From the looks of it, that doesn't look like port forwarding. But if that IS your port forwarding management, just get rid of the Telnet one - you won't use that. If your worried at all about those, you could just open up DMZ on your local IP. That would essentially forward every port to your computer. Unfortunately, it would leave your computer open to some serious attacks. So a firewall would definitely be a good idea; but keep in mind, a software firewall is just as likely to block WC3 as much as a router is to. So you'll need to use something like ZoneAlarm Free that you can configure on a software by software basis.

In my honest opinion, unless your going around on site that you really shouldn't be going to, I don't see much danger in opening up DMZ. The worse that could happen: your IP is logged somewhere, scanned for open ports, and a few DOS attacks are tried. But in either case, NEVER USE CREDIT CARD OR BANK ACCOUNT NUMBERS OVER A DMZ HOST!!! That's the worse you can do, because if someone is monitoring all traffic... -gulp-

Anyways, good luck... I hope you can get it all working.
Sparda
I disconnected my computer form the D-link router and connected directly to the modem to see if the modem was blocking it, and sure enough it was. I unblocked it tried it out and presto! I can create the games for Warcraft III. I think D-link is still blocking it, because I want to share my internet and also host for warcraft III. How do I forward all ports for my D-link router? I went to DMZ but there a a choice of Enable or Disable and a last digit for an IP. I tried enabling it and puting my default gateway for Ip because I did not know what to put. I couldn't create a game with the dlink. Any ideas so I can have shared internet with D-link and be able to create games on Warcraft III?

Edit: It seems I also need to have port 6112-6119 UPD forwarded also. What rule should I delete for this rule to be added?
Sparda
Ok, so I deleted a rule. I add ports 6112-6119 UPD. Click Apply. Continute. And what do you know? The WarcraftIII2 is TCP. When I clearly added UPD. For some reason it keeps changing UPD to TCP for some weird reason. Before I click apply for changes it shows UPD. But after I look at the list of servers it show TCP. I went try to see if it was working on warcraft III because maybe it was a text error and its still not working. Why won't it cooperate with me and open the UPD ports?

Any suggestions?
tommyjordache
I had a similar problem with my USR Router...but then with a IP camera...nothing helped, untill I first disabled the firewall on the USR completely, then disabled my software firewall, restarted => it worked ! I then re-enabled my software FW & it automatically adjusted...now it works...
Maybe this helps ?
cheers
tom
Sparda
Nope. That did not help. I cannot disable my firewall router and it is not the firewall blocking it anyway. It just won't let me forward UPD ports.
jayro11
i have a mac os x 10.5.6 and i got onto my netgear WGT624 v3 and i have everything setup i know what the gameport is... but idk what to put for the incoming and outgoing stuff.. can somebody please help
gs-resume
The other thing that you may want to try is to install 3rd party firmware on your router. This typically gives much more flexibility for traffic configurations and so forth. open-wrt is an option.
Related topics
Favourite game? (OFFICIAL THREAD)
Port Forwarding
Warcraft III - Frozen Throne ( Cheat code )
Warcraft III: Frozen Throne
Speed up Internet?
QUIEN JUEGA O HA JUGADO WARCRAFT III (REING OF CHAOS)?
WARCRAFT
Cisco 2821 port forwarding
Anyone know some good RTS games!
Warcraft III (Favourite Game)
Port forwarding problem on bit torrent client
Warcraft III play without disk
How to Host on Warcraft III with Windows
Warcraft III Roster Parse
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.