FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


[Ubuntu] OpenGL





Arno v. Lumig
Hello,

I've just recently downloaded an game and when I tried to start it it told me that I should install OpenGL, and check if my video card supports it. I am sure my video card supports it, but I can't remember I ever installed OpenGL on linux.

Is there any way I can do this? The manufacturer of the graphics card did not send a cd with linux-drivers...

The graphics card I'm using is an NVIDIA MX 420 (ancient thing...) and I'm using Ubuntu Dapper Drake.
My processor is 1,6GHz AMD 32-bit.

I'm rather new to linux, so forgive me that I don't know these things...


Greetz,
Arno
Nyizsa
Do you have an NVIDIA driver installed? I think you can get it from their homepage, but it must be also available from the repository.
If you have it installed, try installing the xlibmesa-gl package.
Arno v. Lumig
I have downloaded the right NVIDIA driver, but when I try to install it it says that I have an X server running and that I should disable it.
How do I do that? X -terminate returns error:

Code:
root@arno-desktop:/home/arno# X -terminate

Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.

root@arno-desktop:/home/arno#


The exact error message NVIDIA gives me is:

Code:
 ERROR: You appear to be running an X server; please exit X before
         installing.  For further details, please see the section INSTALLING
         THE NVIDIA DRIVER in the README available on the Linux driver
         download page at www.nvidia.com.



My grahics card is an NVIDIA GeForce MX 420 (I guess...)


Other information on the driver-tingies:
Code:

root@arno-desktop:/home/arno/Desktop# egrep -i 'driver|dri|glx' /etc/X11/*.conf
        Load    "dri"
        Load    "glx"
        Driver          "kbd"
        Driver          "mouse"
  Driver        "wacom"
  Driver        "wacom"
  Driver        "wacom"
        Driver          "nv" <--- Note: This should be nvidia if the driver is installed
Section "DRI"


Thanks in advance,
Arno
Nyizsa
Go to a terminal by pressing Ctrl-Alt-F1. Then you should be able to stop X. If there is a desktop environment also running, you may have to stop that first. Look for gdm or kdm among the processes.
Code:
ps -e |grep gdm

An other solution: there should be a boot option to boot the computer in maintenance mode. This way X won't even started, you get a console login. Type the root password (you need to be root anyway), and then try to install the NVIDIA driver.
djclue917
Arno v. Lumig wrote:
Hello,

I've just recently downloaded an game and when I tried to start it it told me that I should install OpenGL, and check if my video card supports it. I am sure my video card supports it, but I can't remember I ever installed OpenGL on linux.

Is there any way I can do this? The manufacturer of the graphics card did not send a cd with linux-drivers...

The graphics card I'm using is an NVIDIA MX 420 (ancient thing...) and I'm using Ubuntu Dapper Drake.
My processor is 1,6GHz AMD 32-bit.

I'm rather new to linux, so forgive me that I don't know these things...


Greetz,
Arno


Ubuntu ships with a great documentation/help/HOWTO for beginners. As far as I can remember, HOWTOs for enabling hardware acceleration for ATI and NVIDIA are already included in the documentation. Just open yelp (help browser for GNOME), then look for the section concerning Hardware. You'll easily spot specific instructions upon looking at the docs. I hope that helps...

By the way, since you said that your video card is somewhat ancient, I think you'll need to install the nvidia-legacy drivers. Anyway, Ubuntu's user manual/doc is really very easy to follow. You may also want to read more stuff from it and learn a lot in very little time. Smile
nox-Hand
I suggest getting automatix ( google it )

It has an automatic option that allows you to get the nVidia driver Smile
corey
If you want to kill the X Server, hit CTRL+ALT+BKSPC a few times until all that remains is the console.
nox-Hand
Or, do the right thing, going to console 1 by pressing Ctrl+Alt+F1, logging in, then doing sudo /etc/init.d/gdm stop && killall X


Smile
Related topics
Help : Fedora Core 4 + Ubuntu
Anybody using ubuntu in here?
new Ubuntu (linux) version is out!
Best flavor of Linux?
Linux and 3D
HOW TO install/uninstall .deb files on Ubuntu!
Free ubuntu cd-rom
Which linux is the best for a new user?
SUSE and Ubuntu
Ubuntu Linux blank screen on startup
Ubuntu doesn't recognize modem? (U.S. Robotics 56k?)
UBUNTU HELP!!
Ubuntu Ati problem
Help with Ubuntu Edgy and Beryl on ATI X1700
Reply to topic    Frihost Forum Index -> Computers -> Software

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.