FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


PHP register_globals setting is `ON` instead of `OFF`





devroom
Thats the message i get by the new joomla version.
if the setting is turned off the server is more safe.

I believe bondings turned is to off some months ago, but the setting is on now.

Does somebody know why and / or can it be turned off?

Edit:
Here is the link of the joomla site with the explanation: http://www.joomla.org/content/view/1843/74/1/3/
mateo
i think that the register_globals was turned on again because there is some users that use PHPNuke, or another PHP Code that requires register_globals On...
My question is: This configuration is for all the PHP Servers?
Why not put the users that need register_globals Off in one configurated in that way?? can't to be??
Bondings
Yes it's a security risk for quite a few scripts. However I have no idea why Joomla reports it to be on and not off. It really should be off according to the settings.
http://www.frih.net/phpinfo.php
SlowWalkere
When I view the phpinfo page, it says that register_globals is on for both the local and master value. I checked the phpinfo page just linked to by Bondings, as well as one I made on my own site on server 2 and got the same results.

- Walkere
Bondings
SlowWalkere wrote:
When I view the phpinfo page, it says that register_globals is on for both the local and master value. I checked the phpinfo page just linked to by Bondings, as well as one I made on my own site on server 2 and got the same results.

- Walkere

Indeed. I just changed the setting to off. My apologies for this. It's not me who changed it. Most likely a new php.ini file came with a new php install.

Either I'm starting to get blind or it was really set to off yesterday in both the settings file and phpinfo. Confused
Vins
Hello master
I think the best solution is that what you have changed, register_globals Off is Ok for the future script, if anyone have it and dont work whit theese settings don't worry, just set RG Emulation from globals.php (that is in Joomla Directory) to ON , set '1' and works fine Smile
Related topics
I have a question about php configuration
MySQL Masters Binary Logs & Replication?
slow booting
Websites hacked/defaced on Server 2
Variaveis pre-definidas[php]
.htaccess Problem With Register_Globals
Script for Upload Form
is register globals off?
Register_globals
setting my own pc as a private server
Finally php 5 on server 2!
Getting a security error
fonctions php en mode off par secu ?
Everything object oriented - WHY?!
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.