FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


chmod /tmp folder - permissions 777????





OutlawSpirit
my users cannot upload avatars from there pc on my forum...

my board was not modded... all permissions in my folders are set to 777... i sent my error to phpbb (the board i am with) and they said the problem could be with my host and told me to ask you this -

Quote:
Ask your host to chmod /tmp folder to 777.


any chance this might help??? and will you be able to do this or not??

thanks

my error

Quote:
Warning: move_uploaded_file(./images/avatars/125884401344e20d0d033ae.jpg): failed to open stream: Permission denied in /home/outlawsp/public_html/fula/fula/includes/usercp_avatar.php on line 291

Warning: move_uploaded_file(): Unable to move '/tmp/phpJW7R5u' to './images/avatars/125884401344e20d0d033ae.jpg' in /home/outlawsp/public_html/fula/fula/includes/usercp_avatar.php on line 291

Warning: Cannot modify header information - headers already sent by (output started at /home/outlawsp/public_html/fula/fula/includes/usercp_avatar.php:291) in /home/outlawsp/public_html/fula/fula/includes/page_header.php on line 483

Warning: Cannot modify header information - headers already sent by (output started at /home/outlawsp/public_html/fula/fula/includes/usercp_avatar.php:291) in /home/outlawsp/public_html/fula/fula/includes/page_header.php on line 485

Warning: Cannot modify header information - headers already sent by (output started at /home/outlawsp/public_html/fula/fula/includes/usercp_avatar.php:291) in /home/outlawsp/public_html/fula/fula/includes/page_header.php on line 486
ranzon
OutlawSpirit wrote:
my users cannot upload avatars from there pc on my forum...

my board was not modded... all permissions in my folders are set to 777... i sent my error to phpbb (the board i am with) and they said the problem could be with my host and told me to ask you this -

my error

Quote:
Warning: move_uploaded_file(./images/avatars/125884401344e20d0d033ae.jpg): failed to open stream: Permission denied in /home/outlawsp/public_html/fula/fula/includes/usercp_avatar.php on line 291


This is saying that you don't have chmodded your avatars folder with permission 777.. it should work if you do that.
if i'm not totally wrong.
Bondings
OutlawSpirit, ranzon is most likely right. Try to change it to 777.
OutlawSpirit
hmm... the permission for the folder 'avatars' is set to '777' and this still doesn't work???
ranzon
OutlawSpirit wrote:
hmm... the permission for the folder 'avatars' is set to '777' and this still doesn't work???


do you have tried to reinstall phpBB??
i had the same problem, and downloaded + installed latest phpBB.. then it worked.
OutlawSpirit
it is the latest Laughing
muggle
You can try to specify absolute path in the move_uploaded_file() instead of relative one `./images…`
Maybe there is misunderstanding between you and your system regarding the base directory which `./images…` is relative to.
You might also verify in your php.ini if safe_mode is off and if the uploaded file size is not bigger than the maximum allowed (upload_max_filesize and eventually post_max_size)
OutlawSpirit
muggle wrote:
You can try to specify absolute path in the move_uploaded_file() instead of relative one `./images…`
Maybe there is misunderstanding between you and your system regarding the base directory which `./images…` is relative to.
You might also verify in your php.ini if safe_mode is off and if the uploaded file size is not bigger than the maximum allowed (upload_max_filesize and eventually post_max_size)


how exactly do i do this Confused thanks
muggle
You may write a simple .php script:
Code:
<?php
phpinfo();
?>

put it on your server and load it in the browser. It will revive all your settings.
Search for `safe_mode` and `upload_max_filesize` in the page displayed.
If you need to modify your settings you might search for `php.ini` to find its location.
Regarding the absolute path, locate the folder where your `images` folder is located and replace initial `.` with its path.
OutlawSpirit
safe mode: off - off

upload_max_filesize: 5m - 5m


could this be any problem???


i found my images folder... where do i find the initial `.` to edit tho??????????
muggle
So far, so good.
Here you said:
OutlawSpirit wrote:

my error
Quote:
Warning: move_uploaded_file(./images/avatars/125884401344e20d0d033ae.jpg): failed to open stream: Permission denied in ...

I don't know who wrote your .php code, but my suggestion was to replace the `./images...` in the above statement with absolute path i.e. `/path_to_folder_containing_images/images...`
Upload file size could be a problem if someone tries to upload bigger files.
OutlawSpirit
hmm i sort of understand... how do i edit this code to change the absolute path?
Related topics
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.