FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


DNS Record Fix





AftershockVibe
This is a bug I think rather than a suggestion but this seems like the most appropriate place to post it.

I discovered an odd bug today. If you miss off the "www." when trying to navigate to the forums like so:

http://frihost.com/forums
Note: No forward slash at the end

You get redirected to the following rather odd address:

http://www.frihost.com/forums//home/frih/public_html/forums

Looks like there is some sort of subdomain problem going on with the DNS. What's more peculiar is that it only happens if you omit the slash at the end, otherwise it redirects just fine! Surely the HTTP server (Apache I presume) should be able to do this properly!

ASV
Cool
Bondings
You need to add the trailing slash, not adding it is actually bad syntax. Normally Apache is able to correct it, but because I have some special configuration it apparantly doesn't work like it should and adds the complete path to the url.
Hogwarts
Bondings wrote:
You need to add the trailing slash, not adding it is actually bad syntax. Normally Apache is able to correct it, but because I have some special configuration it apparantly doesn't work like it should and adds the complete path to the url.


Hmm.... Would it work to put a forum.htm or html or whatever file in the main directory? Then it may work... Worth a shot anyway... Isn't it? Smile
Scorpio
Hogwarts wrote:
Bondings wrote:
You need to add the trailing slash, not adding it is actually bad syntax. Normally Apache is able to correct it, but because I have some special configuration it apparantly doesn't work like it should and adds the complete path to the url.


Hmm.... Would it work to put a forum.htm or html or whatever file in the main directory? Then it may work... Worth a shot anyway... Isn't it? Smile


this error happens only if a name of a directory name is not succeeded by a slash
not for files i guess
AftershockVibe
Bondings wrote:
You need to add the trailing slash, not adding it is actually bad syntax. Normally Apache is able to correct it, but because I have some special configuration it apparantly doesn't work like it should and adds the complete path to the url.


Fair enough. I was just wondering if people knew about it and whether it was simple enough to fix.
Bondings
I'm pretty sure there is a fix with mod_rewrite (which caused this in the first place) and most likely even one line. The syntax is just a bit hard and I have other priorities.
Related topics
PHP Mail Function
Does anyone know where I could get a FREE domain name?
CName?
E-mail is down...
AOL not accepting emails
Change MX Records in DirectAdmin
Gmail for your domain and Frihost together?
Advanced DNS settings
mail()
CNAME (or A Record) referencing to Frihost sites
Problem connecting to Frihost hosting
Questions from a VPS Newbie
Web DNS add CNAME record (TUTORIAL).
Best Subdomain
Reply to topic    Frihost Forum Index -> General -> Suggestions

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.