FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Ubuntu help!! (Solved).. God Knows how!





avk
Hello!!
I know that this is a easy question bu ti couldn't do it!!

How do i log in as the root in ubuntu.
I tried the Login Screen Setup but this happens!!

It asks for a password then
Ubuntu says " Starting Login Screen Setup " But finally nothing starts

What should I do to login as the root!!!

Please help me! I am really new to Ubuntu.....
SamiTheBerber
avk wrote:
Hello!!
I know that this is a easy question bu ti couldn't do it!!

How do i log in as the root in ubuntu.
I tried the Login Screen Setup but this happens!!

It asks for a password then
Ubuntu says " Starting Login Screen Setup " But finally nothing starts

What should I do to login as the root!!!

Please help me! I am really new to Ubuntu.....

Root-accaunt is disabled in Ubuntu by default. It is in server installing, or I got it so in my other computer. If you want to get root, just 'sudo -s' or plain sudo.

More help in Ubuntu Guides (It is Dapper guide, but same thing in Breezy)
avk
It didn't work!!

Can't i use terminal as 'root' rather than 'myusername'.
AftershockVibe
This is true... you can enable root again but the easiest way is just to put

"sudo <command>" before all the commands that need root priveleges.
avk
AftershockVibe wrote:
This is true... you can enable root ............


So .. How do we enable root
fofoo
https://help.ubuntu.com/community/RootSudo#head-8352bb412ccfc81b89a48144986e8690c66e338c
jackill
1.
Code:
sudo passwd root

Enter your existing password
Enter password for root
Confirm password for root


2.
Code:
System -> Administration -> Login Screen Setup
Login Screen Setup
Security Tab -> Security -> Allow root to login with GDM (Checked)
avk
Whenever I type a sudo <command> the followin error comes

Sudo: unable to lookup ubuntu via gethostbyname()
SamiTheBerber
avk wrote:
Whenever I type a sudo <command> the followin error comes

Sudo: unable to lookup ubuntu via gethostbyname()

Are you using Ubuntu by local or remote?
avk
SamiTheBerber wrote:
Are you using Ubuntu by local or remote?


It is local
avk
SamiTheBerber wrote:
Are you using Ubuntu by local or remote?


It is local
AftershockVibe
avk wrote:
SamiTheBerber wrote:
Are you using Ubuntu by local or remote?


It is local


Ah crap. I remember I had this problem when my network drivers were hosed.

I just reinstalled, it seemed simpler than the other methods suggested.
jackill
Code:
restart your system, in the session screen type alt+ctrl+f1
now you are as root

find your ect/host file and at the top of if write this

127.0.0.1 localhost.localdomain localhost <yourhostname>
reboot and thats it


try this, maybe it helps... Rolling Eyes
SamiTheBerber
So are you in admin group? 'groups' gives a list of groups in user you use. If you are in admin group, you can use sudo-command. Are you using the user you created at installing?

I found http://www.ubuntuforums.org/archive/index.php/t-188337.html, there is so,eone having same problem.
avk
Ya !! Tried all and finally the erroe is gone but still my sudo command doesn't work.

I also have reinstalled it.

This is what happens

My Sudo command doesn't work.. Why?

For eg: To edit the /etc/hosts file

1) If i write


Code:
gedit /etc/hosts


then gedit opens it as a read only file

2) If i want to edit it then i write

Code:
sudo gedit /etc/hosts

and then nothing happens

I also have changed the /etc/hosts file to


Code:
127.0.0.1 localhost.localdomain localhost ubuntu
PLease Help me!

I also have reinstalled ubuntu but nothing happens!
SamiTheBerber
avk wrote:
Ya !! Tried all and finally the erroe is gone but still my sudo command doesn't work.

I also have reinstalled it.

This is what happens

My Sudo command doesn't work.. Why?

For eg: To edit the /etc/hosts file

1) If i write


Code:
gedit /etc/hosts


then gedit opens it as a read only file

2) If i want to edit it then i write

Code:
sudo gedit /etc/hosts

and then nothing happens

I also have changed the /etc/hosts file to


Code:
127.0.0.1 localhost.localdomain localhost ubuntu
PLease Help me!

I also have reinstalled ubuntu but nothing happens!

So are you in admin-group? If nothing happens when use sudo, that usually means you aren't in admin-group. I had that problem with server installing.
Nyizsa
You need to run visudo and add yourself to the sudoers. Read the man page for sudoers for more info.
turbohead
go to GDM security section and enable the option "login as super user...."
and open your terminal, then type:
Code:
sudo passwd root *rootpasswdyouwant*
to set your root password.
But this is not recommended for security reasons.
If you want to do some work as a super user, just type "su" in your terminal.
You can get more information by searching "root" in official forums and wiki.
Related topics
Reply to topic    Frihost Forum Index -> Computers -> Operating Systems

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.