FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Screen Resolution on SUSE 10.1





manumiglani
Hello Friends,

Yesterday, I installed suse 10.1 on my system with my windows xp. As soon as I installed it I wanted to change the screen resolution to 800x600.

But as I do it, there is a pop up on a complete black screen which shows that my monitor is out of frequency and it returned to the desktop within 20 seconds to without changing the screen resolution.

I even tried to change the screen reolution to 1280x768 but with same results.

I can change to any screen resolution on windows xp without any problem whatsoever.

What should I do in order to change my screen resolution on suse 10.1 ?



Thanks in advance!!!!!
Nyizsa
First you have to reconfigure your xserver. I don't know what the SuSE command is for that - if you were using Debian, i would. But you can easily find it, I'm sure.
Ok, so when it asks about your monitor, specify the horizontal and vertical sync frequencies. You can found it in your monitor's documentation, or, if you're lucky, on the back of the monitor. Look for something like:
Code:
H: 30-86
V: 50-140

Answer the other questions also, then you will be able to use all of your monitor's modes.
ocalhoun
SuSE has a dedicated program for modifying the X server.
It's called sax2.
You can run it within x or from the command line, in case you screw something up.

From the GUI:
1: Either use YaST to navigate to hardware-->graphics card and monitor then click 'change' or simply use the command line and type 'sax2' <enter>
2: You'll get a control panel with full-context sensitive help to guide you through it. Make sure you monitor was detected correctly (That's what your problem sounds like). If not, use one of the VESA modes. Select the color and resolution option and make sure your desired color depth and resolution are available.
3: When you finish, make sure you 'test' the server first; if you can't see anything, just wait for it to revert to the old settings.
4: If it is viewable and better than what you had before, click 'save'
5: Either log out and in again or press ctrl+alt+backspace to restart the x server, and see if it's better.

From the command line: (If you screw it up, you can use this)
1: boot up in the command line.
2: make sure you are in runlevel 3 (init 3)
3: type 'sax2' <enter>
4: sax will propose an automatic configuration and display with it, if it's not acceptable, edit the configuration.
5: continue from step 2 above.
kernel_geek
You can also just manually edit your /etc/X11/xorg.conf

In the display section type

Quote:
...DefaultDepth 24


and then in the screen section where it uses 24 depth type
Quote:

...Modes "800x600"


You may have mentioned this already but i am to lazy to read
but if nothing works, try (in the console)

Quote:
X -configure

edit the file acordiangly and type:
Quote:
X -config /path/to/file.conf


then you will get into X without yast reseting the settings, go into the yast gui and change it there. You might also want to download drivers for your video card (if your using nvidia) in the suse update ...
Related topics
751 Useful Windows XP Files
Linux OS
Why you should not be using Ubuntu!
Screen resolution?
Anybody running SuSE 10?
SUSE 10 on my Dell Laptop overheats
play DVD's on Suse 10
Linux...
Game Maker
What's your screen resolution?
unable to adjust dell m991 screen resolution setting
Good SUSE 10.2 - better drivers than Win XP and Win 2003
Running local perl scripts in open SuSE 10.3
PDF printer for SUSE 10.x
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.