FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


IIS installation under XP getting 401.1 error





horseatingweeds
The other day I went through the instillation of IIS 5.1 under Win XP in order to learn ASP stuff. I already had Apache installed. When I try to view the default web site or anything ( http://localhost/ ) else I get the 401.1 ‘not authorized to access’ error page.

Initially, I tried to run IIS by turning Apache off. Now I have just changes the port for IIS to 8080, then tried to view ( http://localhost:8080/ ) with the same effect.

I have search through about every instillation instruction and tutorial with no help. I’ve searched this forum and a few others. I think I must just be missing something small that has to do with my previous and current Apache server. I know when I installed the Apache I put localhost for its network domain and server name. I just don’t know enough about things to diagnose or fix anything.

Apache is working fine still.

Any help would be appreciated.
benjicook
Do you have an index.html in the www folder? Is your firewall off?
horseatingweeds
Yes, I have the index.htm. The only fire wall running is the Win XP, I tried it off with the same results.
IceCreamTruck
IUSER_(YOURMACHINENAME) needs to be configured for access to the files otherwise IIS will not allow access.

I've had this problem before too, and to tell you the truth I'm not sure what fixed it exactly, but here's something for you to try.

When anyone logs into IIS on your machine, let's just say your machine name is AWESOMEMACHINE on the network, then you need to configure your public web directory to allow IUSER_AWESOMEMACHINE to have read access on your public web folder.

Go to the folder in winexplorer and right click it to bring up properties. click on the sharing tab and it will be set up one of two ways. One way is that IIS is aware that you want to use this directory publicly, and web-sharing will have configurable options under the normal sharing options, and the other is that IIS is not aware that you want to use this directory and only the normal network sharing options will be availible.

Under the users section you need to add, or make sure that IUSER_AWESOMEMACHINE has the right privaleges to access the folder. DO NOT AD WRITE PERMISSIONS TO THE DIRECTORY FOR IUSR_ BECAUSE THIS IS A MAJOR SECURITY RISK. If anonymous access is allowed under IIS, should be able to configure in IIS options, and the IUSR_AWESOMEMACHINE has the right permissions then everything should work ok.

Let me know if this helps!
horseatingweeds
THis may be the trouble.

I have anonymous access selected but the 'sharing' tab might not be what you are describing.

Here is a link to some screen shots I took of my set up.

http://www.gentledoberman.com/home_direct.htm

I have been trying to find some thorough resorces, like a book, on this subject but all I can find is stuff about IIS 6 on a Win server and stuff on Win XP OS. Nothing on this IIS 5.1 under Win XP....
IceCreamTruck
Check out the "Web Sharing" portion and try to set it there!!



Let me know if IUSR_YOURMACHINENAME appears in the list!!

Also, allow IIS to control password checkbox might be an option to explore!! If IIS can't control what the password is then anonymous password might actually be set, and user would then have to authenticate.
Or I might just be off-base, but I would try that too!

drpiga
1. Place the Windows XP Professional CD-Rom into your CD-Rom Drive.

2. Open 'Add/Remove Windows Components' found in 'Add/Remove Programs' in the 'Control Panel'.

3. Place a tick in the check box for 'Internet Information Services (IIS)' leaving all the default installation settings intact.

4. Once IIS is installed on your machine you can view your home page in a web browser by typing 'http://localhost' (you can substitute 'localhost' for the name of your computer) into the address bar of your web browser. If you have not placed your web site into the default directory you should now be looking at the IIS documentation.

5. If you are not sure of the name of your computer right-click on the 'My Computer' icon on your desktop, select 'Properties' from the shortcut menu, and click on the 'Computer Name' tab.

6. Your default web directory to place your web site in is 'C:\Inetpub\wwwroot', but if you don't want to over write the IIS documentation found in this directory you can set up your own virtual directory through the 'Internet Information Services' console.

7. The 'Internet Information Services' console can be found in the 'Administration Tools' in the 'Control Panel' under 'Performance and Maintenance', if you do not have the control panel in Classic View.

8. Double-click on the 'Internet Information Services' icon.

7. Next you will see the 'Virtual Directory Creation Wizard' from the first screen click the 'next' button.

9. You will then be asked to type in an 'Alias' by which you will access the virtual directory from your web browser (this is the name you will type into your web browser after 'localhost' to view any web pages you place in the directory).

10. Next you will see a 'Browse...' button, click on this to select the directory your web site pages are in on your computer, after which click on the 'next' button to continue.

11. On the final part of the wizard you will see a series of boxes, if you are not worried about security then select them all, if you are and want to run ASP scripts then check the first two, followed by the 'next' button.

12. Once the virtual directory is created you can view the web pages in the folder by typing 'http://localhost/aliasName' (where 'aliasName' is, place the alias you called the virtual directory) into the address bar of your web browser (you can substitute 'localhost' for the name of your computer if you wish).


And buy yourself a beer Surprised Surprised Surprised Surprised Surprised
horseatingweeds
drpiga, I am stuck on step 4. I am getting the 401.1 error, access denide, on localhost. Could this have anything to so with the fact that I already had Apache?

IceCreamTruck,

I tryed adding wwwroot to the list but that didn't help.[/img]

I think I will try to uninstall and reinstall. The win version I have is from compaq (big mistake) so it didn't come with a disc. I think it is made to store everything in a part of the hard drive. I called up and made them send me a hard copy because I thought I could reinstall win and get ride of the mountains of crap that also come installed but the disc had all that crap too.

Tell me if you have anymore ideas. Thanks!
horseatingweeds
OK, I found the problem.

When installing IIS, make sure that in the same check list make sure that Networking Services is check. Also, highlight Network Services and hit the Details button. This brings up another list of options. I just clicked them all on so I’m not sure which one you need. I think it is Simple TCP/IP Services.

Yeehaw!!!! Dancing

It’s so relieving when my stupidity finally reaches a temporary end.

Thanks for your help.
IceCreamTruck
I'm glad you figured it out!! I've had the same kind of issues, different reasons, and it always sucks trying to trouble shoot software issues. Hope that your headaches stop now and that it's smooth sailing from here on out.
Related topics
Windows Tips&tricks!
Windows Vista Official Thread
Windows XP the best?
phpBB Error, seems to be a MYSQL DB error...
This is how to make a Bluetooth headset work with XP SP2
MySQL Data Not Inserting - I keep getting an error
Eventlog found Error...
Why my site is getting error ???
Getting a security error
Running Linux without installing
fatal error in Joomla installation "index.php"
MySQL connection error on Server 2?
MYSQL Ajax im Installation Error
Help on Windows 7 Ultimate - installing IIS 6
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.