FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Getting wpa-psk working on a dell 1370 on LINUX.





solarwind
Hey, I finally found a way to get wpa-psk working on linux on my dell 1370 wireless card which came on my inspiron 6000.

Check it out:

Quote:

Install WPA Supplicant and the GUI tool
Code:

sudo apt-get install wpasupplicant wpagui


That should let you use WPA in all it's varieties. You'll need to edit three files:

/etc/default/wpasupplicant:
Quote:
ENABLED=1
OPTIONS="-w -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf"
Replace madwifi with your driver (madwifi, ndiswrapper, etc.), ath0 with your interface name.

/etc/wpa_supplicant.conf:
Quote:
ctrl_interface=/var/run/wpa_supplicant # Leave this as is
ctrl_interface_group=112 # The GID of the group allowed to use the GUI tool
update_config=1 # This file is only updated if wpa_supplicant is started
# with this set to 1 and the user is in the
# ctrl_interface_group

# Define a network using WPA-PSK or WPA2-PSK
network={
ssid="secure_ssid" # Enter the SSID of the network here
scan_ssid=1
psk="mysupersecretkey" # Enter the network key here
proto=RSN # Leave this as is for WPA2-PSK, remove for WPA1
key_mgmt=WPA-PSK # Tell wpa_supplicant to use WPA-PSK or WPA2-PSK
pairwise=CCMP # Use TKIP+AES (change to TKIP for only TKIP or for WPA1)
}

# Define a network with no encryption (no WPA, no WEP, etc)
network={
ssid="open_ssid" # The SSID
scan_ssid=1
key_mgmt=NONE # Tell wpa_supplicant not to authenticate to this network
}

If you aren't sure what setting you're using (WPA1, WPA2, TKIP+AES or just TKIP) check the access point configuration. Otherwise ask your network administrator and explain you need the settings so you can use wireless with your Linux laptop.

/etc/network/interfaces:
Find the section started by "auto <if_name>" where if_name is the name of your wireless interface (mine is ath0) and add these lines:
Quote:
auto ath0
iface ath0 inet dhcp
pre-up /sbin/wpa_supplicant -Bw -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf
post-down killall -q wpa_supplicant
If "iface ath0..." is elsewhere, comment it out with a pound sign (#) at the start of the line.
If wpa_supplicant isn't in /sbin/ you need to change /sbin/wpa_supplicant to be the full path to wpa_supplicant (maybe /usr/sbin/wpa_supplicant or /usr/local/sbin/wpa_supplicant). You can find this with the command
Code:

which wpa_supplicant

which will give you the full path to the wpa_supplicant binary.

This should get you basically up and running. You can tweak these settings with the GUI tool (run wpa_gui from the command line), just remember to restart wpa_supplicant (I restarted networking: /etc/init.d/networking restart) before launching the GUI.
Related topics
What is your operating system?
Which Linux distribution is the best?
Has anyone dual booted dell laptop/linux?
Is there a Python Hello World using Apache?
Help me sound isn't working with ubuntu linux
Why people hate Windows?
Michael Dell usa linux!
Linux(Ubunto 7.04) onto my Dell Inspiron 1501
Running Linux without installing
Wireless network setup. Unstable connection
Setting up file sharing between Linux and Vista...
Getting Google Analytics Working
Net working Apple with Linux and Windows
I'm still a noobie at home networks, please help...
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.