FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Connecting Computers with Ethernet XOver Cable Not Working





pansophia
I just got a new computer, and I want to transfer files from my old one. The new computer runs W2K, and the old one is running on Windows XP.

I bought an ethernet cable and plugged it in to the ethernet ports of both computers. When I turned on the computers, they weren't seeing each other. I looked both in "My Computer" and "Network Places".

When I look at the directions for connecting two computers with a cable, none of them say to do anything but plug in the cable. I expected that the computers would just see each other. Is there anything else I need to do?
Animal
You should be able to see them, but you may have to enter an address rather than just expecting the machines to appear in My Computer or My Network Places.

First things first, ensure both network cards are on. Secondly, verify that it's definately a Cross-Over Cable you're using (I know you said it was in the title of your post, but just check anyway).
Next, plug the network cable into each computer then open My Computer on the WinXP machine. In the address bar, type "\\NAME" where the network name of the Win2K PC is "NAME". If that doesn't work, try the reverse where you connect to the WinXP computer from the Win2K machine.

If this doesn't work, make sure you've enabled file and printer sharing on the network connection.
waiteck
You can't simply buy an ethernet cable.. And plug into both of the coms..

Make sure you have a router.. and the coms are plugged to the router but not to each other..
pansophia
Thank you for the simple instructions!

I do have a crossover cable, and both computers have NIC cards on.

I'm going to start all over today and work on it from the side of the second computer. After reading more last night, I tried to set up a Home Network through My Network Places. Then I kept getting an error on the last step (first it was a Spooler error, and then after I updated SP2, it was just "an error"). Maybe my there's just something fubar there.

I don't have a router, and I'm hoping I don't have to buy one because all I have to do is move some of my (packed) apps to the new computer. I don't need to maintain a home network otherwise.
Bones
Also take down any firewalls that are turned on.
Do you have a dvd burner? Thats generally the easiest way to transfer files.
And yes you can transfer files this way (it's an ad-hoc network) but it's unreliable at best. That's why most people would recommend a router.
pansophia
Thanks for the tip about the Firewall! That might be the problem.

My old computer unfortunately doesn't have a burner of any sort. I do have a small jump drive, so if push comes to shove I can move files a few at a time.

The new (well, refurbished) computer does have a burner. Woo hoo!
ocalhoun
What was this cable used for previously? Are you sure it's a crossover cable, and not just an ordinary one? There is a difference, and it would explain your problems.

Also, with the computers connected:
1: Find out the IP addresses of both computers (use *gasp* MS help if you don't know how)
2: Click the start button
3: Click 'run...'
4: type 'command'
5: type 'ping ' and the adress of the other computer that you looked up in step 1
6: Report the results here.

This will help us know wether it is a hardware or software issue.
Also, the nic cards should have little lights on them. What are the lights doing?
pansophia
I'm very sure it's a cross-over cable. I bought it yesterday, and I talked to the salesman to make absolutely sure.

Thanks for the "ping" idea - I'll try that, too.

I'm not sure where the NIC lights are supposed to be. I just checked the Hardware list under My Computer/Properties/Devices. There are some lights on the front of my laptop, but none of them look related to networking.

Unfortunately I can't give it a shot until later tonight. My job requires use of the Internet, so I can't do anything with the Ethernet port until my work for the day is done.
Ray Salamon
Verify that it's a crossover:
Hold both cables so that the clipy part of the plug is down. See those 8 wires inside the RJ45 connector? Here's how a straight through cable should look:
Pin #: End 1 --------- End 2
Pin 1: Orange White -------- Orange White
Pin 2: Orange -------- Orange
Pin 3: Green White -------- Green White
Pin 4: Blue ------- Blue
Pin 5: Blue White ------- Blue White
Pin 6: Green --------- Green
Pin 7: Brown White --------- Brown White
Pin 8: Brown --------- Brown

If it DOESN'T match that wiring diagram, then you most likely have an x-over cable (there are others, but I doubt you bought one of those Wink)
Simple steps to network:
1) plug x-over cable into both NICs
2) on PC1, goto "network connections"
2a) Verify that the ethernet adapter is enabled (right click, see if "enable" is an option)
2b) go into the ethernet's properties. (right click -- properties)
2c) Under "this connection uses the following items" in the "general" tab, highlight TCP/IP and click "properties"
2d) Once there, click "Use the following IP address". Type these settings in:
IP Address: 10.0.0.1
Subnet Mask: 255.0.0.0
leave gateway empty
If anything got put into the DNS entries below, delete it.
Click "Ok" in that window, click "Ok" in the adapter's window.

Repeat steps 2a - 2c on the 2nd compy.
For step 2d, on the 2nd computer, put in these settings:
IP Address: 10.0.0.2
Subnetmask: 255.0.0.0
leave gateway empty
And again, delete anything in the DNS entries.
Click "ok" in that window, click "ok" in the adapter's window.

After you do all of that, you created a simple peer-to-peer network between your two computers. Congrats.
IMHO, much easier than burning DVDs of information, and if both NICs are 100Mbps, just as fast. And, if you're like me and have literally near 1TB of information, burning DVDs is just inconcievable.

Hope this has helped... if you need any more detailed assistance, don't hesitate to ask.

-Ray
pansophia
Thanks so much for your generosity in providing the step-by-step instructions. My cable has the colors in a different order so it seems to be a crossover. I still haven't gotten the network working, and I'm about to try your steps above.

I am now trying to make the connection from the second computer. The OS is Win2K, which I've never used before. I added a new connection as a "Direct Connection", but I got an error saying the modem didn't work on the other computer.

I'm going to try the steps you suggested, adding the net masks to the "Direct Connection" on the Win2k machine.

One other thing - the Direct Connection (Win2K) asks me for a network password, and there didn't seem to be a way to opt out of that. I gave the password I used to set my other computer (XP Home), but I don't think I was asked for a password when setting up my "network place" for the XP computer.
pansophia
Still no success. I couldn't find a place to input the IP addresses under the properties of Direct Connect. Sad
Ray Salamon
Hm, interesting dilemma here...
On your Win2k box do these quick trouble shootings. Read them, re-read them, then try them :p:

1) Right-click on My Computer. Select the Network Identification tab. Ensure that your computer is a member of the workgroup 'WORKGROUP'.

If it your computer is not a member of the workgroup 'WORKGROUP':
1a) Click the Network ID button.
1b) Click Next.
1c) Check 'This computer is part of a home network..." option and click Next.
1e) Check the 'My company uses a network without a domain' option and click Next.
1f) Enter the workgroup name 'WORKGROUP' using all caps and click Next.
Click Finish.

2) For your Network Card:

In Local Area Connection Properties (Control Panel -> Network and Dial-up Connections, right click on Local Area connection -> Properties), click on Configure, then click the Advanced tab. Try setting Duplex Mode to Hardware Default, if it's not already.


TCP/IP: (Click on "Internet Protocol (TCP/IP)", then click Properties)

On the General tab:
Make sure "Obtain an IP address automatically" is NOT checked, and that the settings in my previous post are manually entered there.
Make sure "Obtain DNS server address automatically" is UN-Checked also.

After verifying these settings, click OK until you are back to the "Local Area Connection Properties" window. Click OK to close the Local Area Connection Properties window and reboot, if prompted (prolly will be if you changed anything... windows Rolling Eyes).

Also, I'm 90% sure on the exact prompting, but not 100%. It's been roughly 6 months since I've touched a computer with Win2K on it...

After that, verify that your winXP computer is also in the workgroup "WORKGROUP" (case may not be sensitive here, but when in doubt, make sure they both are identical).

If after you verify all that and fix any errors (or find no errors there), on both computers find your way to the run command (start menu usually) and type 'ipconfig /all > c:\config.txt' just without the quotes, then post the .txts here so we can have a better look at things Smile.

Hope this helps!

-Ray
Bones
IMO it's inconceivable to have over (or even close to) a TB of data without dvd backups Wink
Hope the networking works out for you though. Worst case scenerio, buy a router and it will save you a lot of headaches, not to mention allow you to share your internet connection with your other pc(s) Although if you are going to transfer large amounts of data, I would personally stay away from wireless, as it's slower than an ethernet connection, and can be unreliable depending on the environment.
Ray Salamon
Bones wrote:
IMO it's inconceivable to have over (or even close to) a TB of data without dvd backups Wink
Hope the networking works out for you though. Worst case scenerio, buy a router and it will save you a lot of headaches, not to mention allow you to share your internet connection with your other pc(s) Although if you are going to transfer large amounts of data, I would personally stay away from wireless, as it's slower than an ethernet connection, and can be unreliable depending on the environment.


Well, in reality, I have everything on a file server on my home gigabit network, so DVDs are, for me, a slow and useless method for sharing among my PCs. That's for me... for a lot of other people, DVDs are still the way for them.
Any word on if you got it up and running yet? Hope you have Smile.

-Ray
sush
Had the same problem.

Open network connections. Right-click the LAN connection in question, open Properties, click on TCP/IP in the list and click Properties. Set up both PCs in the same way - same subnet mask and matching IP class.

e.g. 192.168.0.1 and 192.168.0.2

Restart.
IceCreamTruck
The cross over cable is there to confuse your computer into thinking its on a routed network, and direct connect might be the problem

Remove any direct connect networks you have set up on both machines as these will push internet traffic through your modem, and not your NIC.

Once all direct connects are removed go through the network setup and make sure both computers are on the same workgoup like was previously stated.

After that "ping" the computers static local area ips and let us know what happens. Microsofts workgroups are notorious for not connecting properly a peer-to-peer based on the order that the machines are restarted, or if one is restarting while the other is off they simply might not be able to see eachother and won't set up the workgroup properly.

Does ping work after you've removed all direct connects and set up a static local area network(ie. 10.0.0.1-2 or 192.168.0.1-2)??????

BTW, the cable itself should say cross-over on it somewhere, or it should be orange or some weird color. If the wires inside, like was stated before, literally change from end to end, then chances are you do have a cross over, but I would make sure of this too! (do the properties of both nics still say disconnected? if so you still might not have the right calbe) does the box it came in, or package, say CROSS-OVER really big on it because it will.

ANSWER THE PING QUESTION!! that guy was on to something, but you skiped that part.
technology.sponge
this may not be exactly helpful, but WAITECK - the point of a xover cable is for a pc to pc direct connection, WITHOUT a router, if u had a router, ud use 2 patch cables
shenyl
No idea, if the issue has been resolved.

You can also enter the command

Start -> Run -> Cmd (to get the black command screen)
Then type : ipconfig /all
IP Configuration / All options will show what are the IP Connections you had on the PC, and also their properties - e.g. IP address, Gateway, etc.

Another option is to show the Connection Status on the System tray. It will show if the connection is OK or Open.

Hope this tip can be used.
orno
setting IP address to 192.168.0.1 and .0.2 works without problems for me (not sure if it makes a difference but set both computers to be on the same domain)

also, if both computers have firewire cards, i suggest connecting them with a firewire cable...much faster transfer rates
Ray Salamon
Has this been resolved at all? I'm curious as to what the actual culprit was that made it not work.
jwellsy
The thread originator hasn't posted in this thread since May 19th.
He only posted for like 36 hrs in this thread.
And his points have gone negative.

I pm'd him that folks are interested in how this turned out.
Maybe he will find his way back.
pansophia
Hi, there -

It's really kind of you to follow up with me! I'm sorry I didn't check back with this thread. Here's what happened:

I tried all the suggestions that came up at the time I posted, and I just couldn't get it to work. I'm sure what I have is a crossover cable - I think the problem was I had never used Win2K before, and I've never had an external router, so I didn't understand some of the finer points of networking such as subnet masks.

I finally ended up returning the computer. It was a donation, but since it didn't have the memory or the processor speed to handle many of the things I do, I felt it would do more good in someone else's hands. I bought a new computer with the specs I wanted. The crossover cable may have worked at that point, since I now had two XP machines, but instead I used a jump drive to sneakernet all my programs/data between them.

I should try the crossover cable at some point just to see if I can do it now at this point.
Related topics
Net-powered computer goes on show
A "small" list of free apps
Wireless/Wired Router Question?
No boot... help, anyone?
[Official] Security: Anti-Spyware/Virus, & Firewall
a network cable is unplugged
Laptop to Desktop Connection problem
Help Connecting PC to Laptop
I'm trying to connect two computers via crossover cable...
Switch Internet Connect Problem.
No access to FTP and cPanel
Why do people hate Apple?
Three words: Firewall. Networking. Issue. (Help!)
ZiLOG ZDS II on Linux
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.