FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Sql/Phpbb error...





[FuN]goku
ok... i have xampp running on my comp as localhost so i can do stuff with php offline... anywho... i was configging a forum offline and whatnot... installing mods... so i was going to upload the files and put the sql tables through a query...so when i try to do that... it gives me this error in phpmyadmin..


Quote:
-- phpMyAdmin SQL Dump
-- version 2.8.0.3
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: May 16, 2006 at 07:35 PM
-- Server version: 5.0.20
-- PHP Version: 5.1.2
--
-- Database: `forums`
--
-- --------------------------------------------------------
--
-- Table structure for table `phpbb_auth_access`
--
CREATE TABLE `phpbb_auth_access` (

`group_id` mediumint( 8 ) NOT NULL default '0',
`forum_id` smallint( 5 ) unsigned NOT NULL default '0',
`auth_view` tinyint( 1 ) NOT NULL default '0',
`auth_read` tinyint( 1 ) NOT NULL default '0',
`auth_post` tinyint( 1 ) NOT NULL default '0',
`auth_reply` tinyint( 1 ) NOT NULL default '0',
`auth_edit` tinyint( 1 ) NOT NULL default '0',
`auth_delete` tinyint( 1 ) NOT NULL default '0',
`auth_sticky` tinyint( 1 ) NOT NULL default '0',
`auth_announce` tinyint( 1 ) NOT NULL default '0',
`auth_vote` tinyint( 1 ) NOT NULL default '0',
`auth_pollcreate` tinyint( 1 ) NOT NULL default '0',
`auth_attachments` tinyint( 1 ) NOT NULL default '0',
`auth_mod` tinyint( 1 ) NOT NULL default '0',
KEY `group_id` ( `group_id` ) ,
KEY `forum_id` ( `forum_id` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci



then at the bottom it says " MYSQL Says"

Quote:
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 COLLATE=latin1_general_ci' at line 36

but when i tried to it on phpmyadmin on my own pic to see if it would work it did.... but what i did different was.. on the one on my pc it has an import button in phpmyadmin... the one in cpanel doesnt.... so anyone have any suggestions???
Bondings
Maybe try to remove the "DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci". It's most likely different mysql versions and types.
[FuN]goku
then it gives me this
Quote:
-- phpMyAdmin SQL Dump
-- version 2.8.0.3
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: May 16, 2006 at 07:35 PM
-- Server version: 5.0.20
-- PHP Version: 5.1.2
--
-- Database: `forums`
--
-- --------------------------------------------------------
--
-- Table structure for table `phpbb_auth_access`
--
CREATE TABLE `phpbb_auth_access` (

`group_id` mediumint( 8 ) NOT NULL default '0',
`forum_id` smallint( 5 ) unsigned NOT NULL default '0',
`auth_view` tinyint( 1 ) NOT NULL default '0',
`auth_read` tinyint( 1 ) NOT NULL default '0',
`auth_post` tinyint( 1 ) NOT NULL default '0',
`auth_reply` tinyint( 1 ) NOT NULL default '0',
`auth_edit` tinyint( 1 ) NOT NULL default '0',
`auth_delete` tinyint( 1 ) NOT NULL default '0',
`auth_sticky` tinyint( 1 ) NOT NULL default '0',
`auth_announce` tinyint( 1 ) NOT NULL default '0',
`auth_vote` tinyint( 1 ) NOT NULL default '0',
`auth_pollcreate` tinyint( 1 ) NOT NULL default '0',
`auth_attachments` tinyint( 1 ) NOT NULL default '0',
`auth_mod` tinyint( 1 ) NOT NULL default '0',
KEY `group_id` ( `group_id` ) ,
KEY `forum_id` ( `forum_id` )
) ENGINE = --
-- Dumping data for table `phpbb_auth_access`
--
-- --------------------------------------------------------
--
-- Table structure for table `phpbb_banlist`
--
CREATE TABLE `phpbb_banlist` (
`ban_id` mediumint( 8 ) unsigned NOT NULL AUTO_INCREMENT ,
`ban_userid` mediumint( 8 ) NOT NULL ,
`ban_ip` char( 8 ) COLLATE latin1_general_ci NOT NULL ,
`ban_email` varchar( 255 ) COLLATE latin1_general_ci default NULL ,
PRIMARY KEY ( `ban_id` ) ,
KEY `ban_ip_user_id` ( `ban_ip` , `ban_userid` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci AUTO_INCREMENT =1


and MYSQL Said

Quote:
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'CREATE TABLE `phpbb_banlist` (
`ban_id` mediumint(Cool unsigne
n0obie4life
Bondings wrote:
Maybe try to remove the "DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci". It's most likely different mysql versions and types.


Haven't I reminded you for the millionth time to update to mySQL 4.1?

@fun[goku]

You have to remove it for every entry..every single instance of it.
devroom
maybe remove the " ---" for and after the lines?

And maybe " Database: `forums` " should be
" Database: 'forums' " or
" Database: forums "

Maybe is that the problem. I can be wrong but just trying to help Wink
[FuN]goku
bah screw it ill just make another forum.. and then just do it manually.... its alot easier
n0obie4life
[FuN]goku wrote:
bah screw it ill just make another forum.. and then just do it manually.... its alot easier


Doesn't your text editor have the find and replace function?
[FuN]goku
n0obie4life wrote:
[FuN]goku wrote:
bah screw it ill just make another forum.. and then just do it manually.... its alot easier


Doesn't your text editor have the find and replace function?
yes but.. ill just do it all over again.. as i have it aredy half configged...
Related topics
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.