FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


lost images - resolved





thpn
Everytime I go to my site my pictures disapear. I have them right in my directory and in my index.html, this also happens with my roleplay forum here
wumingsden
How strange. I have never ever seen this problem before. The only thing that I can think of is that there is some file that somehow stops images being processed.

To solve it try using complete links for images, like http://www.thpn.frih.net/banner.jpg instead of banner.jpg. Also look for files that you cannot remember adding incase this is stopping the images being processed.

Update: the image above is not an image at all but the link to http://www.domain.com/leech.gif - this is not an image but a site. It seems that all of your images are processed as http://www.domain.com/leech.gif Rather you know about this (although your advertising it which doesn't make sense) or some kind of code has entered a file which does this.

If you want you can PM me your details and I'll have a closed look at it
thpn
I was looking through my .htaccess and found this:

Quote:
# -FrontPage-

IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName www.thpn.frih.net
AuthUserFile /home/thpn/domains/thpn.frih.net/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/thpn/domains/thpn.frih.net/public_html/_vti_pvt/service.grp

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$

RewriteCond %{HTTP_REFERER} !^http://(www\.)?domain.com/.*$ [NC]

RewriteRule \.(gif|jpg)$ http://www.domain.com/leech.gif [R,L] //sends them to a leech pic if they are taking .gif or .jpg


Could this be causing it?

//edit
Yes, that was causing it. But uh, could you mind telling me what it is and how it got there?
//end edit
n0obie4life
That piece of code actually stops hotlinking. But it's kind of ineffective eh Smile
wumingsden
a - you did it knowingly

b - you did it un-knowingly

c - a malicious script did it/(remember the other worm/hacker attack?)

d - some other site created the script and you didn't check the code inside

e - somone somehow got access to your hosting account and added it themselves

**note that I've heard of no other complaints as of yet so "c -" is the most unlikely at this point

Also wondering why you Pm'ed me your details when the problem has already been fixed ?

@ N4L - definitly Very Happy
thpn
I didn't put it knowingly.

I didn't put it in unknowingly.

I doubt it was a hacker.

The only person that know my password besides Bondings is lukedk, and he's pretty trustworthy.

It is possible (but highly unlikely) that it was added through a file, because I recently added the files for my layout and forum through FTP.

I sent you my details because I still didn't understad how it got into the htaccess.
Related topics
W3C buttons without images
Some nature's images
Good photoshop images
[RESOLVED] Images not showing up
LOST
PhpBB Ranks <RESOLVED>
The best golf course!
Forum rank images; a lot of images, a lot of frih$
Images / Formatting to the top of the page *Resolved*
Lost Gems - Games you think sliped under the radar.
[Resolved] Domain Lost
They say all the best things in life are free.example?
Lost time ~
remnant of split topic. Left for reference only
This topic is locked: you cannot edit posts or make replies.    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.