FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


MySQL and PHP problem in the future





devroom
Hi

On my site i use joomla. The next release of joomla is going to need MySQL version:
Quote:
use MySQL version 4.1.2 or newer (older versions don’t support utf-8 ).

see http://dev.joomla.org/component/option,com_jd-wp/Itemid,33/p,86/

On server 2 is version 4.0.23 installed.

But also the php version needs to be upgraded:
Quote:
There is an important bug in PHP 4.4.2 that makes PHP crash when the system tries to open an URL using the fopen streams functions.................For 1.5 the problems are more severe
The whole FTP layer will stop working
Newsfeeds will not work
Helpsite fetching will not work

http://dev.joomla.org/component/option,com_jd-wp/Itemid,33/p,85/

Server 2 uses exactly that version Rolling Eyes

So i hope that bondigs or somebody else wants to upgrade the php and mysql versions

Hope to get a respond soon

Grtz Cool
krazycapital
Basically the response they normally give is something like this:
If we upgrade for you, other people's scripts won't work. Therefore, we can't upgrade.
Just trying to help
Zach
Bondings
The php problem seems to be only occuring with Apache 2 and we use Apache 1.

With mysql, there are a few differences with the way passwords are stored between the two versions. So I really don't want to risk the upgrade and then notice that the (irrevertible) upgrade made all passwords to stop working.

By the way, it seems like the change isn't needed, only recommanded.
Quote:
In general it is possible to use the old versions of mySQL with utf-8. The encoding of the database should be latin1 and all varchar fields (that could store text with characters other than pure ascii) should be increased in size by a factor of 3 to be safe from data truncation. (If 256 is exceeded change type to text).

In version 1.5 older versions of mySQL will be allowed. The installation identifies the oldies and uses a different set of sql scripts to create the above changes. Still the recommendation is to use mySQL > 4.1.2
devroom
ok Smile
I hope i wont get troubles

Thx
Related topics
simple php problem, please help...
Seeking MySQL-php-Apache installer for WinXP
Advanced MySQL db merging Tutorials
Mysql database problem
mysql/php help please
A PHP problem !
Need Help integrating php variable into mySQL SELECT query
MySQL, PHP and APACHE
Is mySQL/php in safe mode on Frihosting?
PHP&MySql - Is there any server side caching of queries?
PHP imagecreate + CSS problem.
PHP imagecreate + CSS problem.
Could there be a PhP problem on the server?
[help]Mysql & php problem
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.