FRIHOST • FORUMS • SEARCH • FAQ • TOS • BLOGS • COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Debian Linux CD-rom





aciminsk
Running Debian Linux release 2.6.8.2-686
Took some efforts to configure CD-ROM. Still some problems remain.
1. CD-ROM recognizes CDs and displays the content. Can handle files on CD as usually.
2. When trying to eject the CD, get the following error message : "Eject /dev/hdc failed!".
3. When trying to unmount the CD, get the following error message: "umount: /media/cdrom0: device is busy
umount: /media/cdrom0: device is busy
Please check that the disk is entered correctly.".

Wwould appreciate any suggestions on how to resolve the issue.
KHO
Is debian linux one of the linuxs that runs off a ramdisk and a cdrom? Neutral
And are you currently reading from the cd drive? Neutral
One more, do you have current drivers? Neutral
Helios
Hmm.. very strange problem.
Debian should easily support CD-ROMs.

Maybe you have a DVD drive?


In any case, you should look for drivers that'll make Debian support your CD-ROM.

Also, try running the config again.
I don't remember the command, but you get it after you finish the installation; it tells you that it has finished the setup and if you'd like to run the config script again your should use that command.
Try searching google for that.. shouldn't be hard.

Well, this is easiest explanation. Debian doesn't recognize your hardware :\
aciminsk
^^^
Actually there are two drives, one is CD burner and the second is DVD-CD/rw

But both do the same.

And as I said, I has played with configuration (Initially CD drives were recognized, but did not operate at all). Google helped me to find partial solution
Quote:
Kernel 2.6.*
============

Usually you would not want to use ide-scsi with Kernel 2.6 for
CD-writing, the new kernel provides a (from a user's point of view)
superior access method that finally supports DMA access when writing
Audio-CDs or using -raw.

If you are converting from ide-scsi first undo the steps 2-7 described above.

1. Become root, find out the virtual SCSI ID of your device, running:
cdrecord dev=ATA: -scanbus

2. Become root, setup cdrecord's environment - edit /etc/default/cdrecord:
CDR_DEVICE=cdrw
cdrw=ATA:3,0,0 12 30m
Insert the right values, the fields are described in the manpage
of cdrecord. Alternatively, you may use this values as
cdrecord-parameter or take a frontend with an own configuration
scheme, then you don't need to modify /etc/default/cdrecord.
The columns must be separated by tabs.

3. That's it, 'cdrecord -prcap' should find your writer.

4. If you wish to allow non-root users to write CDs, you must give them
permissions to do so. Run "dpkg-reconfigure cdrecord" to set suid-root
permissions on the executable, then add your users to the cdrom group
("adduser user cdrom") and let the user completely logout and re-login.


Nevertheless the problem of removing CD from the drive remains.
Nyizsa
I think it happens when you eject the CD manually without unmounting first. Most likely when you change CD. It is still mounted, but it was ejected, so it isn't mounted anymore - the system gets confused. Always use the eject command to eject the CDs!
Helios
Well, pressing the button never worked for me.

I got used to 'virtually' doing it,
just by unmounting the device.

After doing that I'd just throw my CD outside Razz
aciminsk
What I've figured out is:
1. If content of CD is displayed (Default file manager is Konqueror), CD-ROM could not be unmoounted;
2. If a program from CD has been run and was not properly exited (a process still remains active in memory), CD-ROM could not be unmounted;
3. If CD-ROM is mounted, CD could not be ejected;
4. Pressing Eject button on CD-ROM does not eject cd;

Came to the following sequence:
1. Make sure that no CD-ROM related processes are still active;
2. Make sure that no CD content is displayed;
3. Unmount CD-ROM;
4. Eject CD
Nyizsa
aciminsk wrote:
What I've figured out is:
1. If content of CD is displayed (Default file manager is Konqueror), CD-ROM could not be unmoounted;
2. If a program from CD has been run and was not properly exited (a process still remains active in memory), CD-ROM could not be unmounted;
3. If CD-ROM is mounted, CD could not be ejected;
4. Pressing Eject button on CD-ROM does not eject cd;

These are just perfect this way. You should ALWAYS eject the CD using the eject function!
If you don't want to eject the CD, you can unmount only, but if you want to eject it is not neccesary to umount it first - the eject function unmounts it automatically.
And all the above applies to floppies as well - the only difference is that you have to take it out manually from the floppy drive after ejecting it.
Related topics
What is your operating system?
Linux & Windows
Linux OS
Linux HD Install
Debian version CD
My hard drives CD-ROm cannot read
open DVD from CD-ROM - possible??
Dualboot Linux/Windows with XP bootloader
10 things you should know about every Linux installation
[VAR] Famelix - El Linux para Windowseros
Computer not booting.
Please help. Major Problem with Linux on external Harddrive.
ΏVale la pena cambiarse a Linux?
How can I install Linux without CD-Rom & FDD?
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.