FRIHOSTFORUMSSEARCHFAQTOSBLOGSCOMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Problème depuis "Big plantage" le 1er plantage du





Granard
Voila, après le plantage, j'ai fait comme Bonding il a dit, refaire un user dans la database avec meme pseudo et meme mdp et maintenant j'ai àa sur mon site

http://www.sheepfold.frihost.net/v2/index.php

Je précise qu'avant tout marchait Smile
pll
Je ne suis pas sur mais je crois que c'est à cause de tes permissions sont-elles à 777 ?
Sinon tu as bien fait Add user to DB dans le cpanel ?

(on sait jamais ça m'est déjà arrivé de ne pas le faire Embarassed )
geo
Granard wrote:
Voila, après le plantage, j'ai fait comme Bonding il a dit, refaire un user dans la database avec meme pseudo et meme mdp et maintenant j'ai àa sur mon site

http://www.sheepfold.frihost.net/v2/index.php

Je précise qu'avant tout marchait Smile


Normalement tu as un user pour l'acces a ta bbd et un user pour ton ftp differents as tu tout bien paramétrés
ZORGLUB
oui,
il faut crée un user, et aussi l'ajouter sur chaque base sql concernée.
tu dois garder le même mot de passe pour ce user.
Normalement, plus de problème ensuite.
sinon, effectivment, certains repertoires peuvent avoir perdu leur CHMOD, vérifie de ce coté.
ça me fait pareil, j'ai perdu une fonctionnalité d'un de mes sites, et je sais pas quel repertoire doit être chmoddé.. grrr
geo
Mais j'ai pas suivi pourquoi bondings a changé les acces des fichiers

serait pour une raison qui a fait planter le serveur?
ZORGLUB
non, rien à voir.
il a récupérer les fichiers sur le disque défectueux, mais la méthode de récup semble avoir modifié les permissions des repertoires, c'est tout.
Granard
pll wrote:
Je ne suis pas sur mais je crois que c'est à cause de tes permissions sont-elles à 777 ?
Sinon tu as bien fait Add user to DB dans le cpanel ?

(on sait jamais ça m'est déjà arrivé de ne pas le faire Embarassed )



Effectivement c'etait ça, je pensais l'avoir fait Laughing

Merci !
MARCIV
Quote:
Frihost - Free Reliable Internet Hosting - Here we are and here we stay

Dernière édition par Bondings le Mar Mar 14, 2006 1:07 am; édité 3 fois


Argh ..... je perds de l'argent et du classement dans google (mon site est actualisé environ tout les 3 jours) arf.....

Question : est il possible d'avoir deux hebergeurs au cas ou ?
Bondings
Granard, il semble qu'il y a encore un problème ici: http://www.sheepfold.frihost.net/v2/galerie.php .

Marciv, c'est possible mais pas facile. Avoir le même site a deux hébergeurs est possible, c'est le dns qui est plus difficile car les 'nameservers' d'un domaine propagent très lentement. Alors un service comme http://freedns.afraid.org/ t'offrira une manière de changer le dsn vers un autre hébergeur en juste quelques minutes.

ZORGLUB, c'est quel url?

geo, j'ai du changer les permissions automaticement car autrement ca ne fonctionnait complètement pas.
pll
Ben au moins j'suis content d'avoir pu aider quelqu'un Very Happy
AtyPics
Mon site est à nouveau en ligne, aucun problème ne semble avoir altéré l'aspect ni le fonctionnement de celui-ci... Je suis méga content! Encore un grand merci pour Bonding! Wink
AtyPics
J'ai parlé trop vite... En fait tout l'aspect dynamique de mon site ne fonctionne pas! J'utilise Movable Type pour gérer mon photoBlog et toutes les page qui existaient avant sont encore accessible mais ne permettent plus d'envoyer des commentaires. En fait la génération automatique de mes pages ne marche plus, je n'ai même plus accès au gestionnaire de mon blog! S'il s'agit d'un problème de permissions, je ne sairais jamais réinitialiser celles-ci afin de permettre le bon fonctionnement de mon site. Voici le type d'erreure que j'ai:

Got an error: Bad ObjectDriver config: Erreur de connexion: Access denied for user: 'atypics_atypics@localhost' to database 'atypics_atypics'

Bon si quelqu'un peu m'aider à ce sujet qu'il se montre... Confused
pll
AtyPics wrote:
Access denied for user: 'atypics_atypics@localhost' to database 'atypics_atypics'

Ça doit être un problème de CHMOD (permissions) > Access denied
Mais pourquoi tu ne pourrais plus les remettre en place ?
Bondings
AtyPics wrote:
J'ai parlé trop vite... En fait tout l'aspect dynamique de mon site ne fonctionne pas! J'utilise Movable Type pour gérer mon photoBlog et toutes les page qui existaient avant sont encore accessible mais ne permettent plus d'envoyer des commentaires. En fait la génération automatique de mes pages ne marche plus, je n'ai même plus accès au gestionnaire de mon blog! S'il s'agit d'un problème de permissions, je ne sairais jamais réinitialiser celles-ci afin de permettre le bon fonctionnement de mon site. Voici le type d'erreure que j'ai:

Got an error: Bad ObjectDriver config: Erreur de connexion: Access denied for user: 'atypics_atypics@localhost' to database 'atypics_atypics'

Bon si quelqu'un peu m'aider à ce sujet qu'il se montre... Confused

Cette erreur est parce que il n'y a pas d'usager pour le database.

Il semble aussi qu'il y a des erreurs avec les permissions des fichiers.

http://www.frihost.com/forums/vp-235041.html#235041
AtyPics
Non non j'ai bien créé un utilisateur pour la base de donnée... Ce n'est donc pas le problème. Le problème c'est que l'outil (Movable Type) que j'utilise est composé de nombreux dossiers et fichiers dont je ne connais pas du tout les permissions originales. Je ne sais donc pas quelles permissions je devrai changer pour permettre le bon fonctionnement de mon site... Crying or Very sad
Bondings
AtyPics wrote:
Non non j'ai bien créé un utilisateur pour la base de donnée... Ce n'est donc pas le problème. Le problème c'est que l'outil (Movable Type) que j'utilise est composé de nombreux dossiers et fichiers dont je ne connais pas du tout les permissions originales. Je ne sais donc pas quelles permissions je devrai changer pour permettre le bon fonctionnement de mon site... Crying or Very sad

C'était bien l'utilisateur. Je l'ai recréé et ca semble fonctionner. J'ai pu envoyer un commentaire maintenant.
AtyPics
Merci Bonding!!! Razz Je suis vraiment pas doué! Toutes mes excuses pour le dérangement.
Granard
Merrrrrrrrrrrrrrrrrrrrrrrrde


J'vais voir avec mon frère c'est kwa le problème mais j'pense que demain je vais venir vous demander pourquoi Laughing
MARCIV
C beau en multicolore !

Voila je voulais pas déranger la communauté pour un problème que je pensais pouvoir rêgler seul mais comme je suis une quiche en MySQL ( et pas q'en ça!) je voudrais l'avis de la communauté.

J'ai recrée un User pour mon forum et tout et tout et là j'avais ça comme erreur :
Quote:
Fatal error: Cannot instantiate non-existent class: sql_db in /home/marciv/public_html/forum/includes/db.php on line 60


Alors je me dis bon je recrée un forum avec fantastico ok ça marche et paf je fais une injection sql et le tour est joué !

Là pif deuxième plantage, je règle ça cétait un truc ou il fallait mettre alter user nan anan ana

Et la repaf ça me remet l'erreur de mon premier forum

Quote:
Fatal error: Cannot instantiate non-existent class: sql_db in /home/marciv/public_html/forum/includes/db.php on line 60


Je capte rien..... Crying or Very sad
ZORGLUB
effectivement, bizarre.
t'as essayé un simple REPAIR de la table sql, avec phpmyadmin?
MARCIV
Bah ouais j'avais déjà essayé dès le début mais là je sèche ! apparement c'est un problème de connexion que j'ai reporté de la première base SQl mais comment le résoudre ...
ZORGLUB
quel forum utilise tu? phpbb?

tu peux ptet poser la question sur phpbb-fr
on sait jamais.
mais si l'erreur a lieu lorque tu mets ta table sql, ya ptet une erreur dedans.
essaie d'injecter progressivemtn chaque table, et de regarder si ton bug apparait à un certain niveau.
Bondings
Peut-être essaye de mettre ce code ci:
Code:
include($phpbb_root_path . 'db/mysql.'.$phpEx);

avant celui ci dans le includes/db.php
Code:
$db = new sql_db($dbhost, $dbuser, $dbpasswd, $dbname, false);

Il semble que phpbb ne reconnait pas la base sql, ce qui est très bizarre.
MARCIV
J'ai pas testé ta réponse pour l'instant.J'ai remis un forum qui roule sans l'historique des messages et je vais faire des test en local pour voir ce qui se passe....
Merci Wink
Related topics
"Collectifs réagissons" : sauvons la musique
Les mangas
windows vista
Votre pays préféré?
Les philosophies politiques françaises
La plus grande découverte depuis l’invention du feu
.htaccess chez frihost : obligation de crypter le pass ?
[UNIK] Windows Vista, êtes vous prêts pour le grand saut??
Quel est votre FAI ?
Problème avec WS_FTP et le serveur 2
[-Jeuxvidéos-] LES FPS.
Vous sentez-vous concerné par le réchauffement climatique ?
[Guide] Les services windows (2000, XP) optimisations.
CM Asrock et IEEE1394 ?
Reply to topic    Frihost Forum Index -> Language Forums -> French

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.