FRIHOST ē FORUMS ē SEARCH ē FAQ ē TOS ē BLOGS ē COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


FreeBSD. My installation exprerience.





aciminsk
Hope you wouldnít mind if I tell my FreeBSD story.

A little foreword. Iím working in a pure MS shop, where Open Source is big NO-NO. Nevertheless I have a small test-bed LAN where I can test whatever I think is appropriate. Lately not the latest and greatest but quite decent server has been decommissioned. I had been using Debian Linux workstation already for quite a while, so Iíve decided to setup a Debian Linux server into W2k3 LAN. Honestly, I donít like to give up, but this time I had to. The machine is HP Netserver LH3000 U3. The older Debian distribution version (Called potato) installs base system but does not recognize NIC, so I could not connect to mirror site to continue installation. The newer stable version completely refuses to recognize NetRAID controller and does not go even as far as the base system. Describing everything what Iíve tried would be way too long, so just the result. Iíve given up. Whatís next to try? The criteria was that it should be not as huge as Debian (The whole distro is 14 CDs), and it should be somewhere nearby so that it would not take me forever to download. It turned out to be FreeBSD.


OK, let's continue
I went to http://www.freebsd.org, spent some time looking around, reading to make sure I know what I'm doing. Though quite a few questions, it did not look too scary, so I went to ftp://ftp2.ru.freebsd.org/pub/FreeBSD/ and grabbed all three disk images (ISOs ) of FreeBSD6.0, which was the latest at that time. One for basic system and network install, and two for complete distribution (Doesn't it seem, well... a little bit too light-weight comparing to 14 CDs Debian distribution?) just in case network install does not work. Burned CDs on my Debian machine. Then I have opened FreeBSD handbook as a single file from http://www.freebsd.org/doc/en_US.ISO8859-1...dbook/book.html, saved it to the local disk and hit Print. (This has been the first rake I've stepped on. For those who wonders how rakes are related to the subject you might wish to check up the thread at http://www.astahost.com/page-2-t10342-s10.html for explanation. The HandBook turned out to be 1300 plus pages, took several hours to print out on an HP DeskJet, has eaten month's supply of paper and cartridges). Everything seems ready to commence the installation. Popped Network Install CD into the retired guy, reboot. Carefully reading prompts, suggestions and handbook and mainly accepting defaults has completed base system installation in about twenty min, another 15 min for initial configuration like creating a user. Another reboot and here you are, welcome, please login. Too good to be true. Nevertheless, I'm logging-in as root. It works. Running some basic commands like ls and ps, works. What about something more complicated? Starting GNOME? Works. KDE? Works, got this beautifull masterpice of GUI design. Unbelievable. Happy end? Well, I'll tell you next time

Yeah, about happy end... Not yet. I have to use the server for something. So, let's add some useful stuff and do a test web server. Easy.

#pkg_add -r mc

And you have Midnight commander.
#mc

Works, great...

#pkg_add -r mysql

A little bit of humming, installed.
#cd /user/local/bin
#mysql_safe --user=mysql &

No error messages
#ps -ax | grep mysql
Lists mysql daemon running. Great
#mysqladmin -u root status
Statistics displayed. Cool

Let's do Apache
#pkg_add -r apache2
Brake for a smoke, done
#/usr/local/sbin/httpd -k start
No error messages. Good
#ps -ax | grep httpd
apache daemon running. Go to my Debian machine, open Mozilla, type in URL
192.xxx.xxx.xxx
Get this lovely Apache feather. Think that I'm probably not that bad in BSD
Do PHP. Go back to the server...
#pkg_add -r php
Yees, done
#vi test.php
make this little test file
<?php phpinfo()?>
Save it to the apache document root. Go back to my Mozilla, type in
192.xxx.xxx.xxx/test.php
Here you are. I'm php info page, I'm here....

One might say that it just could not be that easy and fast. Yeah, but who cares about those little shadows during the happy hour?

Well, the story of success seems to become a little bit boring. So, to wrap it up, a final touch. When the feet started to feel mileage of running between server and workstation, Iíve configured ssh (Secure Shell). Men, I was impressed. Add terminal Server Client for W2K3, and you can access W2K3 and BSD servers from the comfort of your armchairÖ Cool!

Next time I'll start discovering the rakes....
**************************************
So, what did I finally get after all the above? Here is the layout.
Decommissioned HP NetServer LH3000U, with two P4/1.2GHz processors, RAM 4GB, NetRaid SCSI controller and 12 SCSI physical hard drives configured into three logical drives, 5GB RAID1 and 2x90GB RAID5 drives, connected to a small test w2K3 LAN. (You might guess that I have thrown in quite a few of available resources scattered around in a Network Center).
The server has been happy with FreeBSD6.0.The Apache2.4+MySQL+PHP4+GD bundle has been installed, slightly configured and properly serving test pages. X server has been running serving as Gnome so KDE. SSHD has been running giving me an option to access the server from a remote workstation. The only tail to cut was those 2x90GB RAID5 logical drives. As one might guess I have installed everything on one 5GB RAID1 logical drive planning to enable other two later on.
Thatís where the problems startedÖ


Moderator note: Use the edit button. We don't like double posting.
shamil
Good story. Applause I would like to view your answer to problem at http://www.frihost.com/forums/vt-19676.html.
aciminsk
shamil wrote:
Good story. Applause I would like to view your answer to problem at http://www.frihost.com/forums/vt-19676.html.

So, the next task is to enable remaining two RAID5 logical drives. And I want do it from the comfort of my chair. OK
On the Debian box open SU terminal and do
#ssh user@192.xxx.xxx.xxx // to connect to the server
No problems, just supply the password and you are in. Now, to partition the disk you have to have admin rights. Should not be difficult.
$su //Switch to super user mode, worked fine on my Debian machine

Responce is ...Well, no responce and no SU. OK, once more... No responce, no SU. RTF1300pagesM. Found the reason on page 428. Turns out that in FreeBSD to be able to switch to SU mode, the user must belong to WHEEL group. Fine. Now, How to assign my User to the WHEEL group? Turns out 1300 pages are not enough to explain. Read the f****g pw manual page. Took some time to make up sense out of 100 or so switches options and what else and several runs to the server to log-on as root to came up with the command I need. (See some of you smiling).
#pw usershow -n User -P //to see human description of User's properties
#pw usermod -n User -g wheel //To assign Users to wheel group

Good, done. Back to my chair and back to configuring the drives. Handbook comes handy. Chapter 16.3 at page 536 lists three options to add disks, one for dummies, and two for users. Who am I? Well, after all I've gone through definitely not a dummy. So, go to section 16.3.2.2 "Dedicated" and look at method 1. Easy, I can do it. Strictly follow the steps... No luck. OK, may be method 2 is better. Try it. No luck. Well, probably I've overestimated myself a little bit. Go back to Section 16.3.1 "Using sysinstall" (For dummies). Follow the guidance to configure both my RAID5 drives, commit changes, reboot.

What a surprise! After spitting at me quite a few error messages, my so well behaving so far server went into single user mode. After 20 min of trying to make use of it, I've decided that 30 min installation is not that bad after all. So, one more installation. Though next time...

So, reinstall the whole stuff from scratch. Yes, and not once, but still with the same failure result when trying to enable logical RAID5 drives. Chill out guys, Iím not going to tell the whole story from the very beginning, though there were quite a few rakes that Iíve luckily avoided during my first install, but did not miss later on. Just the solution. Turned out to be not soft but hard related. One of the physical SCSI hard drives failed. Took some efforts to figure out which of twelve. So, finally I have ended up removing two and replacing one. Besides Iíve changed NetRAID configuration to 1xRAID1 and 1xRAID5 logical drives. After this I did the base system installation already by heart. As to the final system, Iíve done it a little bit different. Instead of installing prepackaged Apache+MySQL+PHP+GD bundle, I got the latest releases of each and did three steps configure Ė make Ė make install for each. A bit time consuming and no automatic updates. But it will serve for awhile.
Seems as if thatís the end. Unless I recall something worth telling
Related topics
PHPBB 15 and MOD Installation for a small fee
NcFTPd on FreeBSD, Installation/Configuration
FreeBSD-also a good operating system
PHP version 5.0
Uninstallation & Installation Services
FreeBSD 6.0 is up and running!
Linux
phpBB - Installation Tutorial
Please help. I have a problem with installing FreeBSD
myBBoard - Installation Tutorial
Help me finish the installation of smf.
Linux installation
phpBB installation services
Backup lost. Partition recovery
Reply to topic    Frihost Forum Index -> Computers -> Operating Systems

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.