FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


File Upload from webpage failing





ccarter24
I've run into a problem that I've never seen before and can't seem to find an answer to. I have a website that users will use to upload documents. The website is on one server, but there are two addresses to access the website. One is a non-secure website for internal users, the other is a secure site that requires a client certificate for external users, and transfers data using SSL.

The form I am using uses enctype="multipart/form-data". One the internal website, users can upload files up to 2M (which is defined in the PHP.INI file). Internally it works great. When you go to the external server and upload files, you can only upload files up to 46k in size. I experimented, and that seems to be the magic number. 47k files and up don't kill to form, it just doesn't do anything. The form submits and doesn't reutnr anythign at all, just a blank screen.

I've never seen that before, and I haven't found anything about it yet. Just though I'd throw this out there in case anyone has any ideas or has seen it before.
steveadams617
Have you:

1) Tried uploading from different computers with different IP addresses.
2) Tried using a different browser.
3) Tried uploading files with different file extentions?

Is this your frihost account you are using to run the application which handles the uploads or your own machine? If your own machine, which webserver, etc?

Are you using your own digital certificate or one for the machine?
ccarter24
I have used two different computers with different IP addresses. The sane result occurs on each.

Different browsers provide the same results.

I have used different file extensions and the same thing happens with all.

THis is happening on my own machine at work. The machine has a certificate issued to it, and the users need to have their own certificate to access the site.

I still haven't found anything about this. It's just kind of weird. We're using PHP for the website, and this is the only problen that I've seen like this. It's just weird because the exact same form works fine on the non-SSL site.
ccarter24
Just to update with a little more data.

The web server is using IIS 6.0. Under the Secure Communications section of Directory Security in IIS, we require the secure channel (SSL) and 128 bit encryption. We also require client certificates.

When the option of client certificates is changed from accept or require to ignore client certificates, it works fine. It's just a problem when the client certificate is involved.

I've asked several people about this and they've never heard of something like this happening before. I can't find anything helpful about it either. It's just one of those weird problems.
Related topics
File upload with PHP, Build an upload database for your site
Rad Upload Plus v1.22
Filter File Types in PHP File Upload
Upload Script
Looking for easy FormMail Script
quite simple file upload
File upload problem :'(
[RESOLVED] php file upload problem
File upload class problem.
File upload
Looking for file upload!
File upload error
Bulk file upload
www.imagegarage.net
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.