FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


USB2 Mass Storage Device





hhhhh
I have installed an Belkin external usb device with a 150 GB Maxtor HD with
two equal partitons. For lack of knowledge and instructions I have been using it as installed without problems. After about four months I find that Windows explorer does not recognise it, I uninstall it with device manager and searched for new hardware and it solves the problem then every time I start up the device is missing with a ? in device manager. I sometime have to carryout the above procedure about
seven times before I can get it recognised. Just now I was working and it recognised itself.

In the past I have on one occasion had a number of corrupted jpg's and I
must admit that I have unpluggeg the usb connection live on occasion. I have
also selected all files on the second partition which is now empty and
transferred them to my internal hard drive.

Can anyone offer a solution?
phileplanet
hhhhh wrote:
I have installed an Belkin external usb device with a 150 GB Maxtor HD with
two equal partitons. For lack of knowledge and instructions I have been using it as installed without problems. After about four months I find that Windows explorer does not recognise it, I uninstall it with device manager and searched for new hardware and it solves the problem then every time I start up the device is missing with a ? in device manager. I sometime have to carryout the above procedure about
seven times before I can get it recognised. Just now I was working and it recognised itself.

In the past I have on one occasion had a number of corrupted jpg's and I
must admit that I have unpluggeg the usb connection live on occasion. I have
also selected all files on the second partition which is now empty and
transferred them to my internal hard drive.

Can anyone offer a solution?


I haven't had the exact same problem, but I did have a recognition problem with my portable hard drive. It used to keep recognizing and then dissapearing after. Then it wouldn't recognzie at all. After searching every support forum I could find, I tried using a different cable. It works now.
ocalhoun
USB is rather flaky, the advice to use a different cable is good.
Also, plug it into a different port on the computer, or if you are connecting through a hub, then try connecting it directly to the computer.
SoftStag
What OS are you using?
Shin
What is the chipset in your external usb device? some of the chipsets are just not up to the job. I had one cheapo device that just won't work on my laptop but work on my PC. I actually installed the same version of Windows on my PC and laptop.
Yup, swapping a cable is really a good idea.
Related topics
Xbox 360 vs PS3
psp how good?
what software for all drive of usb flash disk 98se
Ipod software
Flash memory on windows 98
using gsm phone as a web cam?
I'm trying to connect two computers via crossover cable...
Windows XP & Motorola Phone Tools Problem?
USB Mass Storage device gone nutz
HD-DVD vs. Blu-Ray Simplified by Three Panel Soul
Anybosy here ranking for a high competetive term
MP3 player hard driver recovery?
Partion deleting
iPod as a storage device
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.