FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Debian workes not





polopolo
When I with grub starting debian, Get I a error that the X-server not workes!
What must I doing now?
How can I fix it?

EDIT: I am using the dutch version
Revvion
Did it work before? have you configured it correctly?
maybe you chose the wrong system driver.
if you use xorg to run your x window try: dpkg-reconfigure xserver-xorg
i don't remember the command for the older one but i am sure its on http://LinuxQuestions.org
polopolo
I have never installed linux on my computer! The wrong config? I don't know, I have choosed NV that not workes. Then I have reinstalled and choosed VIA that not workes too.
I have no idea what x-server program I using. I only know that one that the debian team maked!
Helios
You need to choose "vesa" as your main driver(run the config again and choose "vesa" when you're asked to choose a driver for you vid. card)

That was my problem, but i've solved it in a different way.
I took the /etc/X11/XF86Config-4 file from my Knoppix distro and uploaded it to my host, then, using text based FTP, i downloaded this file and replaced it with the "bad" file on my debian.
So basically I changed the driver to "vesa" the hard way Laughing

After you will do that, download an updated driver from ati.com or nvidia.com for linux. I know that ATI has a driver for linux and I haven't checked nvidia yet.


Good luck!
polopolo
Thank you for the info!
I should do it when my download on windows xp is done!
longjack
I've had problems before with video resolutions and X not booting, which I somehow solved by editing the /etc/X11/XF86Config-4 by hand and typing in the resolution I wanted. The resolution settings are toward the bottom of that file.

On the other hand, I've always have good luck with the Debian net install CD. Download it, run the installer, and when it asks you for more sources point it to HTTP and the Debian site.

Check off Desktop Environment in the install options and Debian will build a Gnome and KDE desktop from the website. It defaults to Gnome. With my 1.5 broadband connection I figure about 90 minutes for the OS to build.

The Mepis CD is another option. Boot off the CD and when you're in the desktop click the icon to install to the hard drive. It usually takes about 30 minutes. Again, the default is the Gnome desktop. I'm not sure if Mepis builds KDE as well, but it might. I use the SOHO server a lot for installations at work, especially for the apache server.

I've never had Xserver issues with Debian installed in those ways.

HTH

longjack
polopolo
Thank you guys!
The method of Helios helps!

I think that I going to post more problems for the futere here!
Again thanks!
Related topics
What is your operating system?
Desktop Screenshot
Linux OS
Debian version CD
Linux
What's your Preferred Linux Distro and GUI
Which Linux distribution is the best?
Debian or ubuntu?
Debian Linux CD-rom
Adding to CD-RW
debian wireless drivers??
Installing Debian
Run Internet Explorer on Debian & Ubuntu
A little Debian help?
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.