FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Path Info Again





Vrythramax
I am on the DirectAdmin server and have not been able to find a way to get it to tell me the absolute path to my document root....I need this for cgi purposes. I am assuming it's something along the line of /home/username/public_html....but assumptions and Perl are not good bedfellows.

Could one of the moderators or Admins please look into this for me and PM me the info? I have 2 full domains in my account also, so could you also give me the info on how to address them? I would really appreciate any help you could offer me.
Loathing in Fear
I'm not sure, but i think it is:

/domains/"your domain"/public_html/
kenetix
It should be like this:
/home/username/domains/yourdomain/public_html/

username - is your username
yourdomain - is your user.frihost.com or user.frih.net domain
Vrythramax
Hi kenetix,

Is that the actual path or an assumption? No offense, I just hate server 500 Errors and a terminal loop can really ruin your day.
Bondings
Vrythramax wrote:
Hi kenetix,

Is that the actual path or an assumption? No offense, I just hate server 500 Errors and a terminal loop can really ruin your day.

That is the correct path, you just need to replace your username(vrythram if I'm not mistaken) and subdomain(like sub.frih.net).

Such a mistake would only give an error and not an eternal loop. Of course I don't know your script so I'm not 100% sure of this. Wink
Vrythramax
Thank you all for your help...and no stress Bondings, I have never created a terminal loop...have seen more than my share of server errors tho Sad


Not to worry, I won't break anything.

One more question...would it work the same with my domain names, just replace sub.frih.net with my.domain?
Bondings
Vrythramax wrote:
Thank you all for your help...and no stress Bondings, I have never created a terminal loop...have seen more than my share of server errors tho Sad


Not to worry, I won't break anything.

One more question...would it work the same with my domain names, just replace sub.frih.net with my.domain?

That part is just relative with everything you see in your file manager/ftp, you just need to add /home/username/ before it.

If you added that domain, then sure it should be working.
Daniel15
Quote:
No offense, I just hate server 500 Errors

You can check the exact details of the error in the error log, which I believe is under the 'Statistics' section.
Make sure your script is CHMODded to 0755, I don't believe the server will let scripts chmodded to 0777 run.

Also, it's case sensitive, so make sure you use the correct case.
Related topics
Imagemagick installed?
Cpanel Acess... again!
[*READ THIS FIRST!*] Commonly asked questions
mod_rewrite
symbolic links with cpanel
SMTP Errors
Path Info
PHP script trouble
Database Privilege
MySQL Database not allowed
Legal Question
about PC-BSD ?
In Command: The Windows Command Prompt
SEO Domain name question
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.