FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Configuring Linux / Windows Dual Boot





Animal
I was planning on installing Ubuntu Linux as a dual-boot option with my WinXP machine. I've previously used another (inferior) Linux distro that completely took over the booting process, setting itself as default and requiring an input before anything was loaded. It didn't work properly, so I got rid of it and haven't used Linux in months.

I'd like to configure a new Linux installation to do the following:

Offer two boot options - 1) Default WinXP and 2) Ubuntu
Automatically select WinXP and load it if there's no user input after say 2 secs at startup.

Is this possible, and if so, how would I do this? Would I install Ubuntu first then edit the Master Boot Record, or is there an option or setting to change during the install?
handeyman
Im not exactly sure how to set the timing and all that stuff, but what I did, was made a linux partition with partition magic then poped in the ubuntu CD and installed it to the partition, now when I boot up I get the option to pic one or the other and if I dont do anything after 30 seconds I beleive it load the first option which is Win XP Pro.
root
First of all, I say you reconsider using Ubuntu, it is not a good distro. But back to dual-booting...

You will have to install Windows XP before you install Ubuntu. If you install Ubuntu prior to installing Windows, Windows will overwrite the MBR with its own boot manager. If you have Windows already installed, then it's all good (assuming you've got a partition onto which you can install Ubuntu).

Go ahead and install Ubuntu (sigh) and make sure you install GRUB as the boot manager. The installation of the boot manager will either automatically detect the XP partition or it wont (not sure how Ubuntu does this.) If all works well, you can then set the default boot partition within Ubuntu and set the time to wait (there should be some configuration settings to this). If all does not work well, you will have to manually edit the GRUB configuration file, in which case you should follow up on this post.

Good Luck,

David
Nyizsa
I use Debian, so this may or may not apply to your case.
After you install Debian (maybe Ubuntu also), it will detect all the bootable partitions. (It didn't detect my Solaris 10 though, I had to add it manually.) GRUB will be used as default boot manager. The file you need to change is /boot/grub/menu.lst. Find the line starting with default, and change the number so that it will point to your Windows boot partition. (First entry is No. 0!)
Good luck!
Animal
Thanks for the help guys!

I'll have a go at installing Linux and let you know if I have any problems. I didn't realise the boot loaders were "pre-configured" for dual boot with Windows. As I said, the last Linux I installed took over, annoyed me, then was asked to leave!
ocalhoun
Important! :
Make sure that you specify a boot-loader location other than the MBR!
Otherwise the bootloader will kill XP, which resides in the MBR.
Animal
Right, I've managed to install Ubuntu without any problems (very impressed with it so far Very Happy ) and I want to change the boot configuration to a lower "automatic selection time" and to default to Windows boot-up.

I've found the file I need to edit, but I can't access it since I'm not logged on as "root". When I try to log in as "root" with the correct password, I get an error message stating that "Root can not be logged on from this screen". Apologies for being such a Linux noob, but could someone give me an idea as to how I can change the file? Also, is there any way to set up my user account to be allowed to alter "root" files?

The other question I have is this: I updated to the most recent Linux kernel when Ubuntu was first installed, but the old kernel option still appears in the boot selection menu. Is there any reason I shouldn't remove this from the boot list? If not, how would I remove it?

Thanks very much for any help you can offer!
Nyizsa
1. Yes, logging in as root is not allowed from the login screen. Login with your account, open a terminal and type su, then enter the root password - there you go!
2. To hide a boot option, the simplest way is to comment it out. Find the one you don't want to be displayed, then insert a # as the first character of every line (of that option - should be 4 or 5).
3. To speed up the boot process, find the line starting with timeout. Then set the number you want the boot loader to wait in seconds.
Good luck!
ocalhoun
Odd, in SuSE I can log in as root just fine.
It's just a hidden user, you can't select to log in as root with just a mouse click.
Animal
Nyizsa wrote:
1. Yes, logging in as root is not allowed from the login screen. Login with your account, open a terminal and type su, then enter the root password - there you go!


Hi Nyizasa,

I've tried entering su and the correct password, but this still doesn't let me edit the file - it is read-only. Do I need to edit it from within Terminal? If so, how do I do it? If not.... help!!!

Thanks for your advice so far.
ocalhoun
If you use that method, then yes, you will need to set the file to read and write, and edit the file from within the console.

try this:
you@linux>su
Password:

...
root@linux>konqueror


You can substitute whatever browser it is you use for file management.
Alteratively, right click your text editor and select "run as root" if it is available. You will be prompted for a password in that case.

Also, are you sure you are using the correct root password?
Animal
I can't get it to work.

The password is definately correct. When I load Terminal, I get:

me@linux>

I then enter su then enter the password and I get:

root@linux>home/me

I can't find a "run as root" option. Any more suggestions?
Animal
Actually, I got it to work myself.

For anyone else who ever needs to know, Ubuntu stop you from logging on under the root account as a security setting. Once you've created your own user account and logged on, you can access the administration panel and select Login Setup. Under the security tab, check the box marked "Allow root to log on as GTK". Then all you have to do is log off and then log back on again to edit the root files. It's up to you whether you disable or re-enable this setting afterwards.

Thanks very much for all your help ocalhoun (and everyone else who chipped in) - I seem to have it running exactly as I want it now.
Nyizsa
For security reasons, logging in as root is disabled by default. You should disable it when you finished. (But it's up to you, of course...)
The mistake you committed: when you opened a console and typed su, you became superuser in that console only!!!! So when you started the file manager from outside, you had the same simple user rights as before. You should have started the editing process from the console. Like this:
Code:
su   #and enter the password
gedit /boot/grub/menu.lst        #text-editor opens up with read-write rights to the file
exit    #after you saved the file and exited gedit

I hope it helped.
Animal
Nyizsa wrote:
I hope it helped.


It did - thanks again!!

Very Happy
corey
Maybe this advice is too late, but....

I'm bolding this not to be rude, but so that this will be seen.

One nice (and some say annoying) thing about Ubuntu/Kubuntu, is that its set up so you never ever have to be root to do administrative things.

Here's how you admin your system:

Type your own password when it asks for one. That's it! Very Happy

Ubuntu uses
Code:
sudo
to achieve the same things that
Code:
su
does, but with more security and safety, so you, as user can admin your system.

Oh, BTW, you can do anything you would have done at the command promt as well by typing
Code:
sudo (command)
. This method just means that you're root only for that one command, like
Code:
su -c "(command) (whatever)"
Related topics
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.