FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


help with phpBB (chinese characters)





engeland
Can someone tell me how can i get my phpBB forum to read chinese characters?

well i have members on the forum who do insert chinese characters in their posts but it comes out as symbols

how do i make it show? Confused
Loathing in Fear
I don't know an answer for that, maybe you could ask for help at the phpBB community. I'm sure they will know what to do.
n0obie4life
The encoding used needs to be correct Wink.

UTF-8 if I remembered correctly.
engeland
encoding?
and how do i change that?
n0obie4life
Depends on the program you used to type in Chinese..Wink
wumingsden
I suggest first trying this before getting too involved in kinds of software:

Type in ideograms (any kind of Chinese)
Does it look weird? If so (based on IE) - do the following...

Click the "view" button in your browser
Then "encoding"
Then "More"
Then your language (i.e Chinese Simp or Trad).
This problem should now be solved.
engeland
what about for firefox?

it didnt work with the IE Confused
wumingsden
Could you give me the URL of the forum that you need help with? It would be much easier if I saw the problem with my own eyes. Also is a Chinese-Simp language pack installed on the forum? One other problem is that the computer might not understand the language, has that got the language packs installed too? (They usually come with the computer but YOU have to install it yourself).

In the meantime go here: www.alkutob-jordan.frih.net As you can see some is in Symbols and some in English. The solution that I gave above works on this, only you have to use Arabic whereas forum langauge packs automatically display the correct language symbols like here: http://www.alkutob-jordan.frih.net/forum/ You'll also able to notice that in the browser bar at the top of the page it cannot read it which is why squares are shown.
bearr
i think you may first check if the web server support chinses.
toasterintheoven
do not do ajax with Chinese encoding (gb2312), it's a nightmare, I'm running into the problem where I can't override the mimetype, hopefully it's something else, but I've been stuck on the same issue forever. XDomainRequest is horrible for doing that, and XmlHttpRequest doesn't have a reliable SetRequestHeaders, and contentType is only available in IE8, cross-browser issues with chinese encoding is terribly stressful, if I could redo my current webpage, I'd go without ajax.
Related topics
Look at this
a good/freat forum!
Donutey, Version 3
Escape this room ?
php-nuke - Forum Help (phpbb)
LF2-one of the best of 2D fighting games
help.. phpbb conflict?
I believe characters are Japanese, but not sure
Any good tutorials out there to learn chinese?
Installing files for East Asian languages on XP Pro.
Why not Chinese?
What is eating my memory???
Chinese names
[-Help-] PHPBB Topic Icons
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.