FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


WordPress Glitch





pansophia
I just installed WordPress on my site, and I noticed a curious glitch. When I click "view site" in the WordPress control panel, it tries to go to index.htm (the FriHost default page) instead index.php (WordPress).

I tried to solve this by deleting index.htm. However, "view site" still goes to the same page - I suppose an error page is kicking.

I know at one time index.htm was necessary to prevent people from viewing my directories - is this still the case in an age of php-based sites? What do I do to make the server understand that index.php is my home page? Also, do I need to put index.htm back for security purposes?

I had this problem on another site (in that case, it was the index.php for PHP-Nuke not showing), and I can't remember how it was solved. The host might not have told me. If it's a server problem rather than my problem, I'd be grateful to know how it was fixed just to increase my own understanding.
Daniel15
Log in to your WordPress administration panel, and click on 'Options'. This will bring you to http://[yoursite].frih.net/wp-admin/options-general.php.

Check under both 'WordPress address (URI)' and 'Blog address (URI)' that index.htm is not mentioned. The only thing that should be in both boxes is your site address (eg. http://[yoursite].frih.net without a slash on the end)

That should work. If it doesn't, change both address fields to include 'index.php' at the end. Hopefully, that will work.
pansophia
It was already http://www.pansophia.frih.net. so I tried making it http://www.pansophia.frih.net/index.php.

This destroyed the formatting of the site!

And when I changed it back to http://www.pansophia.frih.net, the formatting is still destroyed. What should I do now?
n0obie4life
Dump this in the folder where you installed wordpress folder

in the file .htaccess

Code:
DirectoryIndex index.php


Smile

Note - I'm not liable for side effects that MAY happen but that seldom did. The MAY only happens when you use dumb programs like Frontpage.
pansophia
*cries*

I still haven't figured out how to fix this. Sad
pansophia
//in the file .htaccess //

I don't see a file called this - do I make it and put it on the top level? Also, I thought this was an apache file - is it kosher to have multiple .htaccess files? Sorry if that's a stupid question - I really don't know.
n0obie4life
I assume you have installed wordpress in the Directory called

/wordpress/ (prior to public_html)

In wordpress, create a new file called .htaccess if there isn't one and put in

Code:
DirectoryIndex index.php
pansophia
Actually I installed it all straight into public_html - not in a separate wordpress folder. Could this be causing all the problems?
n0obie4life
No.

Then, create the .htaccess file in the public_html folder Wink
pansophia
I've added the .htaccess file, but the site is still messed up. It's like it's not reading the stylesheet at all.
pansophia
Also, for some reason I can't get the admin panel back. :-/
n0obie4life
Remove that .htaccess file Surprised

Okay. In your wordpress config...

General -
WordPress address (URI) - http://<domain>
Blog address (URI) - http://<domain>
pansophia
Now the .htaccess file isn't there! Did a server admin remove it?

Also - this is how it was before:
WordPress address (URI) - http://<domain>
Blog address (URI) - http://<domain>

I changed it to:
WordPress address (URI) - http://<domain>/index.php
Blog address (URI) - http://<domain>/index.php

This broke the site, so I tried to change it back to:
WordPress address (URI) - http://<domain>
Blog address (URI) - http://<domain>

This should be how it is now, but I can't tell because I can't get into the control panel for WordPress. :-/
n0obie4life
You arne't support to add the index.php

Go to cpanel --> filemanager and you can see ur .htaccess file.
pansophia
Ok, .htaccess was there, and I deleted it. Curious that it doesn't show in FTP.

Any idea how I can undo the damage from adding index.php? I can't even get into the WordPress config panel.
n0obie4life
Go to phpmyadmin, then go modify the values.
pansophia
Yay! That worked! Thanks!
pansophia
Very strangely, the original problem with index.htm is also now fixed. Did .htaccess do that?

I'm not sure if this is related, but none of the links in the header area work. I just get a # sign at the end of the url like the code is looking for a target. Maybe it just doesn't work in Firefox?
n0obie4life
Yes. .htaccess most likely did something Wink.

To fix those links, you have to go into the wordpress control panel, options, permalinks. Read through that Wink.
pansophia
Ok, reading.

It looks like .htaccess will strike again!
n0obie4life
Yeah, permalinks dumps .htaccess files Very Happy
pansophia
I added a permalink structure and added the .htaccess file, but the links at the top still don't work.

I don't see anything in the WordPress documentation on Permalinks that looks like this issue, either. I'm trying to find the problem in the WordPress troubleshooting, but I'm not coming up with the right keywords. I'm trying "header links don't work", "links troubleshooting", etc. Is there another way to say this.

For example, here's the URI when I click Contact:
http://www.pansophia.frih.net/#

The other links are just throwing in the # at the end of the URI, too.
n0obie4life
http://bondings-world.frihost.net/ <-- my wordpress blog.

Code:
/%day%/%monthnum%/%year%/%post_id%.bondings


that's my structure.

I'm not really good with wordpress, so maybe giving you my settings would work Wink.

Also, it could be the skin that's doing weird stuff (ie, hardcoded links that you have to modify yourself).
pansophia
Darn - even stealing your settings doesn't work.

In the mean time, I found out that the Permalink for the posting itself doesn't work - it took out the comment, too. I guess I have some Permalink reading cut for me tomorrow. Enough banging my head on the piano keys for tonight!

Thanks for your help. It was a great relief to just unbreak the site.
Related topics
glitch in cpanel?
Skinning Wordpress
wordpress problem
wordpress problem :( need help.. :(
Help with WordPress
http://irish.frihost.net/wordpress
switching from blogger to wordpress
Thinking of change
Admin Themes in Wordpress. What's on your Dashboard?
Admin Themes in Wordpress. What's on your Dashboard?
Is There a WordPress Expert in the House?
K2 Theme for Wordpress
WordPress 2.0
Deleting a Wordpress account?
Reply to topic    Frihost Forum Index -> Support and Web Hosting -> Web Hosting Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.