FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Fedora Core 5 Test 1 Review





desertwind
Fedora Core 5 Test 1 Review

Note Before:
1. This is a desktop user review. No indepth features/bugs are examined.
2. Has worked on this distro for only a few hours. So this not a complete one.


System Config
AMD Athlon XP 2200+ Processor
ASUS A7NVM266 Motherboard
160 GB Seagate Baraccuda 7200 RPM HDD
80 GB Seagate Baraccuda 7200 RPM HDD
nVidia Geforce2 MX 32 MB integrated Video Card
512x2 DDR333 MHz RAM

Installation

So, I downloaded the 6 iso's (5 Installation iso and one network boot iso). I really didn't want to waste 5 cd's for a test distribution. So i burnt the boot.iso into my RW, and decided to go for a hard disc install.

After restart, i booted with the boot cd, selected the installation type, entered the path to iso's, and waited. Alas! I got a valuable piece of information. Anaconda is under some serious changes. Hard disc installation is not supported for the time being.

Booted back into FC4, burnt all 5 cds, ready for a new start. Selected text install now.

SATA is supported natively now. After the usual Media Check and all, The installation screen appeared, and it appeared nasty. All the text seems to be garbled.

Reboot, Graphical install now.

The graphical installer pops up. On pressing next, RedHat advised me not to install this. I clicked "Install Anyway".

After the Language and Keyboard selection, it took directly into the partition screen. No searching for previous installations, No install/upgrade options, and no installation type (workstation/server/personal/custom) selection screens. And the partition screen looks a bit strange for me. It provided four options before me.

1. Remove all partitions
2. Remove all linux partitions
3. Use free space in disk
4. Custom partitioning

I selected custom, for I don't want to disturb my current distro. Next partitioning screen was pretty familiar.

After that te usual Network setup, Time Zone Selection and root password. Firewall/SELinux configuration screens seems to be dissappeared. Now i'm into the package selection screen.

I was dissappointed! This was one of the most worst package selections i've ever seen. This seems to be very basic. It provided me with some groups of packages, which can be selected. No individual package selection and customization at all. The groups are

admin-tools
authoring-and-publishing
base-x*
development-tools
dns-server
eclipse
engineering-and-scientific
ftp-server
games*
gnome-desktop*
gnome-software-development
graphical-internet*
graphics*
java-development
language-support
legacy-network-services
legacy-software-development
mail-server
mysql
network-server
news-server
office*
printing*
server-cfg
smb-server
sound-and-video*
sql-server
system-tools
text-internet*
web-server
x-software-development

of which the starred one's are selected by default. I decided to go with the default selection, additionaly selecting system-tools after the failure of a full installation attempt. (I'll be trying a full installation once again to figure out the error). Clicking next took me to a "Checking for dependancies" dialog, which really checks in detail ! It took about 5 minutes. Installation took about 25 minutes.

Rebooted in anxiety....

Booting

GRUB greeted me with the same old Blue GRUB screen. After starting the usual services The first boot configuration screen appears. Early login is not implemented yet, and the rhgb (RedHat Graphical Boot) seems to be the same old one. The Firewall and SELinux configuration is now a part of firstboot. My sound card is detected, but twice. It shows the same card twice. I selected the default one, as it worked. So the old, blue, login screen again.

Desktop

The first thing I noticed was the same old dark wallpaper. I suggest them to use some light shades for a default wallpaper. Some noticable changes striked me on a first look on the desktop.

1. The new f logo instead of the Hat.
2. No RHN-Applet (Thank GOD! at last...)
3. A new cool 3d animation instead of the old Hour Glass for mouse pointer.

I tried to caoture a screenshot by pressing the PrintScreen key, but nothing happened. I checked with the configuration, but pressing the PrintScreen doesn't seems to work. Atlast i decided to change the Hotkey for Screenshot to F12, which worked.

So Here's the Desktop.



Applications

FC5 test 1 use the latest versions of several softwares like

Kernel 2.6.14
GNOME 2.12.1
Firefox Deer Park
OOo 2.0


Have a Look.



One of the most important feature of new GNOME 2.12 is that it hold the clipboard contents even if the application is closed.

Nautilus

Nautilus still uses the spatial view (which is a real trouble and mess for me) as default. The first thing i've done is to change it to the browser view. The path can't be entered manually now. (There must be some tweak for this). It now show "Places" instead of "Information" by default in the Side Panel.

Have a look.



Multimedia

Arghh!! Still no complete multimedia support. mp3/mpeg/wmv/avi etc are not supported natively. Even if a little trick will do for that, supporting them by default will draw more n00b users to gnu/linux. Hope patend issues will be resolved soon (Or the whole world uses Ogg format).

Totem crashed everytime i open it. So no use of that. Helix player is not able to play a single format, not even rm, so no use of that too. Rhythmbox supports only ogg for the time being. But i notice two changes in Rhythmbox.

1. The Error messages for detecting mp3 has been changed. Early it was something like "Unsupported format", but it shows "The file is not an audio stream".

2. Clicking the close (x) button minimises to the panel. For quitting the application, either I've to go through Music>Quit or by right clicking the panel icon, then quit.

gthumb now opens the Image view directly instead of the browser view, when opening an image.

Firefox

One noticable thing about Fx Deer Park is that it crashed everytime i cliked a Menu Entry. And tooks too much time to load.

File Roller

The archive manager goes back to old mode. Now "Extract Here" will extract all files into the current directory, instead of creating a new archivename.zip_Files directory. But still nor rar archive support.

System Monitor

System Monitor is now divided into three tabs against the old two. Devices is now a new tab along with Process and Resources.

Personal File Sharing & Remote Desktop

Some new additions to the Preferences are "Personal File Sharing" which has an option to share all public files over the network, with/without password protection and "Remote Desktop" which allows user to connect from/to this desktop remotely.

Add/Remove Package

Selecting this show me a message that "/media/cdrecorder seems not be a valid installation source". So i inserted the first installation disc into the drive, mounted it and tried again. But it still shows the same message.

PUP - The Package UPdater

This one of the most featured change in FC5. PUP, the Package UPdater is the replacement for the troublesome old RHN Updater. This is absed on yum and the interface seems to be very basic, and cleans. No options other than simple "select and update" is available. The first time I started it, it simply quit without any warning. But when I started it after connecting to the internet, I just worked fine. Hope that more options will be added to this one.



Conclusion

Although it seems a lot similar to its ancestor, FC4, there are signs of lot of changes. Many core applications like anaconda, package updater etc, are under serious change. Several applications are to be included and several to be excluded.

Anyway, End Users are not advised to install this test release on their machines, as there is a possibliity for a lot of bugs and security flaws. Wait for the final release till February, and I'm sure you'll get a rocking solid new Fedora!
ruff_ryder
Shocked
Didn't know FC5 was due yet. According to your review (which is nice, btw), it looks very promising. I used FC4 for a while, and let's say I have a solid reason for installing FC5. When the final version comes out, of course.
Related topics
Help : Fedora Core 4 + Ubuntu
Fedora Core 5 Test 1 Released
Which linux is the best for a new user?
Linux
Which Linux distribution is the best?
Problem with linux fedora core 4
Problem with linux fedora core 4
Review: GNOME 2.14 (from Linux.com)
Fedora Core 5 Available
Fedora Core 5 Released
Fedora Core 5
Fedora 5 Freez
Help installing Fedora Core 6
Setting Up Php4 on Fedora Core 5
Reply to topic    Frihost Forum Index -> Computers -> Software

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.