FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


[gnu/Linux] ALSA Error on Rhythmbox





desertwind
Off late i'm getting an error when i try to play something on rhythmbox. The error occurs only once per a rhythmbox session. The Error reads as ( Actually it is two error mesages)

Quote:
ALSA device "default" had an error.


and

Quote:
Could not pause playback
wumingsden
Was it newly installed and did you upgrade via freshrpm's apt/synaptic ?
I recommend uninstalling then installing again.

Or, I got this from the web, it may help you:


Quote:

>Number: 56368
>Category: ports
>Synopsis: patch: audio/rhythmbox small fix for build-error WITH_XINE=yes
>Confidential: no
>Severity: non-critical
>Priority: low
>Responsible: freebsd-ports-bugs
>State: open
>Quarter:
>Keywords:
>Date-Required:
>Class: update
>Submitter-Id: current-users
>Arrival-Date: Wed Sep 03 05:50:12 PDT 2003
>Closed-Date:
>Last-Modified:
>Originator: Frank Ruell
>Release: FreeBSD 5.1-RELEASE-p2 i386
>Organization:
>Environment:
System: FreeBSD dreamwarrior.foobar.ath.cx 5.1-RELEASE-p2 FreeBSD 5.1-RELEASE-p2 #0: Wed Aug 20 18:32:14 CEST 2003 stoerte at dreamwarrior.foobar.ath.cx:/usr/obj/usr/src/sys/Dreamwarrior i386


>Description:
the build fails WITH_XINE=yes, add a check if we have XINE_CLOSE to make it build again. Fix pulled from CVS.
>How-To-Repeat:
>Fix:
--- rhythmbox-0.5.2_2.patch begins here ---
diff -ruN rhythmbox.orig/Makefile rhythmbox/Makefile
--- rhythmbox.orig/Makefile Wed Sep 3 14:14:40 2003
+++ rhythmbox/Makefile Wed Sep 3 14:45:24 2003
@@ -7,7 +7,7 @@

PORTNAME= rhythmbox
PORTVERSION= 0.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.5
diff -ruN rhythmbox.orig/files/patch-monkey-media-player-xine.c rhythmbox/files/patch-monkey-media-player-xine.c
--- rhythmbox.orig/files/patch-monkey-media-player-xine.c Thu Jan 1 01:00:00 1970
+++ rhythmbox/files/patch-monkey-media-player-xine.c Wed Sep 3 14:33:39 2003
@@ -0,0 +1,13 @@
+--- monkey-media/monkey-media-player-xine.c.orig Wed Sep 3 14:30:52 2003
++++ monkey-media/monkey-media-player-xine.c Wed Sep 3 14:32:41 2003
+@@ -520,8 +520,10 @@
+ if (xine_get_param (mp->priv->stream, XINE_PARAM_SPEED) == XINE_SPEED_NORMAL)
+ xine_set_param (mp->priv->stream, XINE_PARAM_SPEED, XINE_SPEED_PAUSE);
+
++#ifdef HAVE_XINE_CLOSE
+ /* Close the audio device when on pause */
+ xine_set_param (mp->priv->stream, XINE_PARAM_AUDIO_CLOSE_DEVICE, 1);
++#endif
+ }
+
+ mp->priv->timer_add += floor (g_timer_elapsed (mp->priv->timer, NULL) + 0.5);

--- rhythmbox-0.5.2_2.patch ends here ---



>Release-Note:
>Audit-Trail:
>Unformatted:
desertwind
Thanks a lot dude. That helped.

Yes, i had upgraded alsa- rpms using yum.

I uninstalled it and installed it again. Problem Solved.

Thanks once again.
wumingsden
Glad I could be of service, Very Happy
Related topics
Reply to topic    Frihost Forum Index -> Computers -> Computer Problems and Support

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.