FRIHOST FORUMS SEARCH FAQ TOS BLOGS COMPETITIONS
You are invited to Log in or Register a free Frihost Account!


Visit My Raspberry PI Zero W





Possum
Hi

I'm just set up a Forum on my Raspberry PI Zero W. Just to see if I could do it.

If you have nothing to do, pop over and make a post. Only the Open Forum is open to anyone to post on.


The URL is a static IP address.

http://210.54.35.249/forums/viewforum.php?f=13&sid=cf419f32c6cc8c2f3377383942980d88


I must say I am amazed at what the Pi Zero can do.

If you see any thing I am doing wrong please let me know....
jestoy0514
Hi I am not been able to access the url you have given. I assume you were using the pi on your house. May be you dont have the permission from the isp to host your own site in your internet package. I don't have that much experience with hosting so what I said might not be true.
andy26
Yep i get nothing are you forwarding port 80 & 8080 to the correct IP?
SonLight
It's working now for me. Amazing how you can do so much for so little expense.

I noticed I get a directory listing when I went to the site home page. I would recommend turning that off, so you get a 404 error for any page not coded. You might want to forward home to forum, or put up a static home page. Also if you have other things you're testing on the server, you might want to put them at a non-standard url until they are ready for the public.

No forum should be served from a non-encrypted site these days (Frihost, I'm looking at you). I would recommend getting a certificate and serving over https. Perhaps not only https for now, but no one should log on over http.
Possum
thx everyone

Its was my first try. All done a PI Zero W

Yes I need to and will follow your advice SonLight. Cheers for that.

Sorry to those who went to my PI and it was down. I opened up a port on my router and didn't want my other computers on the network during the test.

Its off for now until I get my security correct.
andy26
Oh sweet i didn't realise it was on a pi zero thats cool i might get one to try i have a home light controller running off a raspberry pi 3.

Also just noticed its you i saw posting out the questions about stopping the file list showing.

again and definitely because its a pi zero your running use nginx instead of apache it uses less ram and runs a lot faster on smaller devices such as the pi.
andy26
SonLight wrote:
It's working now for me. Amazing how you can do so much for so little expense.

I noticed I get a directory listing when I went to the site home page. I would recommend turning that off, so you get a 404 error for any page not coded. You might want to forward home to forum, or put up a static home page. Also if you have other things you're testing on the server, you might want to put them at a non-standard url until they are ready for the public.

No forum should be served from a non-encrypted site these days (Frihost, I'm looking at you). I would recommend getting a certificate and serving over https. Perhaps not only https for now, but no one should log on over http.


Lol i was thinking the same the other day about frihost not running ssl and how it really really should.
deanhills
Looks as though it's working, well done Possum! Cool

Also thank you to andy26 for contributing this tutorial:
https://www.pestmeester.nl/
Related topics
Humor :)
Gry przez siec
[OFFICIAL] Bleach - No more new threads about this
JOOMLA
Praca za granica
Zawsze wiemy co powiedziec...
Za 5 lat koniec swiata!!!!!
Bezsenne noce
Gizmo that turns TV to PC
Raspberry Pi
Did you get a Raspberry Pi
Raspberry Pi and Anime
Higgs boson found?
Custom Operating System in C#, C++, or Java
What do you use your Raspberry Pi for?
Reply to topic    Frihost Forum Index -> Computers -> Hardware and Electronics

FRIHOST HOME | FAQ | TOS | ABOUT US | CONTACT US | SITE MAP
© 2005-2011 Frihost, forums powered by phpBB.